libflann1.9_1.9.1+dfsg-2_i386.deb


Advertisement

Description

libflann1.9 - Fast Library for Approximate Nearest Neighbors - runtime

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libflann1.9_1.9.1+dfsg-2_i386.deb
Package name libflann1.9
Package version 1.9.1+dfsg
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 647.62 KB
Installed size 5.12 MB
FLANN is a library for performing fast approximate nearest neighbor searches
in high dimensional spaces. It contains a collection of algorithms found
to work best for nearest neighbor search and a system for automatically
choosing the best algorithm and optimum parameters depending on the dataset.
This package contains the libraries needed to run FLANN applications.

Alternatives

Package Version Architecture Repository
libflann1.9_1.9.1+dfsg-2_amd64.deb 1.9.1+dfsg amd64 Debian Main
libflann1.9 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libgomp1 >= 4.9
libstdc++6 >= 5.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libflann1.9_1.9.1+dfsg-2_i386.deb
Source Package flann

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libflann1.9 deb package:
    # sudo apt-get install libflann1.9

Files

Path
/usr/lib/i386-linux-gnu/libflann.so.1.9
/usr/lib/i386-linux-gnu/libflann.so.1.9.1
/usr/lib/i386-linux-gnu/libflann_cpp.so.1.9
/usr/lib/i386-linux-gnu/libflann_cpp.so.1.9.1
/usr/share/doc/libflann1.9/changelog.Debian.gz
/usr/share/doc/libflann1.9/changelog.gz
/usr/share/doc/libflann1.9/copyright

Changelog

2016-08-18 - Jochen Sprickerhof <jspricke@debian.org>
flann (1.9.1+dfsg-2) unstable; urgency=medium
* Upload to unstable
* New ABI version. Closes: #797718)
2016-08-13 - Leopold Palomo-Avellaneda <leo@alaxarxa.net>
flann (1.9.1+dfsg-1) experimental; urgency=medium
* Added BUILD tests
* Update watch file to add dfsg suffix
* Imported Upstream version 1.9.1+dfsg
* Added myself as uploader
* Updated to new VCS fields
* Removed unneeded patch. Move to CMake option
* Updated patches
* Set LIB_SUFFIX with DEB_HOST_MULTIARCH
* Update copyright
* Bumped Standards-Version to 3.9.8. No changes
2016-07-30 - Andreas Metzler <ametzler@debian.org>
flann (1.8.4-4.2) unstable; urgency=medium
* Non-maintainer upload.
* 20_abs-std-abs.patch: 3645f0c30a47267e56e5acdecfc7bac2b76bc3d5 from
upstream GIT. Use std::abs instead of abs, fixing gcc6 build error.
Closes: #822717
2014-08-06 - Gilles Filippini <pini@debian.org>
flann (1.8.4-4.1) unstable; urgency=medium
* Non-maintainer upload.
* New patch fix-cmake-hdf5.patch to support hdf5 1.8.13 new packaging
layout (closes: #756471).
2014-06-17 - Mathieu Malaterre <malat@debian.org>
flann (1.8.4-4) unstable; urgency=low
* Bump Std-Vers to 3.9.5, no changes needed. Run w-a-s for cleanup.
* Use the ggc-min-expand flag.
Patch by Dejan Latinovic <Dejan.Latinovic@imgtec.com>.
Closes: #751478.
2013-12-08 - Mathieu Malaterre <malat@debian.org>
flann (1.8.4-3) unstable; urgency=low
* Do not use CMAKE_BUILD_TYPE. Closes: #731514
2013-05-14 - Mathieu Malaterre <malat@debian.org>
flann (1.8.4-2) unstable; urgency=low
* Upload to sid. Closes: #707702
2013-01-19 - Mathieu Malaterre <malat@debian.org>
flann (1.8.4-1) experimental; urgency=low
* New upstream. Fix memleak
2013-01-03 - Mathieu Malaterre <malat@debian.org>
flann (1.8.3-1) experimental; urgency=low
* New upstream
* Switch from tbb to OpenMP
* Remove hack to get Changelog from web, use upstream instead
* Remove Breaks/Replace, not needed anymore
* Bump Std-Vers to 3.9.4, no changes needed
* remove patch not needed anymore:
- debian/patches/remove_lib64.patch
* Remove obsolete DMUA flag
* Use multiarch lib path
2012-06-03 - Mathieu Malaterre <malat@debian.org>
flann (1.7.1-4) unstable; urgency=low
* enable the libhdf5-mpi-dev build dependency on hurd. Closes: #673513
* Fix hardening switch to compat 9

See Also

Package Description
libflatpak-dev_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps (development)
libflatpak-doc_0.8.9-0+deb9u3_all.deb Application deployment framework for desktop apps (documentation)
libflatpak0_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps (library)
libflatzebra-0.1-2v5_0.1.6-4_i386.deb Generic Game Engine library
libflatzebra-dev_0.1.6-4_i386.deb Generic Game Engine library development files
libflexdock-java-demo_1.2.4-1_all.deb Swing Java docking framework - demos and examples
libflexdock-java-doc_1.2.4-1_all.deb Swing Java docking framework - demos and examples
libflexdock-java_1.2.4-1_all.deb Swing Java docking framework
libflext-pd0_0.6.0+git20161101.1.01318a94-2_i386.deb Flext C++ external layer for Pd
libflickcurl-dev_1.26-2+deb9u1_i386.deb C library for accessing the Flickr API - development files
libflickcurl0_1.26-2+deb9u1_i386.deb C library for accessing the Flickr API
libflickr-api-perl_1.28-1_all.deb Perl interface to the Flickr API
libflickr-upload-perl_1.60-1_all.deb module for uploading images to flickr.com
libflightcrew-dev_0.7.2+dfsg-9_all.deb C++ library development filesfor epub validation
libflightcrew0v5_0.7.2+dfsg-9_i386.deb C++ library for epub validation
Advertisement
Advertisement