libfftw3-long3_3.3.5-3_i386.deb


Advertisement

Description

libfftw3-long3 - Library for computing Fast Fourier Transforms - Long precision

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libfftw3-long3_3.3.5-3_i386.deb
Package name libfftw3-long3
Package version 3.3.5
Package release 3
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://fftw.org
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 312.71 KB
Installed size 994.00 KB
The FFTW library computes Fast Fourier Transforms (FFT) in one or more
dimensions. It is extremely fast. This package contains the shared library
for long double precision transforms.
To get the static library and the header files, you need to install
libfftw3-dev. For documentation, see libfftw3-doc.

Alternatives

Package Version Architecture Repository
libfftw3-long3_3.3.5-3_amd64.deb 3.3.5 amd64 Debian Main
libfftw3-long3 - - -

Requires

Name Value
libc6 >= 2.4
libgomp1 >= 4.9

Replaces

Name Value
libfftw3-3 << 3.3.3-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libfftw3-long3_3.3.5-3_i386.deb
Source Package fftw3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfftw3-long3 deb package:
    # sudo apt-get install libfftw3-long3

Files

Path
/usr/lib/i386-linux-gnu/libfftw3l.so.3
/usr/lib/i386-linux-gnu/libfftw3l.so.3.5.5
/usr/lib/i386-linux-gnu/libfftw3l_omp.so.3
/usr/lib/i386-linux-gnu/libfftw3l_omp.so.3.5.5
/usr/lib/i386-linux-gnu/libfftw3l_threads.so.3
/usr/lib/i386-linux-gnu/libfftw3l_threads.so.3.5.5
/usr/share/doc/libfftw3-long3/NEWS.gz
/usr/share/doc/libfftw3-long3/README
/usr/share/doc/libfftw3-long3/README.Debian
/usr/share/doc/libfftw3-long3/changelog.Debian.gz
/usr/share/doc/libfftw3-long3/copyright

Changelog

2017-01-06 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.5-3) unstable; urgency=medium
* fix typo in shlibs file of last upload
2017-01-06 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.5-2) unstable; urgency=medium
* add stricter shlib dependencies for partial upgrades (Closes: #849593)
* mark libfft3-mpi-dev m-a same and libfftw3-doc m-a foreign
2016-10-03 - Ghislain Antony Vaillant <ghisvail@gmail.com>
fftw3 (3.3.5-1) unstable; urgency=medium
* New upstream version 3.3.5
* Update patch fix-runtime-neon-detection.patch.
* Remove superfluous occurrences of ${shlibs:Depends}.
* Insert multiarch support via ${misc:Pre-Depends}.
* Add missing configure step in build-indep. (Closes: #806616)
* Remove XS-Testsuite field, no longer required.
* Use current canonical VCS URIs.
* Bump standards version to 3.9.8, no changes required.
2014-11-23 - S├ębastien Villemot <sebastien@debian.org>
fftw3 (3.3.4-2) unstable; urgency=medium
* Team upload.
* fix-runtime-neon-detection.patch: new patch, fixes runtime NEON
detection on armhf (and also arm64, but NEON is currently
unconditionnally disabled there). Thanks to Edmund Grimley Evans for
the patch. (Closes: #767138)
2014-10-11 - YunQiang Su <syq@debian.org>
fftw3 (3.3.4-1.1) unstable; urgency=low
* Add mips64(el), ppc64el and arm64 to the list with long double support.
(Closes: #763007)
2014-03-16 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.4-1) unstable; urgency=medium
* New upstream release (Closes: #741851)
- all patches applied upstream
* add autopkgtest depend on build-essential (Closes: #740095)
* Bump to standards 3.9.5, no changes required
* suggest libfftw3-doc in -dev packages (Closes: #735541)
* increase debian/compat to 9 and make -dbg package Multi-Arch: same
* disable neon support on arm64, crashes currently available gcc 4.8.2
2013-10-27 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.3-7) unstable; urgency=low
* restrict architectures of long dependency of libfftw3-3 (Closes: #710890)
* enable runtime detected sse2 and avx on x32
* enable long and quad precision on x32
2013-10-26 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.3-6) unstable; urgency=low
* wisdom-manpage.patch: fix wrong example in manpage
* make transitional libfftw3-3 depend on libfftw3-long3 for compatibility
with unpackaged software (Closes: #710890)
* fix-fftw-wisdom-to-conf.patch: fix tool not accepting wisdom files
* add autopkgtests for tools and basic usage
* enable runtime detected neon support for arm64
2013-05-22 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.3-5) unstable; urgency=low
* stop building quad library on ia64, really Closes: #709168
2013-05-21 - Julian Taylor <jtaylor.debian@googlemail.com>
fftw3 (3.3.3-4) unstable; urgency=low
* texinfo5-compat.patch: fix ftbfs with texinfo5
* add generated html files to extended-diff-ignore
* build depend and use gcc-4.8 on ia64, fixes ICE in quad (Closes: #709168)

See Also

Package Description
libfftw3-mpi-dev_3.3.5-3_i386.deb MPI Library for computing Fast Fourier Transforms - development
libfftw3-mpi3_3.3.5-3_i386.deb MPI Library for computing Fast Fourier Transforms
libfftw3-quad3_3.3.5-3_i386.deb Library for computing Fast Fourier Transforms - Quad precision
libfftw3-single3_3.3.5-3_i386.deb Library for computing Fast Fourier Transforms - Single precision
libfgetdata5_0.9.4-1+b2_i386.deb library to read/write dirfile data - Fortran 77 bindings
libfield3d-dev_1.7.2-1+b2_i386.deb development files for Field3D
libfield3d1.7_1.7.2-1+b2_i386.deb library for storing voxel data on disk and in memory
libfieldslib-ocaml-dev_113.33.03-2_i386.deb OCaml syntax extension that enables folding over record fields (dev files)
libfieldslib-ocaml_113.33.03-2_i386.deb OCaml syntax extension that enables folding over record fields (runtime files)
libfifechan-dev_0.1.3-3_i386.deb development files for the GUI library Fifechan
libfifechan0.1.3_0.1.3-3_i386.deb lightweight cross platform GUI library written in C++
libfile-basedir-perl_0.07-1_all.deb Perl module to use the freedesktop basedir specification
libfile-bom-perl_0.15-1_all.deb Perl module for handling Byte Order Marks
libfile-cache-perl_0.16-13_all.deb File::Cache, a filesystem-based object store
libfile-changenotify-perl_0.26-1_all.deb module to monitor files for changes
Advertisement
Advertisement