libfauhdli-dev_20130704-1.1_i386.deb


Advertisement

Description

libfauhdli-dev - interpreter library and development files for fauhdli

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libfauhdli-dev_20130704-1.1_i386.deb
Package name libfauhdli-dev
Package version 20130704
Package release 1.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage -
License -
Maintainer FAUmachine Team <faumachine@potyra.de>
Download size 59.48 KB
Installed size 218.00 KB
This package contains the development files and the interpreter library
for fauhdlc's intermediate code interpreter fauhdli.
It is useful, if you want to make use of the foreign interface of VHDL
and define an own implementation for it.

Alternatives

Package Version Architecture Repository
libfauhdli-dev_20130704-1.1_amd64.deb 20130704 amd64 Debian Main
libfauhdli-dev - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libfauhdli-dev_20130704-1.1_i386.deb
Source Package fauhdlc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfauhdli-dev deb package:
    # sudo apt-get install libfauhdli-dev

Files

Path
/usr/include/basetypes.h
/usr/include/fauhdli.h
/usr/lib/libfauhdli.a
/usr/lib/libfauhdlk.a
/usr/share/doc/libfauhdli-dev/changelog.Debian.gz
/usr/share/doc/libfauhdli-dev/changelog.gz
/usr/share/doc/libfauhdli-dev/copyright
/usr/share/doc/libfauhdli-dev/intermediate_code.txt.gz

Changelog

2017-01-17 - Adrian Bunk <bunk@debian.org>
fauhdlc (20130704-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Switch to working maintainer address.
* Remove the obsolete DM-Upload-Allowed.
* Add libfl-dev to the build dependencies. (Closes: #846422)
* Add FTBFS fix from Stefan Potyra. (Closes: #835106)
2013-07-03 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20130704-1) unstable; urgency=low
* New upstream bugfix release:
Fix build failures with gcc-4.8 and new bison version
(Closes: #710626).
* debian/control: Update standards-version to 3.9.4 (no further changes
necessary).
2012-07-07 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20120707-1) unstable; urgency=low
* New upstream bugfix release: Use allocator/deallocator callbacks
consistently.
* debian/control:
+ Update Standards-Version to 3.9.3, no other changes necessary.
* debian/rules: Add build-indep target and build-arch target.
2011-08-12 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20110812-1) unstable; urgency=low
* New upstream release. Attention: ABI of the intermediate code changed.
* debian/control: Upgrade standards-version to 3.9.2, no changes needed.
* debian/source/format: Switch to 3.0 (quilt).
* debian/rules: Pass --disable-Werror to configure flags 
(Closes: #615673, #625333).
2010-03-25 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20100325-1) unstable; urgency=low
* New upstream version: Fixes FTBFS on sparc et al (Closes: #575398).
2010-03-24 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20100324-1) unstable; urgency=low
* New upstream version.
* debian/rules: Fix inverted nocheck logic. 
* debian/control: Bump Standards-Version, no changes needed.
* debian/control: Add ${misc:Depends} to libfauhdli-dev.
* debian/copyright: Update years of copyright.
* debian/source/format: explicitly select 1.0.
2009-11-19 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20091119-1) unstable; urgency=low
* New upstream release, hightlights:
+ Foreign API completely rewritten.
+ Link correctly against garbage collector library. (Closes: #554277).
+ Speed improvements in type resolution.
* debian/rules: Also install upstream changelog.
2009-09-22 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20090922-1) unstable; urgency=low
* New upstream release, highlights:
+ Support for downto arrays.
+ Resolution function are supported now.
+ Concurrent conditional signal assignments are handled.
* debian/control: 
+ Add DM-Upload-Allowed: yes.
+ Bump standards-version to 3.8.3 (see below).
* debian/rules:
+ support parallel builds
+ don't run tests if nocheck is in DEB_BUILD_OPTS.
2009-05-12 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20090512-1) unstable; urgency=low
* New upstream release, highlights:
+ rework usage of virtual registers
+ better support of generic map aspects
+ foreign interface API changed to better handle foreign generics
+ support building with gcc-4.4 (Closes: #525716)
2009-03-09 - Stefan Potyra <sistpoty@ubuntu.com>
fauhdlc (20090309-1) unstable; urgency=low
* New upstream bugfix release:
+ fixes build failures on unstable, Closes: #518776.
* debian/rules: don't set prefix to debian/tmp, but rather use 
DESTDIR to make install, so that std_logic_1164.vhdl is found.
* debian/fauhdlc.install install std_logic_1164.vhdl in fauhdlc 
package as well.
* debian/copyright: Refer to legal entities as copyright holders
rather than using the term FAUmachine Team.

See Also

Package Description
libfax-hylafax-client-perl_1.02-2_all.deb simple Perl client for HylaFAX fax server
libfbclient2_3.0.1.32609.ds4-14_i386.deb Firebird client library
libfccp-dev_0.0+git20160525~9bf299c-1_all.deb Fast C++ CSV Parser
libfcgi-bin_2.4.0-8.4+b1_i386.deb FastCGI bridge from CGI
libfcgi-dev_2.4.0-8.4+b1_i386.deb Header files of FastCGI
libfcgi-perl_0.78-2_i386.deb helper module for FastCGI
libfcgi-procmanager-maxrequests-perl_0.2-1_all.deb restrict max number of requests by each child
libfcgi-procmanager-perl_0.25-1_all.deb Perl module to help manage FastCGI applications
libfcgi0ldbl_2.4.0-8.4+b1_i386.deb Shared library of FastCGI
libfcitx-config4_4.2.9.1-6_i386.deb Flexible Input Method Framework - configuration support library
libfcitx-core0_4.2.9.1-6_i386.deb Flexible Input Method Framework - library of core funtions
libfcitx-gclient0_4.2.9.1-6_i386.deb Flexible Input Method Framework - D-Bus client library for Glib
libfcitx-qt0_4.2.9.1-6_i386.deb Flexible Input Method Framework - Meta package for Qt library
libfcitx-qt5-1_1.0.5-1+b1_i386.deb Free Chinese Input Toy of X - D-Bus client libraries for Qt5
libfcitx-qt5-dev_1.0.5-1+b1_i386.deb Free Chinese Input Toy of X - Devel files for libfcitx-qt5
Advertisement
Advertisement