libexcalibur-logkit-java_2.0-11_all.deb


Advertisement

Description

libexcalibur-logkit-java - Lightweight and fast designed logging toolkit for Java

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libexcalibur-logkit-java_2.0-11_all.deb
Package name libexcalibur-logkit-java
Package version 2.0
Package release 11
Package architecture all
Package type deb
Category java
Homepage http://excalibur.apache.org
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 74.38 KB
Installed size 132.00 KB
Excalibur Logkit (previously avalon logkit) is a lightweight, fast, securely
designed logging toolkit. It is designed to integrate into existing
applications. Logkit is more lightweight than Log4j.
This package contains the library jar.

Alternatives

Package Version Architecture Repository
libexcalibur-logkit-java_2.0-11_all.deb 2.0 all Debian Main
libexcalibur-logkit-java - - -

Conflicts

Name Value
liblogkit-java -

Replaces

Name Value
liblogkit-java -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libexcalibur-logkit-java_2.0-11_all.deb
Source Package excalibur-logkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libexcalibur-logkit-java deb package:
    # sudo apt-get install libexcalibur-logkit-java

Files

Path
/usr/share/doc/libexcalibur-logkit-java/changelog.Debian.gz
/usr/share/doc/libexcalibur-logkit-java/copyright
/usr/share/java/excalibur-logkit.jar
/usr/share/java/logkit-2.0.jar
/usr/share/java/logkit.jar
/usr/share/maven-repo/logkit/logkit/2.0/logkit-2.0.jar
/usr/share/maven-repo/logkit/logkit/2.0/logkit-2.0.pom
/usr/share/maven-repo/logkit/logkit/debian/logkit-debian.jar
/usr/share/maven-repo/logkit/logkit/debian/logkit-debian.pom

Changelog

2014-10-22 - Emmanuel Bourg <ebourg@apache.org>
excalibur-logkit (2.0-11) unstable; urgency=medium
* debian/control:
- Updated the dependency on the Servlet API (3.0 -> 3.1)
- Depend on libmail-java instead of libgnumail-java
- Updated standards version to 3.9.6 (no changes)
- Use canonical URLs for the Vcs-* fields
* Switch to debhelper level 9
2013-04-28 - Emmanuel Bourg <ebourg@apache.org>
excalibur-logkit (2.0-10) unstable; urgency=low
* Team upload.
* Fixed the watch file
* Updated standards version to 3.9.4 (no changes)
* Updated the dependency on the Servlet API (2.5 -> 3.0)
* Removed the obsolete instructions in README.source for handling the patches
* debian/copyright: Updated the Format URI
* debian/rules: Added a clean target to allow rebuilds
2011-12-20 - Miguel Landaeta <miguel@miguel.cc>
excalibur-logkit (2.0-9) unstable; urgency=low
[ Miguel Landaeta ]
* Team upload.
[ James Page ]
* Fix FTBFS with OpenJDK7 (LP: #888124) (Closes: #652049):
- d/patches/01_implement_abstract_methods.patch: add additional 
unimplemented abstract methods for Java 7.
* d/copyright: tidied up misc lintian warnings.
2011-09-24 - Torsten Werner <twerner@debian.org>
excalibur-logkit (2.0-8) unstable; urgency=low
* Team upload.
* Add Conflicts and Provides for liblogkit-java to support upgrades from
oldstable. (Closes: #642742)
2011-09-16 - Torsten Werner <twerner@debian.org>
excalibur-logkit (2.0-7) unstable; urgency=low
* Team upload.
* Add a compatibility symlink excalibur-logkit.jar.
2011-09-15 - Torsten Werner <twerner@debian.org>
excalibur-logkit (2.0-6) unstable; urgency=low
* Team upload.
* Add pom.xml and use maven-repo-helper for installation.
2011-05-29 - Onkar Shinde <onkarshinde@ubuntu.com>
excalibur-logkit (2.0-5) unstable; urgency=low
* Use libgeronimo-jms-1.1-spec-java instead of libjboss-j2ee-java as build
dependency.
* Use javahelper to install files and set classpath/dependencies.
* Add -doc package containing API documentation.
* Add DEP-3 headers to all patches.
* Update standards version to 3.9.2.
2010-06-08 - Thierry Carrez <thierry.carrez@ubuntu.com>
excalibur-logkit (2.0-4) unstable; urgency=low
* Servlet 2.5 transition: Also runtime-depend on libservlet2.5-java
2010-05-03 - Torsten Werner <twerner@debian.org>
excalibur-logkit (2.0-3) unstable; urgency=low
* Team upload.
* Switch to servlet API 2.5.
* Switch to source format 3.0.
* Update Standards-Version: 3.8.4.
2009-10-07 - Onkar Shinde <onkarshinde@ubuntu.com>
excalibur-logkit (2.0-2) unstable; urgency=low
* Remove libgeronimo-jms-1.1-spec-java from build dependencies.
The package does not exist in Debian archive. (Closes: #549838)

See Also

Package Description
libexcel-template-perl_0.34-1_all.deb Perl module for templating Excel files
libexcel-template-plus-perl_0.06-1_all.deb module for testing and comparing Excel files
libexcel-writer-xlsx-perl_0.95-1_all.deb module to create Excel spreadsheets in xlsx format
libexception-class-dbi-perl_1.01-1_all.deb exception objects customized for DBI
libexception-class-perl_1.42-1_all.deb module that allows you to declare real exception classes in Perl
libexception-class-trycatch-perl_1.13-1_all.deb syntactic try/catch sugar for use with Exception::Class
libexception-handler-perl_1.004-1_all.deb perl module Exception::Handler
libexempi-dev_2.4.1-1_i386.deb library to parse XMP metadata (Development files)
libexempi3_2.4.1-1_i386.deb library to parse XMP metadata (Library)
libexene-smlnj_110.79-2+b1_i386.deb Concurrent ML library for the X Window System
libexif-dev_0.6.21-2+b2_i386.deb library to parse EXIF files (development files)
libexif-gtk-dev_0.3.5-5_i386.deb Library providing GTK+ widgets to display/edit EXIF tags (development files)
libexif-gtk5_0.3.5-5_i386.deb Library providing GTK+ widgets to display/edit EXIF tags
libexif12_0.6.21-2+b2_i386.deb library to parse EXIF files
libexiv2-14_0.25-3.1+deb9u1_i386.deb EXIF/IPTC/XMP metadata manipulation library
Advertisement
Advertisement