libeclipselink-java_2.5.1-4_all.deb


Advertisement

Description

libeclipselink-java - Eclipse Persistence Services Project

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libeclipselink-java_2.5.1-4_all.deb
Package name libeclipselink-java
Package version 2.5.1
Package release 4
Package architecture all
Package type deb
Category java
Homepage http://www.eclipse.org/eclipselink/
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 7.57 MB
Installed size 9.03 MB
Eclipse Persistence Services Project, more commonly known as EclipseLink,
is a Java comprehensive persistence framework delivering a set of persistence
services based around standards. This lets you rapidly build applications
that combine the best aspects of object technology and the specific data
source.
EclipseLink was started by a donation of the full source code and
test suites of Oracle's TopLink product.
EclipseLink's services currently include object-relational with JPA,
object-XML binding in MOXy (with support for JAXB), a Service Data Objects
(SDO) implementation and support for another technologies like: Database Web
Services (DWS), XML-Relational (XRM) and Non-Relational (EIS via JCA).

Alternatives

Package Version Architecture Repository
libeclipselink-java_2.5.1-4_all.deb 2.5.1 all Debian Main
libeclipselink-java - - -

Requires

Name Value
antlr3 >= 3.2
libasm3-java -
libcdi-api-java -
libgeronimo-j2ee-connector-1.5-spec-java -
libgeronimo-jms-1.1-spec-java -
libgeronimo-jta-1.1-spec-java -
libgeronimo-validation-1.0-spec-java -
libjpa-2.1-spec-java -
libjsr311-api-java -
libmail-java -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libeclipselink-java_2.5.1-4_all.deb
Source Package eclipselink

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libeclipselink-java deb package:
    # sudo apt-get install libeclipselink-java

Files

Path
/usr/share/doc-base/libeclipselink-java
/usr/share/doc/libeclipselink-java/README.Debian
/usr/share/doc/libeclipselink-java/about.html
/usr/share/doc/libeclipselink-java/changelog.Debian.gz
/usr/share/doc/libeclipselink-java/copyright
/usr/share/doc/libeclipselink-java/readme.html
/usr/share/java/eclipselink-2.5.1.jar
/usr/share/java/eclipselink.jar
/usr/share/java/org.eclipse.persistence.jpa.jpql-2.5.1.jar
/usr/share/java/org.eclipse.persistence.jpa.jpql.jar
/usr/share/java/org.eclipse.persistence.jpa.modelgen.processor-2.5.1.jar
/usr/share/java/org.eclipse.persistence.jpa.modelgen.processor.jar
/usr/share/lintian/overrides/libeclipselink-java
/usr/share/maven-repo/org/eclipse/persistence/eclipselink/2.5.1/eclipselink-2.5.1.jar
/usr/share/maven-repo/org/eclipse/persistence/eclipselink/2.5.1/eclipselink-2.5.1.pom
/usr/share/maven-repo/org/eclipse/persistence/eclipselink/debian/eclipselink-debian.jar
/usr/share/maven-repo/org/eclipse/persistence/eclipselink/debian/eclipselink-debian.pom
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.jpql/2.5.1/org.eclipse.persistence.jpa.jpql-2.5.1.jar
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.jpql/2.5.1/org.eclipse.persistence.jpa.jpql-2.5.1.pom
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.jpql/debian/org.eclipse.persistence.jpa.jpql-debian.jar
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.jpql/debian/org.eclipse.persistence.jpa.jpql-debian.pom
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.modelgen.processor/2.5.1/org.eclipse.persistence.jpa.modelgen.processor-2.5.1.jar
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.modelgen.processor/2.5.1/org.eclipse.persistence.jpa.modelgen.processor-2.5.1.pom
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.modelgen.processor/debian/org.eclipse.persistence.jpa.modelgen.processor-debian.jar
/usr/share/maven-repo/org/eclipse/persistence/org.eclipse.persistence.jpa.modelgen.processor/debian/org.eclipse.persistence.jpa.modelgen.processor-debian.pom

Changelog

2016-07-19 - Emmanuel Bourg <ebourg@apache.org>
eclipselink (2.5.1-4) unstable; urgency=medium
* Team upload.
* Transition to the Servlet API 3.1
* Standards-Version updated to 3.9.8
* Switch to debhelper level 9
* Use secure Vcs-* URLs
* Use XZ compression for the upstream tarball
2015-07-16 - Emmanuel Bourg <ebourg@apache.org>
eclipselink (2.5.1-3) unstable; urgency=medium
* Team upload.
* Depend on libmail-java instead of libgeronimo-javamail-1.4-spec-java
2014-11-28 - Emmanuel Bourg <ebourg@apache.org>
eclipselink (2.5.1-2) unstable; urgency=medium
* Team upload.
* Install the Maven artifacts (Closes: #729092)
* debian/control:
- Standards-Version updated to 3.9.6 (no changes)
- Removed the recommended dependency on libservlet3.0-java
2013-10-27 - Andrew Ross <ubuntu@rossfamily.co.uk>
eclipselink (2.5.1-1) unstable; urgency=low
* New upstream release. (Closes: #725375).
* Bump Standards-Version to 3.9.4: no changes needed.
* Fix lintian warning dm-upload-allowed-is-obsolete by removing
that field from d/control
2012-06-27 - Miguel Landaeta <miguel@miguel.cc>
eclipselink (2.1.3-2) unstable; urgency=low
[ Miguel Landaeta ]
* Fix FTBFS with Java7 as default-java. (Closes: #678288).
* Bump Standards-Version to 3.9.3. No changes were required.
[ Niels Thykier ]
* Set DMUA flag.
2011-07-26 - Miguel Landaeta <miguel@miguel.cc>
eclipselink (2.1.3-1) unstable; urgency=low
* New upstream release. (Closes: #635210).
* Bump Standards-Version to 3.9.2: no changes needed.
* Refresh patches.
2010-07-09 - Miguel Landaeta <miguel@miguel.cc>
eclipselink (2.1.0-1) unstable; urgency=low
* New upstream release.
* Link javadoc to system javadocs.
2010-07-06 - Damien Raude-Morvan <drazzib@debian.org>
eclipselink (2.0.2-2) unstable; urgency=low
* Team upload.
* Fix d/classpath-debian to include antlr3-runtime.jar (Closes: #588271).
* Fix build with new ANTLR 3.2:
- d/patches/antlr32.diff: Change API usage for ANTLR 3.2
- d/rules: Regenerate lexer from upstream d/JPQL.g
* Bump Standards-Version to 3.9.0: no changes needed.
2010-06-03 - Miguel Landaeta <miguel@miguel.cc>
eclipselink (2.0.2-1) unstable; urgency=low
* Initial release. (Closes: #581861).

See Also

Package Description
libecm-dev_7.0.4+ds-1_all.deb dummy package
libecm1-dev-common_7.0.4+ds-1_all.deb factor integers using the Elliptic Curve Method -- header
libecm1-dev_7.0.4+ds-1_i386.deb factor integers using the Elliptic Curve Method -- libdev
libecm1_7.0.4+ds-1_i386.deb factor integers using the Elliptic Curve Method -- lib
libecore-con1_1.8.6-2.5+b2_i386.deb Ecore Connection Library
libecore-dev_1.8.6-2.5+b2_i386.deb Ecore headers and static libraries
libecore-evas1_1.8.6-2.5+b2_i386.deb Ecore Evas Wrapper Library
libecore-fb1_1.8.6-2.5+b2_i386.deb Ecore frame buffer system functions
libecore-file1_1.8.6-2.5+b2_i386.deb Ecore File Library
libecore-imf1_1.8.6-2.5+b2_i386.deb Ecore Input Method Framework module
libecore-input1_1.8.6-2.5+b2_i386.deb Ecore input module
libecore-ipc1_1.8.6-2.5+b2_i386.deb Ecore inter-process communication functions
libecore-x1_1.8.6-2.5+b2_i386.deb Ecore functions for dealing with the X Window System
libecore1_1.8.6-2.5+b2_i386.deb Core abstraction layer for enlightenment DR 0.17
libecpg-compat3_9.6.15-0+deb9u1_i386.deb older version of run-time library for ECPG programs
Advertisement
Advertisement