libdns162_9.10.3.dfsg.P4-12.3+deb9u5_i386.deb


Advertisement

Description

libdns162 - DNS Shared Library used by BIND

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libdns162_9.10.3.dfsg.P4-12.3+deb9u5_i386.deb
Package name libdns162
Package version 9.10.3.dfsg.P4
Package release 12.3+deb9u5
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage -
License -
Maintainer Debian DNS Packaging <pkg-dns-devel@lists.alioth.debian.org>
Download size 1.07 MB
Installed size 4.84 MB
The Berkeley Internet Name Domain (BIND) implements an Internet domain
name server.  BIND is the most widely-used name server software on the
Internet, and is supported by the Internet Software Consortium, www.isc.org.
This package delivers the libdns shared library used by BIND's daemons and
clients.

Alternatives

Package Version Architecture Repository
libdns162_9.10.3.dfsg.P4-12.3+deb9u5_amd64.deb 9.10.3.dfsg.P4 amd64 Debian Main
libdns162 - - -

Requires

Name Value
libc6 >= 2.4
libcap2 >= 1:2.10
libcomerr2 >= 1.01
libgeoip1 -
libgssapi-krb5-2 >= 1.14+dfsg
libisc160 -
libk5crypto3 >= 1.6.dfsg.2
libkrb5-3 >= 1.6.dfsg.2
libssl1.0.2 >= 1.0.2d
libxml2 >= 2.7.4

Conflicts

Name Value
libbind0 -
libbind9-41 -

Replaces

Name Value
libbind0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdns162_9.10.3.dfsg.P4-12.3+deb9u5_i386.deb
Source Package bind9

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdns162 deb package:
    # sudo apt-get install libdns162

Files

Path
/usr/lib/i386-linux-gnu/libdns-pkcs11.so.162
/usr/lib/i386-linux-gnu/libdns-pkcs11.so.162.1.3
/usr/lib/i386-linux-gnu/libdns.so.162
/usr/lib/i386-linux-gnu/libdns.so.162.1.3
/usr/share/doc/libdns162/changelog.Debian.gz
/usr/share/doc/libdns162/changelog.gz
/usr/share/doc/libdns162/copyright

Changelog

2019-05-03 - Bernhard Schmidt <berni@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u5) stretch-security; urgency=high
[ Marc Deslauriers (Ubuntu) ]
* CVE-2018-5743: limiting simultaneous TCP clients is ineffective.
Thanks to Marc Deslauriers of Ubuntu (Closes: #927932)
[ Ondřej Surý ]
* Sync Maintainer and Uploaders with unstable
* [CVE-2019-6465]: Zone transfer for DLZs are executed though not
permitted by ACLs. (Closes: #922955)
* [CVE-2018-5745]: Avoid assertion and thus causing named to
deliberately exit when a trust anchor's key is replaced with a key
which uses an unsupported algorithm. (Closes: #922954)
2018-01-15 - Salvatore Bonaccorso <carnil@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u4) stretch-security; urgency=high
* Non-maintainer upload by the Security Team.
* Addresses could be referenced after being freed in resolver.c, causing an
assertion failure. (CVE-2017-3145)
2017-08-28 - Ondřej Surý <ondrej@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u3) stretch; urgency=medium
[ Bernhard Schmidt ]
* Import upcoming DNSSEC KSK-2017 from 9.10.5
[ Ondřej Surý ]
* Non-maintainer upload.
2017-07-22 - Yves-Alexis Perez <corsac@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u2) stretch-security; urgency=high
* Non-maintainer upload by the Security Team.
* debian/patches:
- CVE-2017-3142_regression added, fix a regression introduced in with the
correction for CVE-2017-3142.
2017-06-30 - Yves-Alexis Perez <corsac@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u1) stretch-security; urgency=high
* Non-maintainer upload by the Security Team.
* debian/patches:
- debian/patches/CVE-2017-3142+CVE-2017-3143 added, fix TSIG bypasses
CVE-2017-3142: error in TSIG authentication can permit unauthorized zone
transfers. An attacker may be able to circumvent TSIG authentication of
AXFR and Notify requests.
CVE-2017-3143: error in TSIG authentication can permit unauthorized
dynamic updates. An attacker may be able to forge a valid TSIG or SIG(0)
signature for a dynamic update.
2017-05-07 - Salvatore Bonaccorso <carnil@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.3) unstable; urgency=high
* Non-maintainer upload.
* Dns64 with "break-dnssec yes;" can result in a assertion failure
(CVE-2017-3136) (Closes: #860224)
* Some chaining (CNAME or DNAME) responses to upstream queries could trigger
assertion failures (CVE-2017-3137) (Closes: #860225)
* 'rndc ""' could trigger a assertion failure in named (CVE-2017-3138)
(Closes: #860226)
2017-04-18 - James Cowgill <jcowgill@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.2) unstable; urgency=medium
* Non-maintainer upload.
* Replace 32_mips_atomic.diff with a version that uses C11 atomics. Fixes
hangs and crashes on MIPS. (Closes: #778720)
2017-03-17 - Bastian Blank <waldi@debian.org>
bind9 (1:9.10.3.dfsg.P4-12.1) unstable; urgency=medium
* Non-maintainer upload.
* Use /dev/urandom to avoid blocking in the server process.
(closes: #854243)
2017-02-19 - Michael Gilbert <mgilbert@debian.org>
bind9 (1:9.10.3.dfsg.P4-12) unstable; urgency=high
* Merge and accept the non-maintainer upload.
* Fix regression caused by the fix for CVE-2016-8864 (closes: #855540).
* Fix CVE-2017-3135: a malicously crafted query can cause named to crash if
both DNS64 and RPZ are being used (closes: #855520).
2017-02-07 - Arturo Borrero Gonzalez <arturo@debian.org>
bind9 (1:9.10.3.dfsg.P4-11.1) unstable; urgency=medium
* Non-maintainer upload.
* Disable GOST to prevent ENGINE_by_id failed (crypto failure) in chroot.
Patch by Marc Haber <mh+debian-bugs@zugschlus.de> (Closes: #820974).

See Also

Package Description
libdnsjava-java_2.1.8-1_all.deb Implementation of DNS in Java
libdnssec2_2.4.0-3+deb9u1_i386.deb DNSSEC shared library from Knot
libdnssecjava-java-doc_1.1.3-1_all.deb DNSSEC validating stub resolver for Java (documentation)
libdnssecjava-java_1.1.3-1_all.deb DNSSEC validating stub resolver for Java
libdockapp-dev_0.7.2-1_i386.deb Window Maker Dock App support (development files)
libdockapp3_0.7.2-1_i386.deb Window Maker Dock App support (shared library)
libdogleg-dev_0.09-2+b1_i386.deb Powell's dog-leg nonlinear least squares solver for sparse matrices
libdogleg-doc_0.09-2_all.deb Powell's dog-leg nonlinear least squares solver for sparse matrices
libdogleg2_0.09-2+b1_i386.deb Powell's dog-leg nonlinear least squares solver for sparse matrices
libdokujclient-java-doc_3.9.0-1_all.deb Client for Dokuwiki's xmlrpc interface -- documentation
libdokujclient-java_3.9.0-1_all.deb Client library for Dokuwiki's xmlrpc interface
libdolfin-dev_2016.2.0-2_i386.deb Shared links and header files for DOLFIN
libdolfin2016.2_2016.2.0-2_i386.deb Shared libraries for DOLFIN
libdolphinvcs-dev_16.08.3-3_i386.deb library to show version control in Dolphin - development files
libdolphinvcs5_16.08.3-3_i386.deb library to show version control in Dolphin
Advertisement
Advertisement