flightgear_2016.4.4+dfsg-3+deb9u1_i386.deb


Advertisement

Description

flightgear - Flight Gear Flight Simulator

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename flightgear_2016.4.4+dfsg-3+deb9u1_i386.deb
Package name flightgear
Package version 2016.4.4+dfsg
Package release 3+deb9u1
Package architecture i386
Package type deb
Category field::aviation game::simulation games hardware::opengl interface::graphical interface::x11 role::program scope::application uitoolkit::xlib use::gameplaying x11::application
Homepage http://www.flightgear.org/
License -
Maintainer Debian FlightGear Crew <pkg-fgfs-crew@lists.alioth.debian.org>
Download size 7.81 MB
Installed size 32.70 MB
FlightGear Flight Simulator (often shortened to FlightGear or FGFS)
is a sophisticated free, completely open-source flight simulator
framework, created by volunteers.
This package contains the runtime binaries.

Alternatives

Package Version Architecture Repository
flightgear_2016.4.4+dfsg-3+deb9u1_amd64.deb 2016.4.4+dfsg amd64 Debian Main
flightgear - - -

Requires

Name Value
flightgear-data-all >= 1:2016.4.1~
freeglut3 -
libc6 >= 2.15
libcurl3-gnutls >= 7.28.0
libdbus-1-3 >= 1.9.14
libexpat1 >= 2.0.1
libflite1 >= 1.4-release-9~
libgcc1 >= 1:4.2
libgl1 -
libgl1-mesa-glx -
libglu1 -
libglu1-mesa -
libgsm1 >= 1.0.13
libhtsengine1 >= 1.07
libice6 >= 1:1.0.0
libopenal1 >= 1.14
libopenscenegraph100v5 -
libopenthreads20 -
libplib1 >= 1.8.5-1
libpng16-16 >= 1.6.2-1
libqt5core5a >= 5.7.0
libqt5gui5 >= 5.2.0
libqt5widgets5 >= 5.3.0
libsm6 -
libspeex1 >= 1.2~beta3-1
libspeexdsp1 >= 1.2~beta3.2-1
libsqlite3-0 >= 3.7.14
libstdc++6 >= 5.2
libudev1 >= 183
libudns0 >= 0.4
libx11-6 -
libxext6 -
libxi6 -
libxmu6 -
zlib1g >= 1:1.2.6

Download

Type URL
Mirror ftp.br.debian.org
Binary Package flightgear_2016.4.4+dfsg-3+deb9u1_i386.deb
Source Package flightgear

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flightgear deb package:
    # sudo apt-get install flightgear

Files

Path
/usr/games/GPSsmooth
/usr/games/MIDGsmooth
/usr/games/UGsmooth
/usr/games/fgcom
/usr/games/fgelev
/usr/games/fgfs
/usr/games/fgjs
/usr/games/fgpanel
/usr/games/fgviewer
/usr/games/js_demo
/usr/games/metar
/usr/games/yasim
/usr/games/yasim-proptest
/usr/share/applications/flightgear.desktop
/usr/share/doc-base/flightgear
/usr/share/doc-base/flightgear-aptnav
/usr/share/doc-base/flightgear-faq
/usr/share/doc-base/flightgear-nasal
/usr/share/doc/flightgear/AUTHORS
/usr/share/doc/flightgear/AptNavFAQ.FlightGear.html
/usr/share/doc/flightgear/FlightGear-FAQ.html
/usr/share/doc/flightgear/NEWS.gz
/usr/share/doc/flightgear/Nasal.html
/usr/share/doc/flightgear/README
/usr/share/doc/flightgear/README.IO.gz
/usr/share/doc/flightgear/README.JSBSim
/usr/share/doc/flightgear/README.Joystick
/usr/share/doc/flightgear/README.MSVC.gz
/usr/share/doc/flightgear/README.SimGear
/usr/share/doc/flightgear/README.TerraSync
/usr/share/doc/flightgear/README.Unix
/usr/share/doc/flightgear/README.Win32-X
/usr/share/doc/flightgear/README.canvas.gz
/usr/share/doc/flightgear/README.commands.gz
/usr/share/doc/flightgear/README.conditions.gz
/usr/share/doc/flightgear/README.digitalfilters.gz
/usr/share/doc/flightgear/README.effects.gz
/usr/share/doc/flightgear/README.electrical.gz
/usr/share/doc/flightgear/README.extensions
/usr/share/doc/flightgear/README.fgjs
/usr/share/doc/flightgear/README.gui.gz
/usr/share/doc/flightgear/README.introduction
/usr/share/doc/flightgear/README.jsclient
/usr/share/doc/flightgear/README.logging
/usr/share/doc/flightgear/README.mingw
/usr/share/doc/flightgear/README.multiplayer.gz
/usr/share/doc/flightgear/README.multiscreen.gz
/usr/share/doc/flightgear/README.plib
/usr/share/doc/flightgear/README.properties.gz
/usr/share/doc/flightgear/README.protocol.gz
/usr/share/doc/flightgear/README.running.gz
/usr/share/doc/flightgear/README.sound
/usr/share/doc/flightgear/README.src
/usr/share/doc/flightgear/README.submodels.gz
/usr/share/doc/flightgear/README.tutorial
/usr/share/doc/flightgear/README.uiuc.gz
/usr/share/doc/flightgear/README.xmlpanel.gz
/usr/share/doc/flightgear/README.xmlparticles.gz
/usr/share/doc/flightgear/README.xmlsound.gz
/usr/share/doc/flightgear/README.xmlsyntax.gz
/usr/share/doc/flightgear/Thanks.gz
/usr/share/doc/flightgear/changelog.Debian.gz
/usr/share/doc/flightgear/changelog.gz
/usr/share/doc/flightgear/copyright
/usr/share/icons/hicolor/128x128/apps/fgcom.png
/usr/share/icons/hicolor/128x128/apps/flightgear.png
/usr/share/icons/hicolor/16x16/apps/fgcom.png
/usr/share/icons/hicolor/16x16/apps/flightgear.png
/usr/share/icons/hicolor/22x22/apps/fgcom.png
/usr/share/icons/hicolor/22x22/apps/flightgear.png
/usr/share/icons/hicolor/24x24/apps/fgcom.png
/usr/share/icons/hicolor/24x24/apps/flightgear.png
/usr/share/icons/hicolor/32x32/apps/fgcom.png
/usr/share/icons/hicolor/32x32/apps/flightgear.png
/usr/share/icons/hicolor/48x48/apps/fgcom.png
/usr/share/icons/hicolor/48x48/apps/flightgear.png
/usr/share/icons/hicolor/64x64/apps/fgcom.png
/usr/share/icons/hicolor/64x64/apps/flightgear.png
/usr/share/icons/hicolor/scalable/apps/fgcom.svg
/usr/share/icons/hicolor/scalable/apps/flightgear.svg
/usr/share/man/man1/fgfs.1.gz
/usr/share/man/man1/fgjs.1.gz
/usr/share/man/man1/fgpanel.1.gz
/usr/share/man/man1/js_demo.1.gz
/usr/share/man/man1/terrasync.1.gz

Changelog

2017-10-01 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.4.4+dfsg-3+deb9u1) stretch; urgency=medium
* Add patches init-allowed-paths-earlier-secu-fix-f372d7.patch and
prevent-arbitrary-file-writes-secu-fix-58d8e1.patch: prevent
malicious add-ons from overriding arbitrary files.
Closes: #873439 (CVE-2017-13709)
2017-05-19 - Dr. Tobias Quathamer <toddy@debian.org>
flightgear (1:2016.4.4+dfsg-3) unstable; urgency=medium
* Team upload.
* Fix RouteMgr security: don't allow overwriting arbitrary files.
This fixes CVE-2017-8921.
Thanks to Salvatore Bonaccorso <carnil@debian.org> (Closes: #862689)
2017-01-24 - Dr. Tobias Quathamer <toddy@debian.org>
flightgear (1:2016.4.4+dfsg-2) unstable; urgency=medium
* Team upload.
* Depend on simgear 2016.4.4, the package FTBFS with earlier versions.
2017-01-15 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.4.4+dfsg-1) unstable; urgency=medium
* New upstream release.
* Drop patch route-manager-secu-fix-6a05d592.patch, it got applied
upstream.
* Add patch relax_version_check.patch. Closes: #850207.
2016-12-19 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.4.3+dfsg-2) unstable; urgency=medium
* Rebuild against simgear-2016.4.3+dfsg-2.
2016-12-14 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.4.3+dfsg-1) unstable; urgency=high
* New upstream release.
* Refresh patch spelling_20160920.patch.
* Add patch route-manager-secu-fix-280cd5.patch to prevent the
route manager from writing arbitrary files. Closes: #848114.
* Update dependency on simgear to ensure this builds against the
corresponding version.
2016-11-28 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.4.2+dfsg-1) unstable; urgency=medium
* New upstream release. Closes: #839083.
* Refresh existing spelling patches, add spelling_20161121.patch.
* Drop patch additional_lib_links.patch, seems unnecessary now that
we link simgear statically.
* Drop cmake variables ENABLE_FGADMIN, FGCOM_DATA_PATH and
SIMGEAR_SHARED, these are no longer supported (and would be ignored,
anyways).
* Update d/copyright: drop a removed file.
2016-09-29 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.3.1+dfsg-2) unstable; urgency=medium
* Correct dependency on flightgear-data: add epoch.
2016-09-20 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.3.1+dfsg-1) unstable; urgency=medium
* New upstream release.
* Adjust dependencies in debian/control.
* Enable all hardening featueres.
* Drop patch 0001-Use-CMAKE_INSTALL_BINDIR.patch, it got applied
upstream.
* Refresh patches spelling_20160206.patch and spelling_20160529.patch
* Add patch spelling_20160920.patch.
2016-07-10 - Markus Wanner <markus@bluegap.ch>
flightgear (1:2016.2.1+dfsg-6) unstable; urgency=medium
[ Jeremy Bicha ]
* Drop obsolete menu and xpm icons, fix icon istall. Closes: #830701.
(LP: #1591115).
* Switch to automatic dbgsym package; bump debhelper for migration rule.
* Add 0001-Use-CMAKE_INSTALL_BINDIR.patch and simplify d/rules
* Update VCS links.

See Also

Package Description
flim_1.14.9+0.20120428-17_all.deb library about internet message for emacsen
flintqs_1.0-1+b1_i386.deb Program using quadratic sieve to factor integers
flip_1.20-3_i386.deb convert text file line endings between Unix and DOS formats
flite1-dev_2.0.0-release-3+b1_i386.deb Small run-time speech synthesis engine - development files
flite_2.0.0-release-3+b1_i386.deb Small run-time speech synthesis engine
flmsg_2.0.16.01-1+b1_i386.deb amateur radio forms management editor
floatbg_1.0-28+b2_i386.deb slowly modify the color of the X root window
flobopuyo_0.20-5+b2_i386.deb Clone of the PuyoPuyo game
flog_1.8-3+b2_i386.deb dump STDIN to file and reopen on SIGHUP
floppyd_4.0.18-2+b1_i386.deb Daemon for remote access to floppy drives
florence_0.6.3-1+b2_i386.deb extensible and scalable virtual keyboard for X
flow-tools-dev_0.68-12.5_i386.deb development files for flow-tools
flow-tools_0.68-12.5_i386.deb collects and processes NetFlow data
flowblade_1.10-2_all.deb non-linear video editor
flowgrind_0.8.0-1+b1_i386.deb Distributed network performance measurement tool
Advertisement
Advertisement