flex-old_2.5.4a-10_i386.deb


Advertisement

Description

flex-old - Old version of the fast lexical analyzer generator

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename flex-old_2.5.4a-10_i386.deb
Package name flex-old
Package version 2.5.4a
Package release 10
Package architecture i386
Package type deb
Category devel devel::code-generator implemented-in::c interface::commandline role::program scope::utility works-with::software:source
Homepage http://flex.sourceforge.net/
License -
Maintainer Tommi Vainikainen <tvainika@debian.org>
Download size 185.84 KB
Installed size 488.00 KB
flex is a tool for generating scanners: programs which recognize lexical
patterns in text. This is the old 2.5.4a version, which is no longer
being developed. You should normally choose flex, unless you have
legacy lexer files that do not work with a modern flex.
This product includes software developed by the University of California,
Berkeley and its contributors. The upstream source code can be found at
http://flex.sourceforge.net/

Alternatives

Package Version Architecture Repository
flex-old_2.5.4a-10_amd64.deb 2.5.4a amd64 Debian Main
flex-old - - -

Requires

Name Value
dpkg >= 1.15.4
install-info -
libc6 >= 2.7

Conflicts

Name Value
flex -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package flex-old_2.5.4a-10_i386.deb
Source Package flex-old

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flex-old deb package:
    # sudo apt-get install flex-old

Files

Path
/usr/bin/flex
/usr/bin/flex++
/usr/bin/lex
/usr/include/FlexLexer.h
/usr/lib/libfl.a
/usr/lib/libl.a
/usr/share/doc/flex-old/README
/usr/share/doc/flex-old/changelog.Debian.gz
/usr/share/doc/flex-old/changelog.gz
/usr/share/doc/flex-old/copyright
/usr/share/info/flex.info.gz
/usr/share/locale/da/LC_MESSAGES/flex.mo
/usr/share/locale/es/LC_MESSAGES/flex.mo
/usr/share/locale/fr/LC_MESSAGES/flex.mo
/usr/share/locale/ko/LC_MESSAGES/flex.mo
/usr/share/locale/ru/LC_MESSAGES/flex.mo
/usr/share/locale/sv/LC_MESSAGES/flex.mo
/usr/share/man/man1/flex++.1.gz
/usr/share/man/man1/flex.1.gz
/usr/share/man/man1/lex.1.gz

Changelog

2011-05-24 - Tommi Vainikainen <tvainika@debian.org>
flex-old (2.5.4a-10) unstable; urgency=low
* FTBFS: The buildd's still do not respect Build-Depends-Indep.
Duplicated the dependency into Build-Depends as a workaround for this
buildd flaw.
2011-05-24 - Tommi Vainikainen <tvainika@debian.org>
flex-old (2.5.4a-9) unstable; urgency=low
* Adopt the package (Closes: #553704). 
* Fix the URL of the homepage (Closes: #503183).
* Rewriter rules using debhelper.
* Use config.{guess,sub} from autotools-dev (Closes: #535937).
2009-11-01 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-8) unstable; urgency=low
* orphan package. I am not using it, am no longer intrerested in
developing it, and it will take too much effort to bring it up to my
standards. It has a single reverse depends, bison++
2005-08-07 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-7) unstable; urgency=low
* Bug fix: "flex-old: FTBFS: Cannot install docs", thanks to Daniel
Schepler                                              (Closes: #318532).
2003-12-23 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-6) unstable; urgency=low
* FTBFS: missing build-depends. Bah. The buildd's do not respect
Build-Depends-Indep. Duplicated the dependency into Build-Depends as a
workaround for this buildd flaw. Also added file as a
build-dependency.                                     (Closes: #224388).
2003-12-13 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-5) unstable; urgency=low
* Bug fix: "flex-old: Info pages don't display the full version number",
thanks to Akim Demaille. Since the 2.5.31 info pages do, this brings
the flex-old package back in sync.                   (Closes: #223797).
2003-09-13 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-4) unstable; urgency=low
* Typo fixes in the description, thanks to Joshua Kwan <joshk@triplehelix.org>
closes: Bug#210388
2003-09-01 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-3) unstable; urgency=low
* *Sigh*. Really remove acinclude.m4, since it makes autoconf fail to
run.
2003-09-01 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-2) unstable; urgency=low
* Fixed usage of chown root.root in the rules files.
* Added AM_MAINTAINER_MODE to .configure.in so that automatic remaking
does not occur.                                         closes: Bug#208190
* removed acinclude.m4, reran aclocal, and reran autoconf, to update the
auto-* files.
2003-05-04 - Manoj Srivastava <srivasta@debian.org>
flex-old (2.5.4a-1) unstable; urgency=low
* Created a new package called flex-old so that people who have not yet
changed their lex files (or can't change them) and thus can't build
with the new flex have an option. This is a dead-end package, and
shall be removed at some point in the future.

See Also

Package Description
flex_2.6.1-1.3_i386.deb fast lexical analyzer generator
flexbackup_1.2.1-6.3_all.deb Flexible backup tool for small to medium sized installations
flexbar_2.50-2+b1_i386.deb flexible barcode and adapter removal for sequencing platforms
flexc++_2.05.00-1+b1_i386.deb Flex-style scanner generator for C++
flexdll_4.01.0~20140328-1+b2_i386.deb OCaml cross-compiler based on mingw -- FlexDLL linker
flexloader_0.03-3+b1_i386.deb utility to configure SRAM based ALTERA devices
flexml_1.9.6-5+b1_i386.deb Fast validating XML processors and applications generator
flexpart_9.02-15_i386.deb Particle Dispersion model for tracing air transport phenomena
flextra_5.0-6_i386.deb Trajectory model for tracing air transport phenomena
flickcurl-doc_1.26-2+deb9u1_all.deb utilities to call the Flickr API from command line - documentation
flickcurl-utils_1.26-2+deb9u1_i386.deb utilities to call the Flickr API from command line
flight-of-the-amazon-queen_1.0.0-8_all.deb classic 2D point and click fantasy adventure game
flightcrew_0.7.2+dfsg-9_i386.deb C++ epub validator
flightgear-data-ai_2016.4.2+dfsg-1_all.deb FlightGear Flight Simulator -- standard AI data
flightgear-data-all_2016.4.2+dfsg-1_all.deb FlightGear Flight Simulator - virtual package
Advertisement
Advertisement