flashrom_0.9.9+r1954-1+b1_i386.deb


Advertisement

Description

flashrom - Identify, read, write, erase, and verify BIOS/ROM/flash chips

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename flashrom_0.9.9+r1954-1+b1_i386.deb
Package name flashrom
Package version 0.9.9+r1954
Package release 1+b1
Package architecture i386
Package type deb
Category admin::boot admin::hardware electronics field::electronics hardware::TODO implemented-in::c interface::commandline role::program scope::utility
Homepage http://www.flashrom.org
License -
Maintainer Uwe Hermann <uwe@debian.org>
Download size 446.85 KB
Installed size 942.00 KB
flashrom is a tool for identifying, reading, writing, verifying and erasing
flash chips. It's often used to flash BIOS/EFI/coreboot/firmware/optionROM
images in-system using a supported mainboard, but it also supports flashing of
network cards (NICs), SATA controller cards, and other external devices which
can program flash chips.
It supports a wide range of DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32/40/48,
and BGA chips, which use various protocols such as LPC, FWH, parallel
flash, or SPI.
The tool can be used to flash BIOS/firmware images for example -- be it
proprietary BIOS images or coreboot (previously known as LinuxBIOS) images.
It can also be used to read the current existing BIOS/firmware from a
flash chip.
Currently supported programmers include:
* internal (for in-system flashing in the mainboard)
* dummy (virtual programmer for testing flashrom)
* nic3com (for flash ROMs on 3COM network cards)
* nicrealtek (for flash ROMs on Realtek and SMC 1211 network cards)
* nicnatsemi (for flash ROMs on National Semiconductor DP838* network cards)
* nicintel (for parallel flash ROMs on Intel 10/100Mbit network cards)
* gfxnvidia (for flash ROMs on NVIDIA graphics cards)
* drkaiser (for flash ROMs on Dr. Kaiser PC-Waechter PCI cards)
* satasii (for flash ROMs on Silicon Image SATA/IDE controllers)
* satamv (for flash ROMs on Marvell SATA controllers)
* atahpt (for flash ROMs on Highpoint ATA/RAID controllers)
* atavia (for flash ROMs on VIA VT6421A SATA controllers)
* atapromise (for flash ROMs on Promise PDC2026x ATA/RAID controllers)
* it8212 (for flash ROMs on ITE IT8212F ATA/RAID controller)
* ft2232_spi (for SPI flash ROMs attached to an FT2232/FT4232H/FT232H family
based USB SPI programmer), including the DLP Design DLP-USB1232H,
FTDI FT2232H Mini-Module, FTDI FT4232H Mini-Module, openbiosprog-spi,
Amontec JTAGkey/JTAGkey-tiny/JTAGkey-2, Dangerous Prototypes Bus Blaster,
Olimex ARM-USB-TINY/-H, Olimex ARM-USB-OCD/-H, TIAO/DIYGADGET USB
Multi-Protocol Adapter (TUMPA), TUMPA Lite, GOEPEL PicoTAP,
Google Servo v1/v2, and FIC OpenMoko Neo1973 Debug board.
* serprog (for flash ROMs attached to a programmer speaking serprog),
including AVR flasher by Urja Rannikko, AVR flasher by eightdot,
Arduino Mega flasher by fritz, InSystemFlasher by Juhana Helovuo,
and atmegaXXu2-flasher by Stefan Tauner.
* buspirate_spi (for SPI flash ROMs attached to a Bus Pirate)
* dediprog (for SPI flash ROMs attached to a Dediprog SF100)
* rayer_spi (for SPI flash ROMs attached to a RayeR parport based programmer)
* pony_spi (for SPI flash ROMs attached to a SI-Prog serial port
bitbanging adapter)
* nicintel_spi (for SPI flash ROMs on Intel Gigabit network cards)
* ogp_spi (for SPI flash ROMs on Open Graphics Project graphics card)
* linux_spi (for SPI flash ROMs accessible via /dev/spidevX.Y on Linux)
* usbblaster_spi (for SPI flash ROMs attached to an Altera USB-Blaster)
* nicintel_eeprom (for SPI EEPROMs on Intel Gigabit network cards)
* mstarddc_spi (for SPI flash ROMs accessible through DDC in MSTAR-equipped
displays)
* pickit2_spi (for SPI flash ROMs accessible via Microchip PICkit2)
* ch341a_spi (for SPI flash ROMs attached to WCH CH341A)

Alternatives

Package Version Architecture Repository
flashrom_0.9.9+r1954-1+b1_amd64.deb 0.9.9+r1954 amd64 Debian Main
flashrom - - -

Requires

Name Value
libc6 >= 2.7
libftdi1-2 >= 1.2
libpci3 >= 1:3.5.2-1
libusb-0.1-4 >= 2:0.1.12
libusb-1.0-0 >= 2:1.0.9

Download

Type URL
Mirror ftp.br.debian.org
Binary Package flashrom_0.9.9+r1954-1+b1_i386.deb
Source Package flashrom

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flashrom deb package:
    # sudo apt-get install flashrom

Files

Path
/lib/udev/rules.d/60-flashrom.rules
/usr/sbin/flashrom
/usr/share/doc/flashrom/README.Debian
/usr/share/doc/flashrom/README.gz
/usr/share/doc/flashrom/changelog.Debian.gz
/usr/share/doc/flashrom/changelog.Debian.i386.gz
/usr/share/doc/flashrom/changelog.gz
/usr/share/doc/flashrom/copyright
/usr/share/doc/flashrom/mysteries_intel.txt.gz
/usr/share/doc/flashrom/serprog-protocol.txt.gz
/usr/share/man/man8/flashrom.8.gz

Changelog

2016-03-13 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.9+r1954-1) unstable; urgency=medium
* New upstream release.
* Don't build-depend on libftdi1-dev on Hurd, it's not available.
2016-03-01 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.9~rc1+r1946-1) unstable; urgency=medium
* New upstream release (Closes: #788426, #802342).
+ Partial support for alpha, hppa, m68k, sh, and s390 (Closes: 774405).
* debian/control:
+ On kFreeBSD only build-depend on libusb-1.0-0-dev, that
package also includes the old libusb 0.1 API (Closes: #815947).
Thanks Steven Chamberlain for the patch!
+ Don't build-depend on libusb-1.0-0-dev on Hurd, it's not available.
+ Add pkg-config to build-depends, since it is used by the upstream
Makefile. Otherwise the Makefile uses hardcoded guesses, which
are not always correct.
+ Drop "Recommends: dmidecode [any-i386 any-amd64 ia64 armhf]".
Upstream has its own code now, no longer uses dmidecode by default.
* debian/rules: Add "export DEB_BUILD_MAINT_OPTIONS = hardening=+all".
* Standards-Version: 3.9.7 (no changes required).
* Package description: Update list of supported devices.
2016-02-23 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.9~rc1+r1942-1) unstable; urgency=medium
* Acknowledge NMU, thanks Anibal Monsalve Salazar! (Closes: #775428).
* New upstream release (Closes: #786917).
+ Dediprog SF100 support is now enabled by default (Closes: #639957).
+ debian/patches/20_svn_version.patch: Drop, no longer needed (if the
tarball is generated via 'make tarball' from svn checkout).
+ debian/patches/mips-fix-internal.patch: Drop, fixed upstream.
* New build-depends: libusb-1.0-0-dev (in addition to libusb-dev).
* Updated build-depends: libftdi-dev -> libftdi1-dev (Closes: #810372).
2015-10-14 - Anibal Monsalve Salazar <anibal@debian.org>
flashrom (0.9.7+r1852-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS on mipsel.
Patch by Dejan Latinovic <Dejan.Latinovic@imgtec.com>.
Add mips-fix-internal.patch.
Closes: #775428.
2014-10-27 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.7+r1852-1) unstable; urgency=medium
* New upstream release.
* Standards-Version: 3.9.6 (no changes required).
* Use 'Architecture: any', flashrom should build/work pretty much everywhere.
* debian/patches:
+ 10_disable_linuxspi.patch: Drop.
+ 20_svn_version.patch: Update.
* Shorten dmidecode 'Recommends' to [any-i386 any-amd64 ia64 armhf].
* Add missing upstream ChangeLog file (via "svn log").
2014-05-03 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.7+r1782-1) unstable; urgency=high
* New upstream release (Closes: #746734, #690478).
* debian/compat: Upgrade from 5 to 9.
* Standards-Version: 3.9.5 (no changes required).
2012-08-08 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.6.1+r1563-1) unstable; urgency=low
* New upstream release.
2012-06-29 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.5.2+r1546-1) unstable; urgency=medium
* New upstream release.
2012-04-07 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.5.2+r1517-1) unstable; urgency=low
* New upstream release.
* Standards-Version: 3.9.3 (no changes required).
2012-02-26 - Uwe Hermann <uwe@debian.org>
flashrom (0.9.5.1+r1508-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
flasm_1.62-7_i386.deb assembler and disassembler for Flash (SWF) bytecode
flatpak-builder_0.8.9-0+deb9u3_i386.deb Flatpak application building helper
flatpak-tests_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps (tests)
flatpak_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps
flatzinc_4.4.0-5_i386.deb constraint problem modelling language
flawfinder_1.31-1_all.deb examines source code and looks for security weaknesses
fldiff_1.1+0-4_i386.deb graphical diff program
fldigi_3.23.14-1+b1_i386.deb digital modem program for hamradio operators
flent_1.0.1-2_all.deb FLExible Network Tester for bufferbloat testing and more
flex-doc_2.6.1-1.3_all.deb Documentation for flex (a fast lexical analyzer generator)
flex-old-doc_2.5.4a-10_all.deb Documentation for an old flex (a fast lexical analyzer generator)
flex-old_2.5.4a-10_i386.deb Old version of the fast lexical analyzer generator
flex_2.6.1-1.3_i386.deb fast lexical analyzer generator
flexbackup_1.2.1-6.3_all.deb Flexible backup tool for small to medium sized installations
flexbar_2.50-2+b1_i386.deb flexible barcode and adapter removal for sequencing platforms
Advertisement
Advertisement