flare-engine_0.19-3_i386.deb


Advertisement

Description

flare-engine - game engine for single-player 2D action role-playing games

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename flare-engine_0.19-3_i386.deb
Package name flare-engine
Package version 0.19
Package release 3
Package architecture i386
Package type deb
Category games uitoolkit::sdl
Homepage http://flarerpg.org/
License -
Maintainer Jan-Hendrik Peters <hennr@hennr.name>
Download size 487.66 KB
Installed size 1.88 MB
Flare (Free Libre Action Roleplaying Engine) is a simple game engine built to
handle a very specific kind of game: single-player 2D action RPGs. Flare is not
a reimplementation of an existing game or engine. It is a tribute to and
exploration of the action RPG genre.
Flare uses simple file formats (INI style config files) for most of the game
data, allowing anyone to easily modify game contents. Open formats are
preferred (png, ogg). The game code is C++.
This package contains the game engine and you will need a game
package (such as flare or polymorph) to play.

Alternatives

Package Version Architecture Repository
flare-engine_0.19-3_amd64.deb 0.19 amd64 Debian Main
flare-engine - - -

Requires

Name Value
fonts-liberation -
libc6 >= 2.15
libsdl-image1.2 >= 1.2.10
libsdl-mixer1.2 -
libsdl-ttf2.0-0 -
libsdl1.2debian >= 1.2.11
libstdc++6 >= 5.2

Replaces

Name Value
flare << 0.19
flare-data << 0.19

Download

Type URL
Mirror ftp.br.debian.org
Binary Package flare-engine_0.19-3_i386.deb
Source Package flare-engine

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flare-engine deb package:
    # sudo apt-get install flare-engine

Files

Path
/usr/games/flare
/usr/share/doc/flare-engine/changelog.Debian.gz
/usr/share/doc/flare-engine/copyright
/usr/share/games/flare/default/mods/mods.txt
/usr/share/games/flare/default/mods/default/cutscenes/credits.txt
/usr/share/games/flare/default/mods/default/cutscenes/intro_example.txt
/usr/share/games/flare/default/mods/default/engine/classes.txt
/usr/share/games/flare/default/mods/default/engine/combat.txt
/usr/share/games/flare/default/mods/default/engine/combat_text.txt
/usr/share/games/flare/default/mods/default/engine/death_penalty.txt
/usr/share/games/flare/default/mods/default/engine/elements.txt
/usr/share/games/flare/default/mods/default/engine/equip_flags.txt
/usr/share/games/flare/default/mods/default/engine/font_colors.txt
/usr/share/games/flare/default/mods/default/engine/font_settings.txt
/usr/share/games/flare/default/mods/default/engine/gameplay.txt
/usr/share/games/flare/default/mods/default/engine/languages.txt
/usr/share/games/flare/default/mods/default/engine/misc.txt
/usr/share/games/flare/default/mods/default/engine/resolutions.txt
/usr/share/games/flare/default/mods/default/engine/tileset_config.txt
/usr/share/games/flare/default/mods/default/engine/tooltips.txt
/usr/share/games/flare/default/mods/default/fonts/LiberationSans-Regular.ttf
/usr/share/games/flare/default/mods/default/images/logo/icon.png
/usr/share/games/flare/default/mods/default/images/menus/config.png
/usr/share/games/flare/default/mods/default/images/menus/confirm_bg.png
/usr/share/games/flare/default/mods/default/images/menus/logo.png
/usr/share/games/flare/default/mods/default/images/menus/tab_active.png
/usr/share/games/flare/default/mods/default/images/menus/tab_inactive.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/button_default.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/button_x.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/checkbox_default.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/down.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/left.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/listbox_default.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/right.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/scrollbar_default.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/slider_default.png
/usr/share/games/flare/default/mods/default/images/menus/buttons/up.png
/usr/share/games/flare/default/mods/default/languages/data.gd.po
/usr/share/games/flare/default/mods/default/languages/data.pot
/usr/share/games/flare/default/mods/default/languages/data.uk.po
/usr/share/games/flare/default/mods/default/languages/engine.be.po
/usr/share/games/flare/default/mods/default/languages/engine.cs.po
/usr/share/games/flare/default/mods/default/languages/engine.de.po
/usr/share/games/flare/default/mods/default/languages/engine.el.po
/usr/share/games/flare/default/mods/default/languages/engine.es.po
/usr/share/games/flare/default/mods/default/languages/engine.fi.po
/usr/share/games/flare/default/mods/default/languages/engine.fr.po
/usr/share/games/flare/default/mods/default/languages/engine.gd.po
/usr/share/games/flare/default/mods/default/languages/engine.gl.po
/usr/share/games/flare/default/mods/default/languages/engine.it.po
/usr/share/games/flare/default/mods/default/languages/engine.ja.po
/usr/share/games/flare/default/mods/default/languages/engine.nb.po
/usr/share/games/flare/default/mods/default/languages/engine.nl.po
/usr/share/games/flare/default/mods/default/languages/engine.pl.po
/usr/share/games/flare/default/mods/default/languages/engine.pot
/usr/share/games/flare/default/mods/default/languages/engine.ru.po
/usr/share/games/flare/default/mods/default/languages/engine.sk.po
/usr/share/games/flare/default/mods/default/languages/engine.sv.po
/usr/share/games/flare/default/mods/default/languages/engine.uk.po
/usr/share/games/flare/default/mods/default/languages/engine.zh.po
/usr/share/games/flare/default/mods/default/languages/xgettext.py
/usr/share/games/flare/default/mods/default/menus/config.txt
/usr/share/games/flare/default/mods/default/menus/confirm.txt
/usr/share/games/flare/default/mods/default/menus/fps.txt
/usr/share/games/flare/default/mods/default/menus/gameload.txt
/usr/share/games/flare/default/mods/default/menus/gamenew.txt
/usr/share/games/flare/default/mods/default/menus/menus.txt
/usr/share/man/man1/flare.1.gz

Changelog

2017-04-13 - Manuel A. Fernandez Montecelo <mafm@debian.org>
flare-engine (0.19-3) unstable; urgency=medium
* Fix broken symlink to a font, thanks to Andreas Beckmann (Closes: #857395)
2015-08-01 - Manuel A. Fernandez Montecelo <mafm@debian.org>
flare-engine (0.19-2) unstable; urgency=medium
* Bump Policy Standards-Version to 3.9.6 (no changes needed)
* Update Vcs URLs in debian/control
* Add colon after "Closes" in changelog to quell lintian Error
"possible-missing-colon-in-closes"
* Build with "DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed" to avoid
linking against unneeded libraries
* Symlink with system-provided fonts through dh_link
* Do not depend on ttf-unifont, not used
* Refresh d/copyright with current information.  It is basically the
same, but it had beed created from before the split between code and
game data, so it contained information about files not present in the
package anymore.
2014-07-17 - Martin Quinson <mquinson@debian.org>
flare-engine (0.19-1) unstable; urgency=medium
* New upstream version (Closes: #734742)
The game and the engine are now split in two source packages
(Closes: #742062).
2013-05-08 - Manuel A. Fernandez Montecelo <mafm@debian.org>
flare (0.18-1) unstable; urgency=low
[ Jan-Hendrik Peters ]
* New upstream version 0.18
[ Manuel A. Fernandez Montecelo ]
* Bump Policy Standards-Version to 3.9.4 (no changes needed)
* Change maintaner address
* Remove obsolete "DM-Upload-Allowed: yes"
2012-12-28 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
flare (0.17.1-1~exp1) experimental; urgency=low
[ Jan-Hendrik Peters ]
* New upstream version
[ Manuel A. Fernandez Montecelo ]
* Bump Policy Standards-Version to 3.9.3 (no changes needed)
* debhelper compatibility level set to 9 (brings fortified builds and other
goodies), dependencies change accordingly
* Depending on fonts (liberation and unifont) rather than installing the
embedded ones
* Review of debian/copyright for the new version, documenting licenses of
included fonts, updating URLs, copyright file format
* Updated watch file
2011-12-26 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
flare (0.15.1-1) unstable; urgency=low
[ Jan-Hendrik Peters <hennr@hennr.name> ]
* New upstream release (Closes: #646455)
- Imported Upstream version 0.15.1 [76cb190]
* Added new build dependency: libsdl-ttf2.0-dev
[ Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com> ]
* Remove stuff in debian/ now present upstream:
- flare.desktop (now in distribution/flare.desktop.in)
- flare-icon.png (installed by CMake from art_src/logo/flare_logo.svg), and
debian/source/include-binaries (created because of this icon)
* debian/rules:
- No need for "override_dh_fixperms" with this upstream
- Now it doesn't contain the master CMakeLists.txt on build, so no need for
overrides to "dh_auto_configure", "dh_auto_build" or "dh_auto_clean"
(already commented out); nor "--builddirectory=build" to the base "dh"
template.
- "override_dh_install" to include --fail-missing (to avoid not installing
new files by mistake, in this package with the data changing so often)
* debian/copyright: minor updates, e.g. changes to dir names and clarifying
that files are under GPLv3/CC-BY-SAv3 or later (not just 3.0)
* Update package descriptions (text taken from upstream's README)
2011-11-15 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
flare (0.14.1-5) unstable; urgency=low
[ Jan-Hendrik Peters <hennr@hennr.name> ]
* Correcting path to icon in the menu file

See Also

Package Description
flare-game_0.19-2_all.deb fantasy single-player 2D action role-playing game
flare_0.19-1_all.deb Meta package to deal with package name changes in Flare 0.19
flashbake_0.27.1-0.1_all.deb automated snapshots with git
flashbench_62-1+b1_i386.deb identify flash storage properties
flashcache-dkms_3.1.3+git20150701-5_all.deb write-back block device cache for Linux (DKMS version)
flashcache-utils_3.1.3+git20150701-5_i386.deb write-back block device cache for Linux (user space utilities)
flashproxy-client_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - client transport plugin
flashproxy-common_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - common library
flashproxy-facilitator_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - facilitator
flashproxy-proxy_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - browser proxy
flashrom_0.9.9+r1954-1+b1_i386.deb Identify, read, write, erase, and verify BIOS/ROM/flash chips
flasm_1.62-7_i386.deb assembler and disassembler for Flash (SWF) bytecode
flatpak-builder_0.8.9-0+deb9u3_i386.deb Flatpak application building helper
flatpak-tests_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps (tests)
flatpak_0.8.9-0+deb9u3_i386.deb Application deployment framework for desktop apps
Advertisement
Advertisement