fizsh_1.0.7-1_all.deb


Advertisement

Description

fizsh - Friendly Interactive ZSHell

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename fizsh_1.0.7-1_all.deb
Package name fizsh
Package version 1.0.7
Package release 1
Package architecture all
Package type deb
Category interface::shell role::program shells
Homepage http://sourceforge.net/projects/fizsh/
License -
Maintainer Guido van Steen <vansteen@users.sourceforge.net>
Download size 22.08 KB
Installed size 135.00 KB
Fizsh is a frontend to Zsh. It provides the user with interactive syntax
highlighting and a Matlab-like history search facility. At the same time it
can handle Bourne syntax.

Alternatives

Package Version Architecture Repository
fizsh_1.0.7-1_all.deb 1.0.7 all Debian Main
fizsh - - -

Requires

Name Value
zsh >= 4.3.9

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fizsh_1.0.7-1_all.deb
Source Package fizsh

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fizsh deb package:
    # sudo apt-get install fizsh

Files

Path
/etc/fizsh/brackets-highlighter.zsh
/etc/fizsh/cursor-highlighter.zsh
/etc/fizsh/fizsh-miscellaneous.zsh
/etc/fizsh/fizsh-prompt.zsh
/etc/fizsh/fizshrc.zsh
/etc/fizsh/main-highlighter.zsh
/etc/fizsh/modify-etc-shells.sh
/etc/fizsh/pattern-highlighter.zsh
/etc/fizsh/root-highlighter.zsh
/etc/fizsh/zsh-history-substring-search.zsh
/etc/fizsh/zsh-syntax-highlighting.zsh
/usr/bin/fizsh
/usr/share/doc/fizsh/README.source.gz
/usr/share/doc/fizsh/changelog.Debian.gz
/usr/share/doc/fizsh/changelog.gz
/usr/share/doc/fizsh/copyright
/usr/share/man/man1/fizsh.1.gz

Changelog

2014-06-16 - Guido van Steen <vansteen@users.sourceforge.net>
fizsh (1.0.7-1) unstable; urgency=low
* New upstream release 
* Increased standards-version to 3.9.5. This gave rise to 2 warnings:
syntax-error-in-dep5-copyright and debian-watch-may-check-gpg-signature
* Corrected the dep5 syntax errors in ./debian/copyright
* Upgraded from dep5 to copyright-format 1.0
* Updated the years in ./debian/copyright
* Added the option "pgpsigurlmangle" to ./debian/watch
* Added ./debian/upstream/signing-key.asc
* Added ./debian/README.source with information on how to debianize a new
version of fizsh
* Increased debian/compat to '9'
* Increased the Build-depend on debhelper to '(>= 9)'
* Added a Build-depend on automake and autoconf to enable the build
* Added a Build-depend on perl to enable the use of pod2man
* Added override_dh_installman. This override causes pod2man to create the
manpage. It also takes care of some cleaning
* Added override_dh_builddeb. This override clean up the file man/fizsh.1,
which is generated during the build process
* Removed debian/fizsh.manpages because it is not needed anymore.
override_dh_installman takes care of creating the man page
* Removed the ./debian/patches directory and ./debian/source/options.
Upstream corrected the issue, which the patch was addressing
2011-08-09 - Guido van Steen <vansteen@users.sourceforge.net>
fizsh (1.0.2-1) unstable; urgency=low
* Initial release (Closes: #611084)

See Also

Package Description
fl-cow_0.6-4.2_i386.deb copy-on-write utility
flac_1.3.2-1_i386.deb Free Lossless Audio Codec - command line tools
flactag_2.0.4-5+b2_i386.deb Tagger for whole-album FLAC files using data from MusicBrainz
flake8_3.2.1-1_all.deb code checker using pycodestyle and pyflakes
flake_0.11-2_i386.deb Alternative encoder for the Free Lossless Audio Codec
flam3_3.0.1-5+b1_i386.deb render and animate FLAM3s and manipulate their genomes
flamerobin_0.9.3~+20150308.6c0559c-1+b3_i386.deb graphical database administration tool for Firebird DBMS
flamethrower_0.1.8-4_all.deb Multicast file distribution utility
flamp_2.2.03-1+b1_i386.deb ham radio Amateur Multicast Protocol application
flann-doc_1.9.1+dfsg-2_all.deb Fast Library for Approximate Nearest Neighbors - documentation
flare-data_0.19-1_all.deb Meta package to deal with package name changes in Flare 0.19
flare-engine_0.19-3_i386.deb game engine for single-player 2D action role-playing games
flare-game_0.19-2_all.deb fantasy single-player 2D action role-playing game
flare_0.19-1_all.deb Meta package to deal with package name changes in Flare 0.19
flashbake_0.27.1-0.1_all.deb automated snapshots with git
Advertisement
Advertisement