fis-gtm_6.3-000A-1_all.deb


Advertisement

Description

fis-gtm - metapackage for the latest version of FIS-GT.M database

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename fis-gtm_6.3-000A-1_all.deb
Package name fis-gtm
Package version 6.3
Package release 000A-1
Package architecture all
Package type deb
Category database
Homepage http://sourceforge.net/projects/fis-gtm
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 20.30 KB
Installed size 68.00 KB
GT.M is a database engine with scalability proven in large real-time
transaction processing systems that have thousands of concurrent
users, individual database file sizes to the Terabyte range (with
virtually unlimited aggregate database sizes).  Yet the light
footprint of GT.M allows it to also scale down for use in small
applications and software appliances (virtual machines).
The GT.M data model is hierarchical associative memory (i.e.,
multi-dimensional array) that imposes no restrictions on the data
types of the indexes or content - the application logic can impose
any schema, dictionary or data organization suited to its problem
domain.  (Database engines that do not impose schemas, but which
allow layered application software to impose and use whatever schema
that is appropriate to the application are popularly referred to as
"document oriented", "schemaless" or "schema-free" databases.)
GT.M's compiler for the standard M (also known as MUMPS) scripting
language implements full support for ACID (Atomic, Consistent,
Isolated, Durable) transactions, using optimistic concurrency control
and software transactional memory (STM) that resolves the common
mismatch between databases and programming languages. Its unique
ability to create and deploy logical multi-site configurations of
applications provides unrivaled continuity of business in the face of
not just unplanned events, but also planned events, including planned
events that include changes to application logic and schema.
This metapackage always depends from the default fis-gtm version.

Alternatives

Package Version Architecture Repository
fis-gtm_6.3-000A-1_all.deb 6.3 all Debian Main
fis-gtm - - -

Requires

Name Value
fis-gtm-6.3-000a -

Provides

Name Value
mumps -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fis-gtm_6.3-000A-1_all.deb
Source Package fis-gtm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fis-gtm deb package:
    # sudo apt-get install fis-gtm

Files

Path
/usr/share/doc/fis-gtm/README.Debian
/usr/share/doc/fis-gtm/changelog.Debian.gz
/usr/share/doc/fis-gtm/copyright

Changelog

2016-10-28 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.3-000A-1) unstable; urgency=low
[ Amul Shah ]
* Update to fis-gtm V6.3-000A
[ Andreas Tille ]
* debhelper 10
* d/watch: version=4
2016-10-27 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.3-000-3) unstable; urgency=medium
[ Amul Shah ]
* Temporarily drop encryption plugin test builds
Closes: #828300
2016-05-17 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.3-000-2) unstable; urgency=medium
[ Amul Shah ]
* Fix a bug in the installation script 
[ Andreas Tille ]
* Better hardening
* cme fix dpkg-control
2016-03-29 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.3-000-1) unstable; urgency=medium
* Import latest sources and update package version
2016-03-21 - Andreas Tille <tille@debian.org>
fis-gtm (6.2-002A-3) unstable; urgency=medium
[ Gert Wollny ]
* Fix build issue with libc 2.2.4
Closes: #818861
[ Andreas Tille ]
* cme fix dpkg-control
* do not explicitly Pre-Depends: multiarch-support but use
${misc:Pre-Depends} instead
2015-07-04 - Andreas Tille <tille@debian.org>
fis-gtm (6.2-002A-2) unstable; urgency=medium
* Fix build issue by adding Build-Conflicts: locales-all (thanks for
the patch to Chris West <solo-debianbugs@goeswhere.com>)
Closes: #791405
2015-06-26 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.2-002A-1) unstable; urgency=medium
* Import latest sources and update package version
2015-06-08 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.2-002-1) unstable; urgency=low
* Import latest sources and update package version 
2015-04-23 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.2-001-1) unstable; urgency=low
* Import latest sources and update package version 
* Fix a problem generating UTF-8 mode MUMPS object code
Closes: #775302
2014-10-04 - Amul Shah <Amul.Shah@fisglobal.com>
fis-gtm (6.2-000-1) unstable; urgency=low
* Import latest sources and update package version
* Delete prior patches and incorporate -emeb_source 
* Build all three encryption plugins: gcrypt AES2568CFB, OpenSSL AES256CFB,
OpenSSL BLOWFISH. UPDATE: only building the gcrypt AES256CFB plugin until
we can resolve a licensing conflict.
* Eliminate remaining lintian warnings
* Added GFDL-1.3 license information to debian/copyright
Closes: #762457

See Also

Package Description
fische_3.2.2-4+b1_i386.deb stand-alone sound visualisation for Linux
fish-common_2.4.0-1_all.deb friendly interactive shell (architecture-independent files)
fish_2.4.0-1_i386.deb friendly interactive shell
fishpoke_0.1.7-1_all.deb client for the Fishpoll server
fishpolld_0.1.7-1_all.deb daemon that allows remote script's execution when triggered from the network
fitscut_1.4.4-4+b3_i386.deb Extract cutouts from FITS image format files
fitsh_0.9.2-1+b1_i386.deb Software package for astronomical image processing
fitspng_0.3.5-1+b1_i386.deb FITS to PNG converter
fitsverify_4.18-1+b1_i386.deb FITS File Format-Verification Tool
fityk_1.3.0-1_i386.deb general-purpose nonlinear curve fitting and data analysis
fiu-utils_0.95-3_i386.deb userspace fault injection framework (utilities)
five-or-more_3.22.2-1_i386.deb make color lines of five or more length
fixincludes_6.3.0-18+deb9u1_i386.deb Fix non-ANSI header files
fizmo-common_0.7.10-2_all.deb Provides localization data from all default fizmo-related
fizmo-console_0.7.10-2_i386.deb Console-based Z-machine interpreter for Infocom/Inform games
Advertisement
Advertisement