fenix-plugins-system_0.0.20070803-7_i386.deb


Advertisement

Description

fenix-plugins-system - system plugins for the Fenix Game Development System

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename fenix-plugins-system_0.0.20070803-7_i386.deb
Package name fenix-plugins-system
Package version 0.0.20070803
Package release 7
Package architecture i386
Package type deb
Category devel role::plugin uitoolkit::sdl
Homepage http://fenix.divsite.net/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 14.38 KB
Installed size 68.00 KB
Fenix is an interpreted script programming language, especially designed to
developing and running 2D games. It has a full graphic library, sound engine
and full featured 2D game engine, making game development extremely easy.
This package includes binary addons to extend the functionality of Fenix.
Plugins included in this package: exec, fsock and tcpsock.

Alternatives

Package Version Architecture Repository
fenix-plugins-system - - -

Requires

Name Value
libc6 >= 2.15
libsdl1.2debian >= 1.2.11
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fenix-plugins-system_0.0.20070803-7_i386.deb
Source Package fenix-plugins

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fenix-plugins-system deb package:
    # sudo apt-get install fenix-plugins-system

Files

Path
/usr/lib/fenix/plugins/exec.so
/usr/lib/fenix/plugins/fsock.so
/usr/lib/fenix/plugins/tcpsock.so
/usr/share/doc/fenix-plugins-system/changelog.Debian.gz
/usr/share/doc/fenix-plugins-system/copyright

Changelog

2016-04-12 - Peter Pentchev <roam@ringlet.net>
fenix-plugins (0.0.20070803-7) unstable; urgency=medium
[ Peter Pentchev ]
* Bump the debhelper compatibility level to 9:
- use CPPFLAGS, CFLAGS, and LDFLAGS provided by debhelper
- thus, drop the explicit versioned dependency on dpkg-dev
* Point the Vcs-* source control fields to the migrated Git repository.
* Convert the copyright file to the 1.0 machine-readable format and
add my debian/* copyright notice.
* Use the dpkg-dev default settings for the debian tarball compression.
* Turn on all the build hardening features.
* Add a Lintian override for a hardening false positive - the compiler
is smart enough to realize that the calls are perfectly safe.
[ Gianfranco Costamagna ]
* Include the previous two uploads, and drop autoreconf patch.
2016-04-08 - Gianfranco Costamagna <locutusofborg@debian.org>
fenix-plugins (0.0.20070803-6) unstable; urgency=medium
* Team upload.
* Switch to autoreconf.
- d/p/as-needed-autoreconf.patch
* Bump std-version to 3.9.8, and compat level to 9.
2014-03-01 - Eric Dorland <eric@debian.org>
fenix-plugins (0.0.20070803-5.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control: Build-Depend on automake1.11. (Closes: #724367)
2011-03-13 - Ansgar Burchardt <ansgar@debian.org>
fenix-plugins (0.0.20070803-5) unstable; urgency=low
* Team upload.
* debian/control: Do not wrap Architecture field.
2011-02-10 - Peter Pentchev <roam@ringlet.net>
fenix-plugins (0.0.20070803-4) unstable; urgency=low
[ Miriam Ruiz ]
* Added Renesas SH(sh4) CPU to support architecture list.
[ Evgeni Golov ]
* Remove Cyril Brulebois as per his request.
* Add sh4 to ALL binary packages.
* Fix Architecture lines: they were copied from fenix' but the wrapped
line was missed. Add the following architectures accordingly: powerpc
s390 sparc. Thanks to Philipp Kern (Closes: #509702).
[ Peter Pentchev ]
* Add armhf to the list of supported architectures and override
the Lintian "unknown architecture" warning.
* Convert to the 3.0 (quilt) source format with bzip2 compression.
* Refer to the GPL-2 and LGPL-2.1 license files in the copyright blurbs.
* Complete the short description of the fenix-plugins-system package.
* Add a dummy watch file explaining why there is no watch file.
* Bump Standards-Version to 3.9.1 with no changes.
* Bump the debhelper compatibility level to 8:
- shorten the rules file using the dh(1) helper
- use "dh --with autotools_dev" to handle config.guess and config.sub
- use debhelper override rules
* Use dpkg-buildflags from dpkg-dev 1.15.7 to obtain CFLAGS, CPPFLAGS
and LDFLAGS.
* Add myself to the list of uploaders.
* Acknowledge Andreas Metzler's NMU with my build fix: build with new
autotools by using the ltmain.sh provided by the Debian version of
libtool to avoid the backwards-incompatible $echo -> $ECHO change.
2011-01-08 - Andreas Metzler <ametzler@debian.org>
fenix-plugins (0.0.20070803-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Update ltmain.sh. Closes: #608333 (Patch by Peter Pentchev)
2008-12-23 - Barry deFreese <bdefreese@debian.org>
fenix-plugins (0.0.20070803-3) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Change XS-Vcs-* to Vcs-*.
* Remove Homepage semi-field from description.
[ Barry deFreese ]
* Add myself to uploaders.
* Remove non-64 bit arches to match fenix.
* Bump Standards Version to 3.8.0. (No changes needed).
2007-12-03 - Jon Dowland <jon@alcopop.org>
fenix-plugins (0.0.20070803-2) unstable; urgency=low
[ Cyril Brulebois ]
* Added libtool to “Build-Depends” since there were undefined macros
(Closes: #439471).
* Added myself to the “Uploaders”.
[ Jon Dowland ]
* add Homepage: control field to source stanza
2007-08-01 - Miriam Ruiz <little_miry@yahoo.es>
fenix-plugins (0.0.20070803-1) unstable; urgency=low
* Initial release.

See Also

Package Description
fenix-plugins_0.0.20070803-7_i386.deb plugins for the Fenix Game Development System
fenix_0.92a.dfsg1-11.1+b1_i386.deb development environment for making 2D games
ferm_2.3-2_all.deb maintain and setup complicated firewall rules
ferret-datasets_7.0-2_all.deb Datasets for use with Ferret Visualisation and analysis suite
ferret-vis_7.0-2_i386.deb Interactive data visualization and analysis environment
ferret_0.6-6_all.deb CASE tool for data model editing
festival-ca_3.0.6-1_all.deb Catalan support for Festival speech synthesis system
festival-czech_0.3-3_all.deb Czech support for Festival speech synthesis system
festival-dev_2.4~release-3+b1_i386.deb Development kit for the Festival speech synthesis system
festival-doc_2.4~release-3_all.deb Documentation for Festival
festival-freebsoft-utils_0.10-5_all.deb Festival extensions and utilities
festival-hi_0.1-9_all.deb festival text to speech synthesizer for Hindi language
festival-mr_0.1-9_all.deb festival text to speech synthesizer for Marathi language
festival-te_0.3.3-4_all.deb festival text to speech synthesizer for Telugu (te) language
festival_2.4~release-3+b1_i386.deb General multi-lingual speech synthesis system
Advertisement
Advertisement