fenics_2016.2.0.1_all.deb


Advertisement

Description

fenics - Automated Solution of Differential Equations

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename fenics_2016.2.0.1_all.deb
Package name fenics
Package version 2016.2.0.1
Package release -
Package architecture all
Package type deb
Category field::mathematics math role::metapackage
Homepage http://fenicsproject.org
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 3.24 KB
Installed size 12.00 KB
FEniCS is a collection of free software for automated, efficient
solution of differential equations.
FEniCS has an extensive list of features, including automated
solution of variational problems, automated error control and
adaptivity, a comprehensive library of finite elements, high
performance linear algebra and many more.
FEniCS is organized as a collection of interoperable components,
including the problem-solving environment DOLFIN, the form compiler
FFC, the finite element tabulator FIAT, the just-in-time compiler
Instant, the code generation interface UFC, the form language UFL and
a range of additional components.

Alternatives

Package Version Architecture Repository
fenics_2016.2.0.1_all.deb 2016.2.0.1 all Debian Main
fenics - - -

Requires

Name Value
dolfin-bin >= 2016.2.0
dolfin-doc >= 2016.2.0
libdolfin-dev >= 2016.2.0
python-dijitso >= 2016.2.0
python-dolfin >= 2016.2.0
python-ffc >= 2016.2.0
python-fiat >= 2016.2.0
python-instant >= 2016.2.0
python-ufl >= 2016.2.0
python-ufl-doc >= 2016.2.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fenics_2016.2.0.1_all.deb
Source Package fenics

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fenics deb package:
    # sudo apt-get install fenics

Files

Path
/usr/share/doc/fenics/changelog.gz
/usr/share/doc/fenics/copyright
/usr/share/lintian/overrides/fenics

Changelog

2017-01-05 - Johannes Ring <johannr@simula.no>
fenics (1:2016.2.0.1) unstable; urgency=medium
* debian/control:
- Update Depends field to DOLFIN 2016.2.0, FFC 2016.2.0, FIAT
2016.2.0, Instant 2016.2.0 and UFL 2016.2.0.
- Add python-dijitso to Depends.
- Remove Christophe Prud'homme from Uploaders (closes: #835014).
2016-06-27 - Johannes Ring <johannr@simula.no>
fenics (1:2016.1.0.1) UNRELEASED; urgency=medium
* debian/control:
- Update Depends field to DOLFIN 2016.1.0, FFC 2016.1.0, FIAT
2016.1.0, Instant 2016.1.0 and UFL 2016.1.0.
- Bump Standards-Version to 3.9.8 (no changes needed).
2015-03-24 - Johannes Ring <johannr@simula.no>
fenics (1:1.5.0.1) unstable; urgency=medium
* debian/control:
- Update Depends field to DOLFIN 1.5.0, FFC 1.5.0, FIAT 1.5.0,
Instant 1.5.0 and UFL 1.5.0.
- Bump Standards-Version to 3.9.6 (no changes needed).
2014-08-29 - Johannes Ring <johannr@simula.no>
fenics (1:1.4.0.1) unstable; urgency=medium
* debian/control:
- Update Depends field to DOLFIN 1.4.0, FFC 1.4.0, FIAT 1.4.0,
Instant 1.4.0 and UFL 1.4.0.
- Remove ufc, python-ufc and python-ferari from Depends field
(closes: #755728, LP: #1353018).
- Remove libsyfi1.0-dev, python-syfi, syfi-doc and sfc from Suggest.
2014-02-20 - Johannes Ring <johannr@simula.no>
fenics (1:1.3.0.1) unstable; urgency=low
* debian/control:
- Update Depends field to DOLFIN 1.3.0, FFC 1.3.0, FIAT 1.3.0,
Instant 1.3.0, UFC 2.3.0 and UFL 1.3.0.
- Bump Standards-Version to 3.9.5.
* Remove unused lintian override no-upstream-changelog.
2013-03-26 - Johannes Ring <johannr@simula.no>
fenics (1:1.2.0.1) unstable; urgency=low
* debian/control:
- Update Depends field to DOLFIN 1.2.0, FFC 1.2.0, Instant 1.2.0,
UFC 2.2.0 and UFL 1.2.0.
- Move SyFi releated packages to Suggests.
- Remove DM-Upload-Allowed field.
- Bump Standards-Version to 3.9.4.
- Use canonical URIs for Vcs-* fields.
* Use a Debian native version number.
2013-01-11 - Johannes Ring <johannr@simula.no>
fenics (1:1.1.0-1) UNRELEASED; urgency=low
* debian/control:
- Update Depends field to DOLFIN 1.1.0, FFC 1.1.0, FIAT 1.1, Instant
1.1.0, UFC 2.1.0 and UFL 1.1.0.
- Remove python-viper from Depends field.
- Bump Standards-Version to 3.9.3 (no changes needed).
- Update description field.
2011-12-08 - Johannes Ring <johannr@simula.no>
fenics (1:1.0.0-1) unstable; urgency=low
* debian/control: Update Depends field for latest FEniCS releases.
2011-11-29 - Johannes Ring <johannr@simula.no>
fenics (1:1.0-rc2-1) unstable; urgency=low
* debian/control: Update Depends field to DOLFIN 1.0-rc2 and FFC
1.0-rc1 and UFC 2.0.4.
2011-11-22 - Johannes Ring <johannr@simula.no>
fenics (1:1.0-rc1-1) unstable; urgency=low
* debian/control:
- Update Homepage field.
- Update Depends field to DOLFIN 1.0-rc1 and UFL 1.0-rc1.

See Also

Package Description
fenix-dev_0.92a.dfsg1-11.1_all.deb development environment for making 2D games - header files
fenix-plugin-mpeg_0.0.20070803-7_i386.deb mpeg plugin for the Fenix Game Development System
fenix-plugins-system_0.0.20070803-7_i386.deb system plugins for the Fenix Game Development System
fenix-plugins_0.0.20070803-7_i386.deb plugins for the Fenix Game Development System
fenix_0.92a.dfsg1-11.1+b1_i386.deb development environment for making 2D games
ferm_2.3-2_all.deb maintain and setup complicated firewall rules
ferret-datasets_7.0-2_all.deb Datasets for use with Ferret Visualisation and analysis suite
ferret-vis_7.0-2_i386.deb Interactive data visualization and analysis environment
ferret_0.6-6_all.deb CASE tool for data model editing
festival-ca_3.0.6-1_all.deb Catalan support for Festival speech synthesis system
festival-czech_0.3-3_all.deb Czech support for Festival speech synthesis system
festival-dev_2.4~release-3+b1_i386.deb Development kit for the Festival speech synthesis system
festival-doc_2.4~release-3_all.deb Documentation for Festival
festival-freebsoft-utils_0.10-5_all.deb Festival extensions and utilities
festival-hi_0.1-9_all.deb festival text to speech synthesizer for Hindi language
Advertisement
Advertisement