fcgiwrap_1.1.0-9_i386.deb


Advertisement

Description

fcgiwrap - simple server to run CGI applications over FastCGI

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename fcgiwrap_1.1.0-9_i386.deb
Package name fcgiwrap
Package version 1.1.0
Package release 9
Package architecture i386
Package type deb
Category web
Homepage https://github.com/gnosek/fcgiwrap
License -
Maintainer Peter Colberg <peter@colberg.org>
Download size 17.48 KB
Installed size 59.00 KB
fcgiwrap is a simple server for running CGI applications over FastCGI.
Its goal is to provide clean CGI support to the nginx webserver, although
can be used with others.
fcgiwrap is lightweight and has no configuration, making it possible to
use the same pool to run different sites.

Alternatives

Package Version Architecture Repository
fcgiwrap_1.1.0-9_amd64.deb 1.1.0 amd64 Debian Main
fcgiwrap - - -

Requires

Name Value
init-system-helpers >= 1.18~
libc6 >= 2.15
libfcgi0ldbl -
libsystemd0 -
lsb-base >= 3.0-6
spawn-fcgi >= 1.6.1
systemd -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fcgiwrap_1.1.0-9_i386.deb
Source Package fcgiwrap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fcgiwrap deb package:
    # sudo apt-get install fcgiwrap

Files

Path
/etc/init.d/fcgiwrap
/lib/systemd/system/fcgiwrap.service
/lib/systemd/system/fcgiwrap.socket
/usr/sbin/fcgiwrap
/usr/share/doc/fcgiwrap/README.Debian
/usr/share/doc/fcgiwrap/changelog.Debian.gz
/usr/share/doc/fcgiwrap/copyright
/usr/share/doc/fcgiwrap/examples/default
/usr/share/doc/fcgiwrap/examples/monitrc
/usr/share/doc/fcgiwrap/examples/nginx.conf
/usr/share/man/man8/fcgiwrap.8.gz

Changelog

2016-10-22 - Peter Colberg <peter@colberg.org>
fcgiwrap (1.1.0-9) unstable; urgency=medium
* Depend on lsb-base (>= 3.0-6) for /lib/lsb/init-functions
2016-09-24 - Peter Colberg <peter@colberg.org>
fcgiwrap (1.1.0-8) unstable; urgency=medium
* Remove Sergio Talens-Oliag from Uploaders with many thanks for his work
(Closes: #831757)
2016-07-28 - Peter Colberg <peter@colberg.org>
fcgiwrap (1.1.0-7) unstable; urgency=medium
* Override dh_auto_configure instead of manually invoking configure
* Build with hardening flags (Closes: #828804)
* Depend on spawn-fcgi only when systemd is not installed (Closes: #828794)
* Run wrap-and-sort
* Add debian/gbp.conf for pristine-tar
* Bump Standards-Version to 3.9.8
* Update Vcs fields to git repository
* Drop unused dependency on automake
* Relicense debian/* to Expat to match upstream license (Closes: #830742)
* Set myself as Maintainer (Closes: #829654)
2015-07-25 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-6) unstable; urgency=medium
* Add patch to build against libsystemd (closes: #779755; thanks, mbiebl!).
* Bump Standards-Version to 3.9.6.
* Use github as Homepage, the real one has been down for ages.
* Add patch from Dmitry Smirnov to make the systemd unit read DAEMON_OPTS
from /etc/default/fcgiwrap (closes: #792705).
2015-04-02 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-5) unstable; urgency=medium
* Add a prerm script that forcibly stops fcgiwrap.socket, to avoid
respawns via socket activation.
2015-04-01 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-4) unstable; urgency=medium
* Ensure the socket unit is started upon installation by making
fcgiwrap.service Require fcgiwrap.socket (closes: #781524). Thanks,
Michael Biebl!
2014-05-10 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-3) unstable; urgency=medium
* Ensure fcgiwrap.socket is enabled via dh-systemd (closes: #742439).
2014-01-02 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-2) unstable; urgency=medium
* Enable systemd support only on Linux architectures.
2013-12-19 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.1.0-1) unstable; urgency=low
[ Jordi Mallach ]
* New upstream release (closes: #721518).
* Remove all patches, all were applied upstream.
* Add pkg-config to Build-Depends, as per configure.ac.
* Minor tabs-vs-spaces cosmetic fix in init.
* Pull post-1.1.0 patches from Git:
- debian/patches/0002-Add-p-path-option-to-restrict-scripts.patch:
restricts fcgiwrap to a literal path match.
* Pass --with-systemdsystemunitdir=/lib/systemd/system.
* Build-Depend on libsystemd-daemon-dev and pass --with-systemd to
enable systemd socket activation.
* Update to debhelper compat v9.
* Use canonical Vcs URLs.
* Bump Standards-Version to 3.9.5 (no changes needed).
[ Sergio Talens-Oliag ]
* Update watch file as suggested by Haha Warosu (closes: #720912).
* Added -f option to fcgiwrap to redirect stderr (closes: #633116).
* Modified init file to remove the use of DAEMON_USER and DAEMON_GID, as
spawn-fcgi already does the check and fails if the user does not exist
and also changed the PID file extension (closes: #697856).
* Use env -i when calling spawn-fcgi to have a clean environment when
executing the scripts (closes: #621754), but enabling the option of
exporting some variables if desired (ENV_VARS).
* Add fix_systemd.patch: change user/group and socket name definitions
in service file to match the Debian-suitable sysvinit values.
* Cleanup autotools files on clean.
2011-04-01 - Jordi Mallach <jordi@debian.org>
fcgiwrap (1.0.3-3) unstable; urgency=low
* Remove Replaces on old package name that never hit the official
archive.
* Actually use $DAEMON_OPTS when spawning the server (closes: #616551).
* Add support for FCGI_SOCKET_USER & FCGI_SOCKET_GROUP, as suggested by
Maik Zumstrull (closes: #616552).
* Add an example default file.

See Also

Package Description
fcheck_2.7.59-19_all.deb IDS filesystem baseline integrity checker
fcitx-anthy_0.2.2-1_i386.deb Fcitx wrapper for Anthy IM engine
fcitx-bin_4.2.9.1-6_i386.deb Flexible Input Method Framework - essential binaries
fcitx-chewing_0.2.2-1_i386.deb Fcitx wrapper for Chewing library
fcitx-config-common_0.4.8-3_all.deb graphic Fcitx configuration tool - common files
fcitx-config-gtk2_0.4.8-3+b1_i386.deb graphic Fcitx configuration tool - Gtk+ 2 version
fcitx-config-gtk_0.4.8-3+b1_i386.deb graphic Fcitx configuration tool - Gtk+ 3 version
fcitx-data_4.2.9.1-6_all.deb Flexible Input Method Framework - essential data files
fcitx-frontend-all_4.2.9.1-6_all.deb Flexible Input Method Framework - frontends metapackage
fcitx-frontend-fbterm_0.2.0-2+b1_i386.deb Flexible Input Method Framework - FbTerm frontend
fcitx-frontend-gtk2_4.2.9.1-6_i386.deb Flexible Input Method Framework - GTK+ 2 IM Module frontend
fcitx-frontend-gtk3_4.2.9.1-6_i386.deb Flexible Input Method Framework - GTK+ 3 IM Module frontend
fcitx-frontend-qt4_4.2.9.1-6_i386.deb Flexible Input Method Framework - Qt4 IM Module frontend
fcitx-frontend-qt5_1.0.5-1+b1_i386.deb Free Chinese Input Toy of X - Qt5 IM Module frontend
fcitx-googlepinyin_0.1.6-3_i386.deb Fcitx wrapper for Google Pinyin IM engine
Advertisement
Advertisement