epic5_2.0.1-1+b2_i386.deb


Advertisement

Description

epic5 - epic irc client, version 5

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename epic5_2.0.1-1+b2_i386.deb
Package name epic5
Package version 2.0.1
Package release 1+b2
Package architecture i386
Package type deb
Category net protocol::irc role::program uitoolkit::ncurses use::chatting
Homepage http://www.epicsol.org/
License -
Maintainer Kurt Roeckx <kurt@roeckx.be>
Download size 666.71 KB
Installed size 1.77 MB
epic5 is an irc client based on ircII.  It is primarily suited to users who
wish to write their own irc scripts or have irc scripts written by others.
Previous versions of epic were 100% compatible with ircII 2.8.2, though
this is no longer the case.  Instead we've taken a new direction and chosen
to find places where compatibility with ircII is undesirable and fix them.
No gratuitous incompatibilities have been added, though many new features
have been.

Alternatives

Package Version Architecture Repository
epic5_2.0.1-1+b2_amd64.deb 2.0.1 amd64 Debian Main
epic5 - - -

Requires

Name Value
libc6 >= 2.17
libncurses5 >= 6
libperl5.24 >= 5.24.0
libssl1.1 >= 1.1.0
libtcl8.6 >= 8.6.0
libtinfo5 >= 6
zlib1g >= 1:1.1.4

Provides

Name Value
irc -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package epic5_2.0.1-1+b2_i386.deb
Source Package epic5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install epic5 deb package:
    # sudo apt-get install epic5

Files

Path
/etc/epic5/epic5.irc
/etc/epic5/servers
/usr/bin/epic5
/usr/lib/epic5/epic5-wserv4
/usr/share/doc/epic5/BUG_FORM.gz
/usr/share/doc/epic5/DCC_REVERSE.gz
/usr/share/doc/epic5/EPIC_ABOUT
/usr/share/doc/epic5/EPIC_THANKS
/usr/share/doc/epic5/EPIC_VERSIONS
/usr/share/doc/epic5/IPV6.gz
/usr/share/doc/epic5/IRCII_VERSIONS
/usr/share/doc/epic5/KNOWNBUGS.gz
/usr/share/doc/epic5/README.Debian
/usr/share/doc/epic5/README.SSL
/usr/share/doc/epic5/README.gz
/usr/share/doc/epic5/SILLINESS.gz
/usr/share/doc/epic5/TS4.gz
/usr/share/doc/epic5/UPDATES.gz
/usr/share/doc/epic5/antiflooding
/usr/share/doc/epic5/changelog.Debian.gz
/usr/share/doc/epic5/changelog.Debian.i386.gz
/usr/share/doc/epic5/colors.gz
/usr/share/doc/epic5/copyright
/usr/share/doc/epic5/dccresum.txt
/usr/share/doc/epic5/entry_points.gz
/usr/share/doc/epic5/epic5.1.gz
/usr/share/doc/epic5/expansions.gz
/usr/share/doc/epic5/fish
/usr/share/doc/epic5/keys
/usr/share/doc/epic5/missing
/usr/share/doc/epic5/nicknames
/usr/share/doc/epic5/outputhelp
/usr/share/doc/epic5/pf-loader.gz
/usr/share/doc/epic5/scrollind
/usr/share/doc/epic5/utf8
/usr/share/doc/epic5/what-needs-rewriting
/usr/share/doc/epic5/word-lists
/usr/share/doc/epic5/word-support.gz
/usr/share/doc/epic5/examples/wrapper.irc
/usr/share/epic5/script/2.8script
/usr/share/epic5/script/activity
/usr/share/epic5/script/addset
/usr/share/epic5/script/alloc_dump_summary.sh
/usr/share/epic5/script/altchan
/usr/share/epic5/script/ambig
/usr/share/epic5/script/autoget
/usr/share/epic5/script/autojoin
/usr/share/epic5/script/autoquery
/usr/share/epic5/script/ban
/usr/share/epic5/script/builtins
/usr/share/epic5/script/chanmonitor
/usr/share/epic5/script/commandqueues
/usr/share/epic5/script/country
/usr/share/epic5/script/cycle
/usr/share/epic5/script/data_array
/usr/share/epic5/script/data_struct
/usr/share/epic5/script/dcc_ports
/usr/share/epic5/script/debug.irc
/usr/share/epic5/script/dump
/usr/share/epic5/script/edit_topic
/usr/share/epic5/script/epic-crypt-gpg
/usr/share/epic5/script/epic-crypt-gpg-aa
/usr/share/epic5/script/files
/usr/share/epic5/script/find_ssl_root_certs
/usr/share/epic5/script/floodprot
/usr/share/epic5/script/functions
/usr/share/epic5/script/global
/usr/share/epic5/script/grep
/usr/share/epic5/script/guh
/usr/share/epic5/script/help
/usr/share/epic5/script/help.irc
/usr/share/epic5/script/highlight
/usr/share/epic5/script/history
/usr/share/epic5/script/history.rb
/usr/share/epic5/script/hold_mode
/usr/share/epic5/script/idlealert
/usr/share/epic5/script/ison
/usr/share/epic5/script/layout
/usr/share/epic5/script/less
/usr/share/epic5/script/less-pipe
/usr/share/epic5/script/loadformats
/usr/share/epic5/script/local
/usr/share/epic5/script/local.examp
/usr/share/epic5/script/locale
/usr/share/epic5/script/logman
/usr/share/epic5/script/mail
/usr/share/epic5/script/man
/usr/share/epic5/script/map
/usr/share/epic5/script/massmode
/usr/share/epic5/script/meta-compat
/usr/share/epic5/script/motd
/usr/share/epic5/script/netsplit
/usr/share/epic5/script/new_lastlog
/usr/share/epic5/script/newaway
/usr/share/epic5/script/newnick
/usr/share/epic5/script/nickcomp
/usr/share/epic5/script/nopaste
/usr/share/epic5/script/notify
/usr/share/epic5/script/paste
/usr/share/epic5/script/pipe
/usr/share/epic5/script/reconnect
/usr/share/epic5/script/rejoin
/usr/share/epic5/script/renumber
/usr/share/epic5/script/revdcc
/usr/share/epic5/script/sasl_auth
/usr/share/epic5/script/save
/usr/share/epic5/script/scan
/usr/share/epic5/script/screen
/usr/share/epic5/script/screen.e
/usr/share/epic5/script/set_color
/usr/share/epic5/script/setmail
/usr/share/epic5/script/slowcat
/usr/share/epic5/script/snip
/usr/share/epic5/script/speak.irc
/usr/share/epic5/script/sping
/usr/share/epic5/script/suppressmotd
/usr/share/epic5/script/tabkey.ce
/usr/share/epic5/script/tabkey.jm
/usr/share/epic5/script/tabkey.sjh
/usr/share/epic5/script/tmux_away
/usr/share/epic5/script/topicbar
/usr/share/epic5/script/topicbar.bj
/usr/share/epic5/script/url.irc
/usr/share/epic5/script/userlist
/usr/share/epic5/script/utime
/usr/share/epic5/script/xmsglog
/usr/share/man/man1/epic5.1.gz
/usr/share/menu/epic5

Changelog

2016-08-15 - Kurt Roeckx <kurt@roeckx.be>
epic5 (2.0.1-1) unstable; urgency=medium
* New upstream release
2016-07-24 - Kurt Roeckx <kurt@roeckx.be>
epic5 (2.0-1) unstable; urgency=medium
* New upstream release
* Add CPPFLAGS to the CFLAGS, remove -Wall
* Make it build reproducible.  Patch from Reiner Herrmann
<reiner@reiner-h.de> (Closes: #829761)
* Update config.patch to apply and only have irc.debian.org as
default.
* Make it build using openssl 1.1 (Closes: #828295)
* Use dh_prep instead of dh_clean -k
* Add sh -e in the prerm
* Use sh instead of bash in the preinst
2015-07-19 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.11-1) unstable; urgency=medium
* New upstream release
2014-06-09 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.10-1) unstable; urgency=medium
* New upstream release
2013-08-06 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.6-1) unstable; urgency=low
* New upstream release
2013-05-21 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.5-1) unstable; urgency=low
* New upstream release
* Add build-arch and build-indep targets
* Use dpkg-buildflags to set CFLAGS / LDFLAGS
2012-08-06 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.4-1) unstable; urgency=low
* New upstream release
2010-07-22 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.2-2) unstable; urgency=low
* Fix config.patch to set defaults to epic5 instead of epic4.
2010-05-01 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.2-1) unstable; urgency=low
* New upstream release
* Switch to dpkg-source 3.0 (quilt) format
2010-04-13 - Kurt Roeckx <kurt@roeckx.be>
epic5 (1.1.1-1) unstable; urgency=low
* New upstream release

See Also

Package Description
epigrass-doc_2.4.7-1_all.deb Documentation for EpiGrass, a network epidemiology tool
epigrass_2.4.7-1_i386.deb scientific tool for simulations and scenario analysis in network epidemiology
epiphany-browser-data_3.22.7-1_all.deb Data files for the GNOME web browser
epiphany-browser_3.22.7-1_i386.deb Intuitive GNOME web browser
epiphany-data_0.7.0+0-3_all.deb required data files for epiphany game
epiphany_0.7.0+0-3+b1_i386.deb clone of Boulder Dash game
epix_1.2.16-3_i386.deb Create mathematically accurate line figures, plots and movies
epm_4.2-6_i386.deb Cross-platform package builder by Easy Software Products
epoptes-client_0.5.10-2_all.deb Computer lab management tool (client)
epoptes_0.5.10-2_all.deb Computer lab management tool
epsilon-bin_0.9.2+dfsg-2_i386.deb Library for wavelet image compression - tools
epstool_3.08+repack-5_i386.deb edit preview images and fix bounding boxes in EPS files
epub-utils_0.2.2-4+b4_i386.deb tools to work with the EPUB file format
epubcheck_4.0.1-2_all.deb Validation Tool for EPUB
epydoc-doc_3.0.1+dfsg-14_all.deb tool for documenting Python modules (documentation)
Advertisement
Advertisement