entr_3.6-1_i386.deb


Advertisement

Description

entr - Run arbitrary commands when files change

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename entr_3.6-1_i386.deb
Package name entr
Package version 3.6
Package release 1
Package architecture i386
Package type deb
Category implemented-in::c interface::commandline interface::daemon misc role::program scope::utility use::monitor works-with::file
Homepage http://entrproject.org/
License -
Maintainer Yuri D'Elia <wavexx@thregr.org>
Download size 15.60 KB
Installed size 39.00 KB
The Event Notify Test Runner (entr) runs arbitrary commands when
files change. Changes are detected through the kqueue/inotify
kernel interface.

Alternatives

Package Version Architecture Repository
entr_3.6-1_amd64.deb 3.6 amd64 Debian Main
entr - - -

Requires

Name Value
libbsd0 >= 0.6.0
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package entr_3.6-1_i386.deb
Source Package entr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install entr deb package:
    # sudo apt-get install entr

Files

Path
/usr/bin/entr
/usr/share/doc/entr/README.md
/usr/share/doc/entr/changelog.Debian.gz
/usr/share/doc/entr/changelog.gz
/usr/share/doc/entr/copyright
/usr/share/man/man1/entr.1.gz

Changelog

2016-07-17 - Yuri D'Elia <wavexx@thregr.org>
entr (3.6-1) unstable; urgency=low
* Imported Upstream version 3.6
* Standards-Version 3.9.8 (no changes needed)
* Switch Vcs-Git and Vcs-Browser to https
* Ship upstream changelog
2015-12-31 - Yuri D'Elia <wavexx@thregr.org>
entr (3.4-1) unstable; urgency=low
* New upstream release 3.4
2015-12-06 - Otto Kekäläinen <otto@seravo.fi>
entr (3.3-1) unstable; urgency=low
* No-change upload to unstable
2015-11-29 - Otto Kekäläinen <otto@seravo.fi>
entr (3.3-1~exp1) experimental; urgency=low
* New upstream release (Closes: #788530)
- Refresh patch to match the end result the patch created in 2.6
- Drop from patch libbsd-overlay hack for Makefile.linux to get
the program compiled.
2014-01-29 - Yuri D'Elia <wavexx@thregr.org>
entr (2.6-1) unstable; urgency=low
* Update to upstream 2.6:
- New '-c' flag to clear the screen.
- '/_' path replacement.
* Override upstream copy and use 'libbsd' overlay.
* Build support for kFreeBSD.
2013-12-31 - Yuri D'Elia <wavexx@thregr.org>
entr (2.5-1) unstable; urgency=low
* Initial release (Closes: #733563)

See Also

Package Description
entropybroker_2.8-3_i386.deb infrastructure for distributing random numbers (entropy data)
enum_1.1-1_i386.deb seq- and jot-like enumerator
env2_1.1.0-3_all.deb convert environment variables between scripting languages
environment-modules_3.2.10-10_i386.deb Modular system for handling environment variables
envstore_2.1-4_i386.deb store for environment variables across shell processes
eoconv_1.5-1_i386.deb convert text files between various Esperanto encodings
eog-dev_3.20.5-1+b1_i386.deb Development files for the Eye of GNOME
eog-plugins_3.16.5-1_i386.deb set of plugins for eog
eog_3.20.5-1+b1_i386.deb Eye of GNOME graphics viewer program
eom-common_1.16.1-1_all.deb Eye of MATE graphics viewer program (common files)
eom-dev_1.16.1-1_i386.deb Eye of MATE graphics viewer program (development files)
eom_1.16.1-1_i386.deb Eye of MATE graphics viewer program
eot-utils_1.1-1+b1_i386.deb Tools to convert from OTF or TTF to EOT font format
eot2ttf_0.01-4+b1_i386.deb utility to convert Embedded OpenType fonts to TrueType
eperl_2.2.14-22+b2_i386.deb Embedded Perl 5 Language
Advertisement
Advertisement