emboss-lib_6.6.0+dfsg-6_i386.deb


Advertisement

Description

emboss-lib - EMBOSS Libraries

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename emboss-lib_6.6.0+dfsg-6_i386.deb
Package name emboss-lib
Package version 6.6.0+dfsg
Package release 6
Package architecture i386
Package type deb
Category devel::lang:c devel::library field::biology field::biology:bioinformatics implemented-in::c role::devel-lib role::shared-lib science
Homepage http://emboss.sourceforge.net
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 2.81 MB
Installed size 15.35 MB
This package contains the core libraries of the European Molecular Biology
Open Software Suite, EMBOSS.
AJAX covers standard data structures, including strings, sequences, file
handles, queues, hashes, heaps, lists, dictionaries, trees and dynamic
arrays. It also covers standard algorithms including comparisons, pattern
matching, sorting, and iterators. AJAX will also provide a set of high level
graphics functions suited to the needs of sequence analysis applications.
The NUCLEUS library provides higher-level functions specific to molecular
sequence analysis, including sequence comparisons, translation, codon usage
and annotation.
It also contains a eplplot, an EMBOSS, a fork of the plplot library.
In Debian, these libraries are to be considered private.

Alternatives

Package Version Architecture Repository
emboss-lib_6.6.0+dfsg-6_amd64.deb 6.6.0+dfsg amd64 Debian Main
emboss-lib - - -

Requires

Name Value
libc6 >= 2.11
libexpat1 >= 2.0.1
libgd3 >= 2.1.0~alpha~
libhpdf-2.2.1 -
libmariadbclient18 >= 5.5.36
libpng16-16 >= 1.6.2-1
libpq5 -
zlib1g >= 1:1.1.4

Conflicts

Name Value
libajax6 -
libajax6-dev -
libnucleus6 -
libnucleus6-dev -

Replaces

Name Value
libajax6 -
libajax6-dev -
libnucleus6 -
libnucleus6-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package emboss-lib_6.6.0+dfsg-6_i386.deb
Source Package emboss

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emboss-lib deb package:
    # sudo apt-get install emboss-lib

Files

Path
/usr/lib/emboss/include/ajacd.h
/usr/lib/emboss/include/ajalign.h
/usr/lib/emboss/include/ajarch.h
/usr/lib/emboss/include/ajarr.h
/usr/lib/emboss/include/ajassem.h
/usr/lib/emboss/include/ajassemdata.h
/usr/lib/emboss/include/ajassemdb.h
/usr/lib/emboss/include/ajassemread.h
/usr/lib/emboss/include/ajassemwrite.h
/usr/lib/emboss/include/ajassert.h
/usr/lib/emboss/include/ajax.h
/usr/lib/emboss/include/ajbamindex.h
/usr/lib/emboss/include/ajbase.h
/usr/lib/emboss/include/ajcall.h
/usr/lib/emboss/include/ajcigar.h
/usr/lib/emboss/include/ajcod.h
/usr/lib/emboss/include/ajdan.h
/usr/lib/emboss/include/ajdas.h
/usr/lib/emboss/include/ajdefine.h
/usr/lib/emboss/include/ajdmx.h
/usr/lib/emboss/include/ajdom.h
/usr/lib/emboss/include/ajdomain.h
/usr/lib/emboss/include/ajexcept.h
/usr/lib/emboss/include/ajfeat.h
/usr/lib/emboss/include/ajfeatdata.h
/usr/lib/emboss/include/ajfeatdb.h
/usr/lib/emboss/include/ajfeatread.h
/usr/lib/emboss/include/ajfeatwrite.h
/usr/lib/emboss/include/ajfile.h
/usr/lib/emboss/include/ajfiledata.h
/usr/lib/emboss/include/ajfileio.h
/usr/lib/emboss/include/ajfmt.h
/usr/lib/emboss/include/ajftp.h
/usr/lib/emboss/include/ajgraph.h
/usr/lib/emboss/include/ajgraphstruct.h
/usr/lib/emboss/include/ajhist.h
/usr/lib/emboss/include/ajhttp.h
/usr/lib/emboss/include/ajindex.h
/usr/lib/emboss/include/ajjava.h
/usr/lib/emboss/include/ajlib.h
/usr/lib/emboss/include/ajlist.h
/usr/lib/emboss/include/ajmart.h
/usr/lib/emboss/include/ajmath.h
/usr/lib/emboss/include/ajmatrices.h
/usr/lib/emboss/include/ajmem.h
/usr/lib/emboss/include/ajmess.h
/usr/lib/emboss/include/ajnam.h
/usr/lib/emboss/include/ajnexus.h
/usr/lib/emboss/include/ajobo.h
/usr/lib/emboss/include/ajobodata.h
/usr/lib/emboss/include/ajobodb.h
/usr/lib/emboss/include/ajoboread.h
/usr/lib/emboss/include/ajobowrite.h
/usr/lib/emboss/include/ajpat.h
/usr/lib/emboss/include/ajpdb.h
/usr/lib/emboss/include/ajpdbio.h
/usr/lib/emboss/include/ajphylo.h
/usr/lib/emboss/include/ajquery.h
/usr/lib/emboss/include/ajquerydata.h
/usr/lib/emboss/include/ajrange.h
/usr/lib/emboss/include/ajrefseq.h
/usr/lib/emboss/include/ajrefseqdata.h
/usr/lib/emboss/include/ajrefseqdb.h
/usr/lib/emboss/include/ajrefseqread.h
/usr/lib/emboss/include/ajrefseqwrite.h
/usr/lib/emboss/include/ajreg.h
/usr/lib/emboss/include/ajreport.h
/usr/lib/emboss/include/ajresource.h
/usr/lib/emboss/include/ajresourcedata.h
/usr/lib/emboss/include/ajresourcedb.h
/usr/lib/emboss/include/ajresourceread.h
/usr/lib/emboss/include/ajresourcewrite.h
/usr/lib/emboss/include/ajseq.h
/usr/lib/emboss/include/ajseqabi.h
/usr/lib/emboss/include/ajseqbam.h
/usr/lib/emboss/include/ajseqdata.h
/usr/lib/emboss/include/ajseqdb.h
/usr/lib/emboss/include/ajseqread.h
/usr/lib/emboss/include/ajseqtype.h
/usr/lib/emboss/include/ajseqwrite.h
/usr/lib/emboss/include/ajsoap.h
/usr/lib/emboss/include/ajsort.h
/usr/lib/emboss/include/ajsql.h
/usr/lib/emboss/include/ajstr.h
/usr/lib/emboss/include/ajsys.h
/usr/lib/emboss/include/ajtable.h
/usr/lib/emboss/include/ajtagval.h
/usr/lib/emboss/include/ajtax.h
/usr/lib/emboss/include/ajtaxdata.h
/usr/lib/emboss/include/ajtaxdb.h
/usr/lib/emboss/include/ajtaxread.h
/usr/lib/emboss/include/ajtaxwrite.h
/usr/lib/emboss/include/ajtext.h
/usr/lib/emboss/include/ajtextdata.h
/usr/lib/emboss/include/ajtextdb.h
/usr/lib/emboss/include/ajtextread.h
/usr/lib/emboss/include/ajtextwrite.h
/usr/lib/emboss/include/ajtime.h
/usr/lib/emboss/include/ajtranslate.h
/usr/lib/emboss/include/ajtree.h
/usr/lib/emboss/include/ajurl.h
/usr/lib/emboss/include/ajurldata.h
/usr/lib/emboss/include/ajurldb.h
/usr/lib/emboss/include/ajurlread.h
/usr/lib/emboss/include/ajurlwrite.h
/usr/lib/emboss/include/ajutil.h
/usr/lib/emboss/include/ajvar.h
/usr/lib/emboss/include/ajvarbcf.h
/usr/lib/emboss/include/ajvardata.h
/usr/lib/emboss/include/ajvardb.h
/usr/lib/emboss/include/ajvarread.h
/usr/lib/emboss/include/ajvarwrite.h
/usr/lib/emboss/include/ajvector.h
/usr/lib/emboss/include/ajxml.h
/usr/lib/emboss/include/ajxmldata.h
/usr/lib/emboss/include/ajxmldb.h
/usr/lib/emboss/include/ajxmlread.h
/usr/lib/emboss/include/ajxmlwrite.h
/usr/lib/emboss/include/embaln.h
/usr/lib/emboss/include/embcom.h
/usr/lib/emboss/include/embcons.h
/usr/lib/emboss/include/embdata.h
/usr/lib/emboss/include/embdbi.h
/usr/lib/emboss/include/embdmx.h
/usr/lib/emboss/include/embdomain.h
/usr/lib/emboss/include/embest.h
/usr/lib/emboss/include/embexit.h
/usr/lib/emboss/include/embgroup.h
/usr/lib/emboss/include/embiep.h
/usr/lib/emboss/include/embindex.h
/usr/lib/emboss/include/embinit.h
/usr/lib/emboss/include/embmat.h
/usr/lib/emboss/include/embmisc.h
/usr/lib/emboss/include/embmol.h
/usr/lib/emboss/include/embnmer.h
/usr/lib/emboss/include/emboss.h
/usr/lib/emboss/include/embpat.h
/usr/lib/emboss/include/embpatlist.h
/usr/lib/emboss/include/embpdb.h
/usr/lib/emboss/include/embprop.h
/usr/lib/emboss/include/embread.h
/usr/lib/emboss/include/embshow.h
/usr/lib/emboss/include/embsig.h
/usr/lib/emboss/include/embword.h
/usr/lib/emboss/include/ensalign.h
/usr/lib/emboss/include/ensanalysis.h
/usr/lib/emboss/include/ensassembly.h
/usr/lib/emboss/include/ensassemblyexception.h
/usr/lib/emboss/include/ensassemblymapper.h
/usr/lib/emboss/include/ensattribute.h
/usr/lib/emboss/include/ensbaseadaptor.h
/usr/lib/emboss/include/enscache.h
/usr/lib/emboss/include/enscoordsystem.h
/usr/lib/emboss/include/ensdata.h
/usr/lib/emboss/include/ensdatabaseadaptor.h
/usr/lib/emboss/include/ensdatabaseconnection.h
/usr/lib/emboss/include/ensdatabaseentry.h
/usr/lib/emboss/include/ensdensity.h
/usr/lib/emboss/include/ensditag.h
/usr/lib/emboss/include/ensembl.h
/usr/lib/emboss/include/ensexon.h
/usr/lib/emboss/include/ensexternaldatabase.h
/usr/lib/emboss/include/ensfeature.h
/usr/lib/emboss/include/ensgene.h
/usr/lib/emboss/include/ensgvallele.h
/usr/lib/emboss/include/ensgvattribute.h
/usr/lib/emboss/include/ensgvbaseadaptor.h
/usr/lib/emboss/include/ensgvdata.h
/usr/lib/emboss/include/ensgvdatabaseadaptor.h
/usr/lib/emboss/include/ensgvgenotype.h
/usr/lib/emboss/include/ensgvindividual.h
/usr/lib/emboss/include/ensgvpopulation.h
/usr/lib/emboss/include/ensgvsample.h
/usr/lib/emboss/include/ensgvsource.h
/usr/lib/emboss/include/ensgvsynonym.h
/usr/lib/emboss/include/ensgvvariation.h
/usr/lib/emboss/include/ensintron.h
/usr/lib/emboss/include/enskaryotype.h
/usr/lib/emboss/include/ensmapper.h
/usr/lib/emboss/include/ensmarker.h
/usr/lib/emboss/include/ensmetacoordinate.h
/usr/lib/emboss/include/ensmetainformation.h
/usr/lib/emboss/include/ensmiscellaneous.h
/usr/lib/emboss/include/ensontology.h
/usr/lib/emboss/include/ensoperon.h
/usr/lib/emboss/include/ensprediction.h
/usr/lib/emboss/include/ensprojectionsegment.h
/usr/lib/emboss/include/ensprotein.h
/usr/lib/emboss/include/ensqc.h
/usr/lib/emboss/include/ensqcalignment.h
/usr/lib/emboss/include/ensqcdasfeature.h
/usr/lib/emboss/include/ensqcdatabase.h
/usr/lib/emboss/include/ensqcsequence.h
/usr/lib/emboss/include/ensqcsubmission.h
/usr/lib/emboss/include/ensqcvariation.h
/usr/lib/emboss/include/ensregistry.h
/usr/lib/emboss/include/ensrepeat.h
/usr/lib/emboss/include/ensseqregion.h
/usr/lib/emboss/include/enssequence.h
/usr/lib/emboss/include/enssequenceedit.h
/usr/lib/emboss/include/enssimple.h
/usr/lib/emboss/include/ensslice.h
/usr/lib/emboss/include/enssoftware.h
/usr/lib/emboss/include/ensstorable.h
/usr/lib/emboss/include/enstable.h
/usr/lib/emboss/include/enstranscript.h
/usr/lib/emboss/include/enstranslation.h
/usr/lib/emboss/include/ensutility.h
/usr/lib/emboss/include/ensvariation.h
/usr/lib/emboss/include/epcre/pcre.h
/usr/lib/emboss/include/epcre/pcre_config.h
/usr/lib/emboss/include/epcre/pcre_internal.h
/usr/lib/emboss/include/epcre/pcre_printint.src
/usr/lib/emboss/include/epcre/pcreemboss.h
/usr/lib/emboss/include/epcre/pcreposix.h
/usr/lib/emboss/include/epcre/ucp.h
/usr/lib/emboss/include/eplplot/disptab.h
/usr/lib/emboss/include/eplplot/drivers.h
/usr/lib/emboss/include/eplplot/metadefs.h
/usr/lib/emboss/include/eplplot/pdf.h
/usr/lib/emboss/include/eplplot/plConfig.h
/usr/lib/emboss/include/eplplot/plDevs.h
/usr/lib/emboss/include/eplplot/plcore.h
/usr/lib/emboss/include/eplplot/pldebug.h
/usr/lib/emboss/include/eplplot/pldll.h
/usr/lib/emboss/include/eplplot/plevent.h
/usr/lib/emboss/include/eplplot/plfci-type1.h
/usr/lib/emboss/include/eplplot/plhershey-unicode.h
/usr/lib/emboss/include/eplplot/plplot.h
/usr/lib/emboss/include/eplplot/plplotP.h
/usr/lib/emboss/include/eplplot/plstrm.h
/usr/lib/emboss/include/eplplot/plunicode-type1.h
/usr/lib/emboss/include/eplplot/plxwd.h
/usr/lib/emboss/include/eplplot/ps.h
/usr/lib/emboss/lib/libacd.a
/usr/lib/emboss/lib/libacd.so
/usr/lib/emboss/lib/libacd.so.6
/usr/lib/emboss/lib/libacd.so.6.0.5
/usr/lib/emboss/lib/libajax.a
/usr/lib/emboss/lib/libajax.so
/usr/lib/emboss/lib/libajax.so.6
/usr/lib/emboss/lib/libajax.so.6.0.5
/usr/lib/emboss/lib/libajaxdb.a
/usr/lib/emboss/lib/libajaxdb.so
/usr/lib/emboss/lib/libajaxdb.so.6
/usr/lib/emboss/lib/libajaxdb.so.6.0.5
/usr/lib/emboss/lib/libajaxg.a
/usr/lib/emboss/lib/libajaxg.so
/usr/lib/emboss/lib/libajaxg.so.6
/usr/lib/emboss/lib/libajaxg.so.6.0.5
/usr/lib/emboss/lib/libensembl.a
/usr/lib/emboss/lib/libensembl.so
/usr/lib/emboss/lib/libensembl.so.6
/usr/lib/emboss/lib/libensembl.so.6.0.5
/usr/lib/emboss/lib/libepcre.a
/usr/lib/emboss/lib/libepcre.so
/usr/lib/emboss/lib/libepcre.so.7
/usr/lib/emboss/lib/libepcre.so.7.0.9
/usr/lib/emboss/lib/libeplplot.a
/usr/lib/emboss/lib/libeplplot.so
/usr/lib/emboss/lib/libeplplot.so.3
/usr/lib/emboss/lib/libeplplot.so.3.2.7
/usr/lib/emboss/lib/libnucleus.a
/usr/lib/emboss/lib/libnucleus.so
/usr/lib/emboss/lib/libnucleus.so.6
/usr/lib/emboss/lib/libnucleus.so.6.0.5
/usr/share/EMBOSS/plstnd5.fnt
/usr/share/EMBOSS/plxtnd5.fnt
/usr/share/doc/emboss-lib/ChangeLog.gz
/usr/share/doc/emboss-lib/changelog.Debian.gz
/usr/share/doc/emboss-lib/changelog.gz
/usr/share/doc/emboss-lib/copyright
/usr/share/lintian/overrides/emboss-lib

Changelog

2016-12-03 - Andreas Tille <tille@debian.org>
emboss (6.6.0+dfsg-6) unstable; urgency=medium
* debhelper 10
* d/watch: version=4
* Build-Depends: default-libmysqlclient-dev
Closes: #845838
2016-08-12 - Andreas Tille <tille@debian.org>
emboss (6.6.0+dfsg-5) unstable; urgency=medium
* Make sure manpage links will not end up in archindep packages
Closes: #834013
2016-08-09 - Canberk Koç <canberkkoc@gmail.com>
emboss (6.6.0+dfsg-4) unstable; urgency=medium
[ Canberk Koç ]
* Team upload.
* Autopkgtest added
[ Andreas Tille ]
* hardening+=all
* Fix some minor spelling issues inside packaging
* Secure Vcs-Git
* Bumped Standards-Version
2015-12-01 - Andreas Tille <tille@debian.org>
emboss (6.6.0+dfsg-3) unstable; urgency=medium
* Make sure we will not delete documentation files from new upstream
version
* Enable build on hurd
Closes: #762673
* cme fix dpkg-control
* incorporate changes from biolinux (see below)
* Make sure data are really in th directory where they will be copied from
Closes: #806022
* Ignore false lintian positives about package-contains-timestamped-gzip
* Cleanup debian/copyright from not existing files and not DEP5 conform
issues
* d/watch: add version mangling
2015-04-08 - Tim Booth <tbooth@ceh.ac.uk>
emboss (6.6.0+dfsg-2biolinux1) trusty; urgency=medium
* Current package builds jemboss from source but then installs
the pre-built jemboss.jar from the tarball - not good!!
Add ant dep and ensure that jemboss.jar really builds
* Include image for icon and edit .desktop file
* Add /usr/bin/jemboss
* Clean ./jemboss/runJemboss.sh which is created on build
* Clean various other files that blocked debuild -S (but note
we are still using some convenience copies of JARs)
* Remove makeJar.csh, and thus remove jemboss dep on csh
* Remove activation.jar which does not seem to be used at all
2014-05-19 - Andreas Tille <tille@debian.org>
emboss (6.6.0+dfsg-1) unstable; urgency=medium
[ Andreas Tille ]
* debian/copyright: Add Upstream-Contact to report bugs
[ Gert Wollny ]
* Add patch to pad Hershey_to_Unicode_table consistently (Closes: #748395)
[ Andreas Tille ]
* cme fix dpkg-control:
- drop very old library versions from conflicts / replaces list
* remove explicite quilt dependency which is not needed
* debian/copyright: Exclude invariant GFDL 1.1 files which are related to
quite outdated EMBOSS 2.5.0
* debian/emboss-doc.doc-base.emboss-admin: removed
* debian/patches/remove_non-free_doc.patch: Cleanup Makefile.am from non-free
docs
2013-09-09 - Andreas Tille <tille@debian.org>
emboss (6.6.0-1) unstable; urgency=low
[ Charles Plessy ]
ec024a3 Imported Upstream version 6.5.7
78ef855 Removed upstream patch (for version 6.4.0).
2f66060 Clarified the license of the packaging.
[ Andreas Tille ]
* Imported Upstream version 6.6.0 (+adapt quilt patches)
Closes: #558852 (at least the regexp
dpkg-shlibdeps: warning: symbol.*found in none of the libraries
does not appear in the build log any more - feel free to reopen
with more info)
* Clarified copyright and licenses for:
- emboss/data/OBO/chebi.obo [b60238c]
- emboss/data/OBO/gene_ontology*.obo [dc91819]
- emboss/data/OBO/software.obo [3c8b4bf]
- emboss/data/OBO/*.obo [8c34d40]
- emboss/data/OBO/pathway.obo [1b3bbcf][1ff8ab9]
- emboss/data/OBO/eco.obo [95aa795]
- emboss/data/OBO/ro.obo [2865596]
* debian/control:
- Standards-Version: 3.9.4 (no changes needed)
- Provide real package evince in addition to virtual package pdf-viewer
* debian/rules:
- Remove some remainings from CVS from emboss-test package
* debian/{jemboss.desktop,jemboss.menu}:
- runJemboss.sh is now POSIX shell instead of csh
* debian/source/format: 3.0 (quilt)
* debian/patches/bashism.patch: Avoid bashism
Closes: #690651
2012-08-10 - Andreas Tille <tille@debian.org>
emboss (6.4.0-4) unstable; urgency=low
* use autoreconf to enable latest changes

See Also

Package Description
emboss-test_6.6.0+dfsg-6_all.deb test files for the EMBOSS package
emboss_6.6.0+dfsg-6_i386.deb European molecular biology open software suite
emdebian-archive-keyring_2.2_all.deb GnuPG archive keys for the emdebian repository
emelfm2-svg-icons_20100219-3_all.deb icon SVG files from emelfm2 project
emma_0.6-5_all.deb extendable MySQL managing assistant
emms_4.2-1.1_i386.deb Emacs MultiMedia System
empathy-common_3.12.12-4_all.deb GNOME multi-protocol chat and call client (common files)
empathy_3.12.12-4_i386.deb GNOME multi-protocol chat and call client
empire-hub_1.0.2.2_i386.deb Empire protocol multiplexer
empire-lafe_1.1-1+b3_i386.deb Fast line-mode Empire client
empire_1.14-1+b1_i386.deb war game of the century
empty-expect_0.6.20b-1+b1_i386.deb Run processes and applications under pseudo-terminal
emu8051_1.1.1-1+b1_i386.deb Emulator and simulator for 8051 microcontrollers
enamdict_2016.12.06-1_all.deb Dictionary of Japanese proper names
enblend_4.2-2_i386.deb image blending tool
Advertisement
Advertisement