emacs25-nox_25.1+1-4+deb9u1_i386.deb


Advertisement

Description

emacs25-nox - GNU Emacs editor (without GUI support)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename emacs25-nox_25.1+1-4+deb9u1_i386.deb
Package name emacs25-nox
Package version 25.1+1
Package release 4+deb9u1
Package architecture i386
Package type deb
Category editors
Homepage http://www.gnu.org/software/emacs/
License -
Maintainer Rob Browning <rlb@defaultvalue.org>
Download size 2.80 MB
Installed size 11.29 MB
GNU Emacs is the extensible self-documenting text editor.  This
package contains a version of Emacs compiled without support for X,
and provides only a text terminal interface.

Alternatives

Package Version Architecture Repository
emacs25-nox_25.1+1-4+deb9u1_amd64.deb 25.1+1 amd64 Debian Main
emacs25-nox - - -

Requires

Name Value
emacs25-bin-common = 25.1+1-4+deb9u1
libacl1 >= 2.2.51-8
libasound2 >= 1.0.16
libc6 >= 2.15
libdbus-1-3 >= 1.9.14
libgnutls30 >= 3.5.6
libgpm2 >= 1.20.4
libjpeg62-turbo >= 1.3.1
libselinux1 >= 1.32
libtinfo5 >= 6
libxml2 >= 2.7.4
zlib1g >= 1:1.1.4

Provides

Name Value
editor -
emacs25 -
emacsen -
info-browser -
mail-reader -
news-reader -

Conflicts

Name Value
emacs25 -
emacs25-lucid -

Replaces

Name Value
emacs25 -
emacs25-lucid -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package emacs25-nox_25.1+1-4+deb9u1_i386.deb
Source Package emacs25

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emacs25-nox deb package:
    # sudo apt-get install emacs25-nox

Files

Path
/usr/bin/emacs25
/usr/bin/emacs25-nox
/usr/share/doc/emacs25-nox/README.Debian
/usr/share/doc/emacs25-nox/changelog.Debian.gz
/usr/share/doc/emacs25-nox/copyright
/usr/share/emacs/25.1/etc/DOC
/usr/share/lintian/overrides/emacs25-nox
/usr/share/man/man1/emacs25-nox.1.gz
/usr/share/man/man1/emacs25.1.gz

Changelog

2017-09-13 - Rob Browning <rlb@defaultvalue.org>
emacs25 (25.1+1-4+deb9u1) stretch-security; urgency=high
* Block remote code execution via enriched text.  Add
0012-A-remote-execution-exploit-via-enriched-text-has-bee.patch to
fix the problem.  Thanks to David Bremner for the alert and
Salvatore Bonaccorso for reporting the problem to Debian.
(Closes: 875447)
2017-04-23 - Rob Browning <rlb@defaultvalue.org>
emacs25 (25.1+1-4) unstable; urgency=medium
* Don't offer/use openssl s_client by default: "s_client is a debug
tool, it does not set up a secure connection, it ignores all
errors and just continues.  It also doesn't do checks it should be
doing.  This is all documented behaviour." -- Kurt Roeckx
Add 0009-openssl-s_client-is-no-longer-a-default-for-ssl-conn.patch to
fix the problem.  Thanks to Kurt Roeckx for reporting the issue.
(Closes: 766397)
2016-11-30 - Rob Browning <rlb@defaultvalue.org>
emacs25 (25.1+1-3) unstable; urgency=medium
* Configure with REL_ALLOC=no to fix crashes.  Thanks to Santiago
Vila for reporting the problem, and Sean Whitton for helping test
the fix. (Closes: 842728)
* Disable xwidget (webkit) support.  Thanks to David Bremner for
reporting the issue. (Closes: 843462)
* Depend on liboss4-salsa-dev on hurd and kfreebsd.  Thanks to Aaron
M. Ucko for reporting the problem and Svante Signell for providing
the fix. (Closes: 840702)
2016-10-24 - Rob Browning <rlb@defaultvalue.org>
emacs25 (25.1+1-2) unstable; urgency=medium
* Respect DEB_BUILD_OPTIONS=nocheck.  Thanks to David Bremner for
reporting the issue.
* Don't dh_auto_clean, and run dh_clean first.  Since we don't build
in the source tree, we shouldn't clean there either, and let
dh_clean take care of its bits before we stomp around.
* Install emacs.appdata.xml as emacs25.appdata.xml.
* Drop emacs23 icons to avoid future path conflicts.  Thanks to
Tatsuya Kinoshita for reporting the problem. (Closes: 841687)
* Fix fix for package-test gpg-agent cleanup race.  Specify
--no-autostart so that we don't start an agent if one wasn't
already running when we're requesting shutdown, and delete the
test dir with "rm -rf" to avoid being affected by vanishing
sockets (sockets that gpg-agent may be deleting in parallel).
* Add gnupg-agent build-dep for package-test.
* Don't segfault if gcc expects -nopie instead of -no-pie.  Thanks
to Lucas Nussbaum and Aaron M. Ucko for reporting the problem, and
Sven Joachim for tracking down the upstream patch. (Closes:
841551)

See Also

Package Description
emacs25_25.1+1-4+deb9u1_i386.deb GNU Emacs editor (with GTK+ GUI support)
emacs_46.1_all.deb GNU Emacs editor (metapackage)
emacsen-common_2.0.8_all.deb Common facilities for all emacsen
emacspeak-espeak-server_45.0+dfsg-1_i386.deb espeak syntesis server for emacspeak
emacspeak-ss_1.12.1-6_i386.deb Emacspeak speech servers for several synthesizers
emacspeak_45.0+dfsg-1_all.deb speech output interface to Emacs
email-reminder_0.7.8-3_all.deb Send event reminders by email
embassy-domainatrix_0.1.660-1_i386.deb Extra EMBOSS commands to handle domain classification file
embassy-domalign_0.1.660-1_i386.deb Extra EMBOSS commands for protein domain alignment
embassy-domsearch_0.1.660-1_i386.deb Extra EMBOSS commands to search for protein domains
ember-media_0.7.2.1-1_all.deb 3D client framework for the WorldForge project -- media files
ember_0.7.2+dfsg-1+b1_i386.deb 3D client framework for the WorldForge project
emboss-data_6.6.0+dfsg-6_all.deb data files for the EMBOSS package
emboss-doc_6.6.0+dfsg-6_all.deb documentation for EMBOSS
emboss-explorer_2.2.0-8_all.deb web-based GUI to EMBOSS
Advertisement
Advertisement