emacs24-nox_24.5+1-11+deb9u1_i386.deb


Advertisement

Description

emacs24-nox - GNU Emacs editor (without GUI support)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename emacs24-nox_24.5+1-11+deb9u1_i386.deb
Package name emacs24-nox
Package version 24.5+1
Package release 11+deb9u1
Package architecture i386
Package type deb
Category editors
Homepage http://www.gnu.org/software/emacs/
License -
Maintainer Rob Browning <rlb@defaultvalue.org>
Download size 2.75 MB
Installed size 10.59 MB
GNU Emacs is the extensible self-documenting text editor.  This
package contains a version of Emacs compiled without support for X,
and provides only a text terminal interface.

Alternatives

Package Version Architecture Repository
emacs24-nox_24.5+1-11+deb9u1_amd64.deb 24.5+1 amd64 Debian Main
emacs24-nox - - -

Requires

Name Value
emacs24-bin-common = 24.5+1-11+deb9u1
libacl1 >= 2.2.51-8
libasound2 >= 1.0.16
libc6 >= 2.15
libdbus-1-3 >= 1.9.14
libglib2.0-0 >= 2.18.0
libgpm2 >= 1.20.4
libselinux1 >= 1.32
libtinfo5 >= 6
libxml2 >= 2.7.4
zlib1g >= 1:1.1.4

Provides

Name Value
editor -
emacs24 -
emacsen -
info-browser -
mail-reader -
news-reader -

Conflicts

Name Value
emacs24 -
emacs24-lucid -

Replaces

Name Value
emacs24 -
emacs24-lucid -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package emacs24-nox_24.5+1-11+deb9u1_i386.deb
Source Package emacs24

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emacs24-nox deb package:
    # sudo apt-get install emacs24-nox

Files

Path
/usr/bin/emacs24
/usr/bin/emacs24-nox
/usr/share/doc/emacs24-nox/README.Debian
/usr/share/doc/emacs24-nox/changelog.Debian.gz
/usr/share/doc/emacs24-nox/changelog.gz
/usr/share/doc/emacs24-nox/copyright
/usr/share/emacs/24.5/etc/DOC
/usr/share/lintian/overrides/emacs24-nox
/usr/share/man/man1/emacs24-nox.1.gz
/usr/share/man/man1/emacs24.1.gz

Changelog

2017-09-12 - Moritz Muehlenhoff <jmm@debian.org>
emacs24 (24.5+1-11+deb9u1) stretch-security; urgency=medium
* Remove unsafe enriched mode translations
2017-04-29 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.5+1-11) unstable; urgency=medium
* emacs-common: add "Breaks: mell (<= 1.0.0-7)".  Apparently it was
removed from the archive in 2011 and can no longer install.
Thanks to Andreas Beckmann for reporting the problem.
(Closes: 860858)
* emacs-common: add "Breaks: prom-mew (<= 2.00+3.2am01-1)".
Apparently it was removed from the archive in 2009 and can no
longer install.  Thanks to Andreas Beckmann for reporting the
problem. (Closes: 851604)
* Add additional fix for memory exhaustion on ppc64el.  Add
0030-Emacs-should-really-work-with-glibc-2.24-on-ppc64.patch to
augment the previous fix for memory exhaustion on ppc64(el).
Thanks to Adrian Bunk and Iain Lane for reporting the problem and
Iain Lane for backporting and providing the fix.
(Closes: 854799, 861032)
2017-04-22 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.5+1-10) unstable; urgency=medium
* Don't segfault if gcc expects -nopie instead of -no-pie.
Add 0027-Emacs-shouldn-t-segfault-when-gcc-expects-nopie.patch, a
backport from emacs25 (that closed #841551) to fix the problem.
Thanks to Lucas Nussbaum and Aaron M. Ucko for reporting the
problem, and Sven Joachim for tracking down the upstream patch.
* Don't offer/use openssl s_client by default: "s_client is a debug
tool, it does not set up a secure connection, it ignores all
errors and just continues.  It also doesn't do checks it should be
doing.  This is all documented behaviour." -- Kurt Roeckx
Add these patches to fix the problem:
0028-IMAP-connections-no-longer-use-openssl-s_client.patch
0029-openssl-s_client-is-no-longer-a-default-for-ssl-conn.patch
Thanks to Kurt Roeckx for reporting the issue. (Closes: #766397)
2017-04-16 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.5+1-9) unstable; urgency=medium
* Improve gnutls security.  Remove --insecure and specify a trustfile.
Add these upstream patches to fix the problem:
0024-Remove-insecure-from-gnutls-cli-invocation.patch
0025-Refactor-out-gnutls-trustfiles.patch
0026-Make-tls.el-use-trustfiles-by-default.patch
Partially addresses #816063.
* Stop using libgnutls.  Add a dependency on gnutls-cli, configure
--without-gnutls, and remove the corresponding build dependency so
the patches that were just added to improve SSL security will take
effect by default.  Thanks to Nathaniel Smith for reporting the
problem and Antoine Beaupre for providing code to reproduce
it. (Closes: 816063)
2017-01-22 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.5+1-8) unstable; urgency=medium
* Configure with REL_ALLOC=no to fix crashes.  Thanks to Santiago
Vila for reporting the problem, and Sean Whitton for helping test
the fix. (Closes: 849775)
* Backport upstream fix for TRAMP hang on startup.  Thanks to Sean
Whitton for tracking down, backporting and testing the
fix. (Closes: 810640)
2016-12-18 - Balint Reczey <balint@balintreczey.hu>
emacs24 (24.5+1-7.1) unstable; urgency=medium
* Non-maintainer upload.
* Disable building with PIE which is now the default (Closes: #837421)
* Add Breaks: oneliner-el (<= 0.3.6-7.1) (Closes: #754892)

See Also

Package Description
emacs24_24.5+1-11+deb9u1_i386.deb GNU Emacs editor (with GTK+ GUI support)
emacs25-bin-common_25.1+1-4+deb9u1_i386.deb GNU Emacs editor's shared, architecture dependent files
emacs25-common_25.1+1-4+deb9u1_all.deb GNU Emacs editor's shared, architecture independent infrastructure
emacs25-el_25.1+1-4+deb9u1_all.deb GNU Emacs LISP (.el) files
emacs25-lucid_25.1+1-4+deb9u1_i386.deb GNU Emacs editor (with Lucid GUI support)
emacs25-nox_25.1+1-4+deb9u1_i386.deb GNU Emacs editor (without GUI support)
emacs25_25.1+1-4+deb9u1_i386.deb GNU Emacs editor (with GTK+ GUI support)
emacs_46.1_all.deb GNU Emacs editor (metapackage)
emacsen-common_2.0.8_all.deb Common facilities for all emacsen
emacspeak-espeak-server_45.0+dfsg-1_i386.deb espeak syntesis server for emacspeak
emacspeak-ss_1.12.1-6_i386.deb Emacspeak speech servers for several synthesizers
emacspeak_45.0+dfsg-1_all.deb speech output interface to Emacs
email-reminder_0.7.8-3_all.deb Send event reminders by email
embassy-domainatrix_0.1.660-1_i386.deb Extra EMBOSS commands to handle domain classification file
embassy-domalign_0.1.660-1_i386.deb Extra EMBOSS commands for protein domain alignment
Advertisement
Advertisement