ekg2-scripting-perl_0.4~pre+20120506.1-13_i386.deb


Advertisement

Description

ekg2-scripting-perl - instant messenger and IRC client for UNIX systems - Perl scripting

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename ekg2-scripting-perl_0.4~pre+20120506.1-13_i386.deb
Package name ekg2-scripting-perl
Package version 0.4~pre+20120506.1
Package release 13
Package architecture i386
Package type deb
Category devel::lang:perl devel::runtime implemented-in::c net role::plugin use::chatting
Homepage http://ekg2.org/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 53.90 KB
Installed size 218.00 KB
EKG2 is an open source instant messenger program for UNIX systems. The program
has a plugin-based structure, and supports multiple protocols, currently
Jabber, ICQ, Gadu-Gadu, IRC, RivChat, PolChat, NNTP and RSS.
This package contains the plugin which embeds a Perl interpreter inside
EKG2.

Alternatives

Package Version Architecture Repository
ekg2-scripting-perl_0.4~pre+20120506.1-13_amd64.deb 0.4~pre+20120506.1 amd64 Debian Main
ekg2-scripting-perl - - -

Requires

Name Value
ekg2-core = 1:0.4~pre+20120506.1-13
libc6 >= 2.4
libperl5.24 >= 5.24.0
perl >= 5.24.1~rc4-1
perlapi-5.24.1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ekg2-scripting-perl_0.4~pre+20120506.1-13_i386.deb
Source Package ekg2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ekg2-scripting-perl deb package:
    # sudo apt-get install ekg2-scripting-perl

Files

Path
/usr/lib/ekg2/plugins/perl.so
/usr/lib/i386-linux-gnu/perl5/5.24/Ekg2.pm
/usr/lib/i386-linux-gnu/perl5/5.24/Ekg2/Irc.pm
/usr/lib/i386-linux-gnu/perl5/5.24/auto/Ekg2/Ekg2.so
/usr/lib/i386-linux-gnu/perl5/5.24/auto/Ekg2/Irc/Irc.so
/usr/share/doc/ekg2-scripting-perl
/usr/share/doc/ekg2-core/Perl-API-en.txt.gz
/usr/share/doc/ekg2-core/Perl-API-pl.txt.gz
/usr/share/ekg2/scripts/audioscrobbler_bot.pl
/usr/share/ekg2/scripts/autoop.pl
/usr/share/ekg2/scripts/cycki.pl
/usr/share/ekg2/scripts/dns.pl
/usr/share/ekg2/scripts/dupa.pl
/usr/share/ekg2/scripts/ggbe.pl
/usr/share/ekg2/scripts/irc.pl
/usr/share/ekg2/scripts/sample.pl
/usr/share/ekg2/scripts/slownik.pl
/usr/share/ekg2/scripts/xmms.pl

Changelog

2016-12-09 - Mateusz Łukasik <mati75@linuxmint.pl>
ekg2 (1:0.4~pre+20120506.1-13) unstable; urgency=medium
* QA upload.
* Use OpenSSL 1.0.2 instead 1.1.0 to fix FTBFS. (Closes: #828292)
* debian/control:
- Drop ekg2-dbg package.
- Bump dh version to 10.
- Bump Standards-Version to 3.9.8.
- Change XS-Python-Version to all.
- Add dh-python to B-D.
* Drop debian/pycompat.
* debian/rules:
- Enable hardening.
- Remove *.la files.
* Fix multiple spelling errors.
* Fix debian/copyright.
* Drop menu files.
2016-03-19 - Santiago Vila <sanvila@debian.org>
ekg2 (1:0.4~pre+20120506.1-12) unstable; urgency=medium
* QA upload.
* Add graphviz to Build-Depends. Documentation was incomplete, but
this package did not FTBFS because of Bug #818379 in doxygen.
* Fix debian/copyright encoding. Patch by Jakub Wilk. Closes: #798822.
2015-09-08 - Santiago Vila <sanvila@debian.org>
ekg2 (1:0.4~pre+20120506.1-11) unstable; urgency=medium
* QA upload.
* Use override_dh_installdocs-arch and override_dh_installdocs-indep
so that the "Architecture: all" autobuilder does not FTBFS.
2015-09-07 - Santiago Vila <sanvila@debian.org>
ekg2 (1:0.4~pre+20120506.1-10) unstable; urgency=medium
* QA upload.
* debian/rules: Drop topgit stuff.
* debian/rules: Switch to automake-1.15. Closes: #797230.
* debian/control: Drop alternative for autopoint, which is old enough.
* Add debian/patches/we-will-do-fine-without-the-compile-time.diff
which removes the use of compile_time() function everywhere.
2015-05-03 - Andreas Metzler <ametzler@debian.org>
ekg2 (1:0.4~pre+20120506.1-9) unstable; urgency=low
* QA upload.
* gnutls_deprecated.diff: Stop using deprecated (and removed in 3.4.0)
gnutls*set_priority functions. Closes: #624036
* testsuite_ignore_pc_subdirectory.diff: Fixup testsuite error by ignoring
.pc subdirectory when scanning for gettext input files.
* Drop ekg recommends for ekg2-dbg. Closes: #778755
2014-08-05 - Andreas Metzler <ametzler@debian.org>
ekg2 (1:0.4~pre+20120506.1-8) unstable; urgency=medium
* QA upload.
* Upload to unstable.
2014-08-03 - Andreas Metzler <ametzler@debian.org>
ekg2 (1:0.4~pre+20120506.1-7) experimental; urgency=medium
* QA upload.
* Build against libgnutls28-dev. Closes: #753024
* Add missing "add" to ekg2-core package description (Thanks, Beatrice
Torracca).  Closes: #621852
* Use debhelper v9 mode to get dpkg-buildflags support. However set libdir
(used for plugins) to /usr/lib instead of multiarch path.
* Upload to experimental to get build test without delaying propagation of
-6 to testing.
2014-07-29 - gregor herrmann <gregoa@debian.org>
ekg2 (1:0.4~pre+20120506.1-6) unstable; urgency=medium
* QA upload.
* Fix "hardcodes /usr/lib/perl5":
use a debian/ekg2-scripting-perl.install.in in file where a variable gets
replaced from debian/rules at build time with the value of
$Config{vendorarch}
(Closes: #752470)
2014-07-08 - Marcin Owsiany <porridge@debian.org>
ekg2 (1:0.4~pre+20120506.1-5) unstable; urgency=low
* Orphaning.
2014-04-19 - Marcin Owsiany <porridge@debian.org>
ekg2 (1:0.4~pre+20120506.1-4) unstable; urgency=medium
* Added a patch to fix segfault in ekg2_check (Closes: #743098)

See Also

Package Description
ekg2-scripting-python_0.4~pre+20120506.1-13_i386.deb instant messenger and IRC client for UNIX systems - Python scripting
ekg2-ui-gtk_0.4~pre+20120506.1-13_i386.deb instant messenger and IRC client for UNIX systems - GTK+ interface
ekg2-ui-ncurses_0.4~pre+20120506.1-13_i386.deb instant messenger and IRC client for UNIX systems - ncurses interface
ekg2_0.4~pre+20120506.1-13_i386.deb instant messenger and IRC client for UNIX systems
ekg_1.9~pre+r2855-5_i386.deb console Gadu-Gadu client for UNIX systems - ncurses UI
ekiga-plugin-evolution_4.0.1-6+b5_i386.deb H.323 and SIP compatible VoIP client - evolution plugin
ekiga_4.0.1-6+b5_i386.deb H.323 and SIP compatible VoIP client
el-get_3.1-1.1_all.deb install and manage elisp code for Emacs
elasticsearch-curator_4.2.5-1_all.deb command-line tool for managing Elasticsearch time-series indices
elastix-doc_4.8-10_all.deb toolbox for rigid and nonrigid registration of images - docs
elastix_4.8-10+b1_i386.deb toolbox for rigid and nonrigid registration of images
eldav_0.8.1-7_all.deb interface to the WebDAV servers for Emacs
electric-fence_2.2.4_i386.deb A malloc(3) debugger
electric_9.07+dfsg-1_all.deb electrical CAD system
eleeye_0.29.6-2.1_i386.deb Chinese chess (Xiangqi) engine
Advertisement
Advertisement