eclipse-emf-sdk_2.8.3-2_all.deb


Advertisement

Description

eclipse-emf-sdk - Eclipse Modeling Framework (EMF) - (Source/Documentation)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename eclipse-emf-sdk_2.8.3-2_all.deb
Package name eclipse-emf-sdk
Package version 2.8.3
Package release 2
Package architecture all
Package type deb
Category java
Homepage http://www.eclipse.org/emf
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 1.48 MB
Installed size 1.73 MB
The Eclipse Modeling Framework (EMF) allows developers to build tools and
other applications based on a structured data model. From a model
specification described in XMI, EMF provides tools and runtime support to
produce a set of Java classes for the model, along with a set of adapter
classes that enable viewing and command-based editing of the model, and a
basic editor.
Documentation and source for the Eclipse Modeling Framework (EMF).

Alternatives

Package Version Architecture Repository
eclipse-emf-sdk_2.8.3-2_all.deb 2.8.3 all Debian Main
eclipse-emf-sdk - - -

Requires

Name Value
default-jre -
eclipse-emf = 2.8.3-2
eclipse-pde >= 3.5.2
java5-runtime -
java6-runtime -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package eclipse-emf-sdk_2.8.3-2_all.deb
Source Package eclipse-emf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install eclipse-emf-sdk deb package:
    # sudo apt-get install eclipse-emf-sdk

Files

Path
/usr/share/doc/eclipse-emf-sdk/changelog.Debian.gz
/usr/share/doc/eclipse-emf-sdk/copyright
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.doc_2.7.0.dist/eclipse_update_120.jpg
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.doc_2.7.0.dist/epl-v10.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.doc_2.7.0.dist/feature.properties
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.doc_2.7.0.dist/feature.xml
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.doc_2.7.0.dist/license.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.sdk_2.8.3.dist/eclipse_update_120.jpg
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.sdk_2.8.3.dist/epl-v10.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.sdk_2.8.3.dist/feature.properties
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.sdk_2.8.3.dist/feature.xml
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.sdk_2.8.3.dist/license.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.source_2.8.3.dist/epl-v10.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.source_2.8.3.dist/feature.properties
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.source_2.8.3.dist/feature.xml
/usr/share/eclipse/dropins/emf-sdk/eclipse/features/org.eclipse.emf.source_2.8.3.dist/license.html
/usr/share/eclipse/dropins/emf-sdk/eclipse/plugins/org.eclipse.emf.cheatsheets_2.5.0.dist.jar
/usr/share/eclipse/dropins/emf-sdk/eclipse/plugins/org.eclipse.emf.doc_2.6.0.dist.jar
/usr/share/eclipse/dropins/emf-sdk/eclipse/plugins/org.eclipse.emf.example.installer_1.2.0.dist.jar
/usr/share/eclipse/dropins/emf-sdk/eclipse/plugins/org.eclipse.emf.source_2.8.3.dist/plugin.xml
/usr/share/eclipse/dropins/emf-sdk/eclipse/plugins/org.eclipse.emf.source_2.8.3.dist/META-INF/MANIFEST.MF
/usr/share/lintian/overrides/eclipse-emf-sdk

Changelog

2016-10-20 - Emmanuel Bourg <ebourg@apache.org>
eclipse-emf (2.8.3-2) unstable; urgency=medium
* Team upload.
* Fixed the build failure with Java 8 (Closes: #831230)
* Removed Niels Thykier from the uploaders (Closes: #770566)
* Standards-Version updated to 3.9.8
* Switch to debhelper level 9
* Use secure Vcs-* URLs
2013-07-01 - Jakub Adam <jakub.adam@ktknet.cz>
eclipse-emf (2.8.3-1) unstable; urgency=low
* New upstream release.
* Add d/eclipse.environment to reflect new upstream source layout.
* Remove XSD packages because upstream split the project repositories.
* d/control: set context qualifier to 'dist'.
* Removed d/patches/Unchecked-generic-class-cast.patch
(applied upstream).
* Refreshed patches for new upstream release.
* Ignore nonexistent org.eclipse.emf.doc.source feature.
* Add Jakub Adam to Uploaders.
* Bump Standards-Version to 3.9.4.
* Updated d/watch.
* Remove now useless d/fetch-eclipse-source.exclude.
* Added d/README.source mentioning removed JET tutorials.
* Add s/*.lintian-overrides for codeless JARs.
* Use xz for upstream tarball compression.
2012-01-25 - Niels Thykier <niels@thykier.net>
eclipse-emf (2.5.0-2) unstable; urgency=low
* Added patch to deal with stricter type checking in generics.
(Closes: #655827)
* Bumped Standards-Versions 3.9.2, no changes required.
2010-06-11 - Benjamin Drung <bdrung@ubuntu.com>
eclipse-emf (2.5.0-1) unstable; urgency=low
* Initial release. (Closes: #551858)

See Also

Package Description
eclipse-emf_2.8.3-2_all.deb Eclipse Modeling Framework (EMF)
eclipse-gef-doc_3.9.100-1_all.deb Eclipse Graphical Editing Framework (documentation)
eclipse-gef_3.9.100-1_all.deb Eclipse Graphical Editing Framework
eclipse-jdt_3.8.1-10_all.deb Eclipse Java Development Tools (JDT)
eclipse-mercurialeclipse_1.9.4-2_all.deb Mercurial DVCS integration for Eclipse
eclipse-mylyn-builds-hudson_3.12.0-2_all.deb Mylyn Hudson/Jenkins Connector
eclipse-mylyn-context-cdt_3.12.0-2_all.deb Mylyn context integration for Eclipse CDT
eclipse-mylyn-context-jdt_3.12.0-2_all.deb Task support for Eclipse JDT
eclipse-mylyn-context-pde_3.12.0-2_all.deb Task support for Eclipse PDE
eclipse-mylyn-context-pydev_3.9.2-5_all.deb Mylyn context integration for PyDev
eclipse-mylyn-tasks-bugzilla_3.12.0-2_all.deb Mylyn Bugzilla Connector
eclipse-mylyn-tasks-github_3.3.0-2_all.deb Mylyn GitHub Connector
eclipse-mylyn-tasks-trac_3.12.0-2_all.deb Mylyn Trac Connector
eclipse-mylyn-versions-cvs_3.12.0-2_all.deb Mylyn version control integration for CVS
eclipse-mylyn-wikitext_3.12.0-2_all.deb Mylyn WikiText
Advertisement
Advertisement