libuim-custom2_1.8.6+gh20161003.0.d63dadd-2_amd64.deb


Advertisement

Description

libuim-custom2 - Universal Input Method - uim-custom API library

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package name libuim-custom2
Package version 1.8.6+gh20161003.0.d63dadd
Package release 2
Package architecture amd64
Package type deb
Installed size 39 B
Download size 10.23 KB
Official Mirror ftp.br.debian.org
Uim is an input method module library which supports various scripts and can
act as a front end for a range of input methods, including Anthy, Canna,
PRIME, or SKK (for Japanese), Pinyin (for Chinese), Byeoru (for Korean), and
M17n (for many other languages). Most of its functions are implemented in
Scheme, so it's very simple and flexible.
This package contains the shared library for uim-custom API.

Alternatives

Package Version Architecture Repository
libuim-custom2_1.8.6+gh20161003.0.d63dadd-2_i386.deb 1.8.6+gh20161003.0.d63dadd i386 Debian Main
libuim-custom2 - - -

Requires

Name Value
libc6 >= 2.4
libuim-scm0 >= 1:1.5.7
libuim8 >= 1:1.7.0
uim-common >= 1:1.8.6+gh20161003.0.d63dadd-2

Replaces

Name Value
libuim6 -
libuim7 << 1:1.7.2-2

Download

Type URL
Binary Package libuim-custom2_1.8.6+gh20161003.0.d63dadd-2_amd64.deb
Source Package uim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuim-custom2 deb package:
    # sudo apt-get install libuim-custom2

Files

Path
/usr/lib/x86_64-linux-gnu/libuim-custom.so.2
/usr/lib/x86_64-linux-gnu/libuim-custom.so.2.1.0
/usr/share/doc/libuim-custom2

Changelog

2016-11-06 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20161003.0.d63dadd-2) unstable; urgency=medium
* debian/uim-{qt,gtk3,common,qt5,gtk2.0}.{postinst,prerm}:
maintainer script(s) do not start on #!
(Closes: #843284, #843286, #843293, #843296, #843300)
2016-10-03 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20161003.0.d63dadd-1) unstable; urgency=medium
* New upstream git checkout.
- do not use GtkWidget-focus-* deprecated since GTK 3.14 (Closes: #838844).
* debian/control: mark libuim-plugins as Multi-Arch: same,
reported by Multiarch hinter
* debian/README.Debian: eliminate lintian warning:
spelling-error-in-readme-debian Chosing Choosing
2016-06-30 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20160630.0.c408e95-1) unstable; urgency=medium
* New upstream git checkout.
2016-06-26 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20160626.0.6821431-1) unstable; urgency=medium
* New upstream git checkout.
* resurrect wb86/zm scms and icons.
* debian/libuim-data.install: re-remove tables wb86.table and zm.table.
* debian/rules: fix table suffix.
2016-06-23 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20160621.0.87bf935-1) unstable; urgency=medium
* New upstream git checkout.
* revert /usr/share/doc/uim-xim is linked to /usr/share/doc/uim-common.
- debian/rules: do not dh_link from /usr/share/doc/uim-xim to uim-common's.
- debian/uim-xim.lintian-overrides: resurrect.
* debian/uim-qt5.menu: remove.
* upload to unstable.
2016-06-17 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20160614.0.ec95c5a-1) experimental; urgency=medium
* New upstream git checkout.
* remove Applied-Upstream and needless patches.
- 90_close_socket_on_exec.patch
- 95_sock_cloexec.patch
- add_keywords_to_application_desktop_files.patch
- close_socket_after_uim_skk_requests_disconnection.patch
- fix-stuck-messages-to-uim-input-pad-ja.patch
- fix_candwin_vertical_gtk.patch
- fix_global-variablel-uim_fd.patch
- fix_spelling_errors.patch
- libpanel-applet.patch
- ppc64el.patch
- qt5-fix-candwin-infinite-loop.patch
- qt5-fix-candwin-infinite-loop2.patch
- qt5-fix-qt-5.5.1.patch
- qt5-immodule-destdir.patch
- qt5-no-longer-supports-Q_WS_X11.patch
- qt5-support.patch
- workaround_for_gtk3_higher_3.7.8.patch
* debian/control
- re-fix Breaks+Replaces relation (ref. #810351)
- update Vcs-* urls.
* debian/rules: remove dh-orig for emacs/uim-version.el and uim.desktop.
* /usr/share/doc/uim-xim is linked to /usr/share/doc/uim-common.
- debian/rules: dh_link from /usr/share/doc/uim-xim to uim-common's.
- debian/uim-xim.lintian-overrides: remove.
* debian/libuim-data.install
- add new xkb.scm entry.
- re-add tables wb86.table and zm.table.
see https://github.com/uim/uim/issues/78
2016-06-07 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6-15exp3) UNRELEASED; urgency=medium
* debian/rules: enable hardening all
* debian/copyright: eliminate lintian warning: spelling-error-in-copyright
* fix spelling errors.
- debian/patches/fix_spelling_errors.patch: add.
* fix cannot select candidate on GTK3 application.
- debian/patches/fix_candwin_vertical_gtk.patch: add
* fix uim-candwin-qt5 infinite loop bug (add missing part)
- debian/patches/qt5-fix-candwin-infinite-loop2.patch: add.
* fix global variablel uim_fd
- debian/patches/fix_global-variablel-uim_fd.patch: add
- debian/libuim8.symbols: add optional uim_set_uim_fd and uim_unset_uim_fd.
* debian/patches/*: update headers.
* debian/control:
- eliminate lintian warning: vcs-field-uses-insecure-uri
- fix Breaks+Replaces relation (Closes: #810351)
- bump up Standards-Version 3.9.8.

See Also

Package Description
libuim-data_1.8.6+gh20161003.0.d63dadd-2_all.deb Universal Input Method - data files
libuim-dev_1.8.6+gh20161003.0.d63dadd-2_amd64.deb Universal Input Method - development files
libuim-plugins_1.8.6+gh20161003.0.d63dadd-2_amd64.deb Universal Input Method - plugin files
libuim-scm0_1.8.6+gh20161003.0.d63dadd-2_amd64.deb Universal Input Method - uim-scm API library
libuim8_1.8.6+gh20161003.0.d63dadd-2_amd64.deb Universal Input Method - uim library
libuima-adapter-soap-java_2.9.0-1_all.deb Library to provide SOAP web services within UIMA
libuima-adapter-vinci-java_2.9.0-1_all.deb Library to provide Vinci web services within UIMA
libuima-addons-java_2.3.1-6_all.deb Apache UIMA Addons
libuima-as-java-doc_2.3.1-5_all.deb Documentation for Apache UIMA Asynch Scaleout framework
libuima-as-java_2.3.1-5_all.deb Apache UIMA Asynch Scaleout framework
libuima-core-java_2.9.0-1_all.deb Core library for the UIMA framework
libuima-cpe-java_2.9.0-1_all.deb Library for the UIMA Collection Processing Engine
libuima-document-annotation-java_2.9.0-1_all.deb Library for the UIMA document annotation
libuima-tools-java_2.9.0-1_all.deb UIMA library for the UIMA tools
libuima-vinci-java_2.9.0-1_all.deb Library to handle Vinci web service protocol
Advertisement
Advertisement