libsolid4_4.14.26-2_amd64.deb


Advertisement

Description

libsolid4 - Solid Library for KDE Platform

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package name libsolid4
Package version 4.14.26
Package release 2
Package architecture amd64
Package type deb
Installed size 1.24 KB
Download size 330.29 KB
Official Mirror ftp.br.debian.org
Solid is a device integration framework. It provides a way of querying and
interacting with hardware independently of the underlying operating system.
This package is part of the KDE Development Platform libraries module.

Alternatives

Package Version Architecture Repository
libsolid4_4.14.26-2_i386.deb 4.14.26 i386 Debian Main
libsolid4 - - -

Requires

Name Value
libc6 >= 2.14
libqt4-dbus >= 4:4.8.0
libqt4-xml >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libstdc++6 >= 5
libudev1 >= 183
udev -

Download

Type URL
Binary Package libsolid4_4.14.26-2_amd64.deb
Source Package kde4libs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsolid4 deb package:
    # sudo apt-get install libsolid4

Files

Path
/usr/lib/libsolid.so.4
/usr/lib/libsolid.so.4.14.26
/usr/share/doc/libsolid4/NEWS.Debian.gz
/usr/share/doc/libsolid4/changelog.Debian.gz
/usr/share/doc/libsolid4/copyright

Changelog

2017-05-10 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.26-2) unstable; urgency=medium
* Apply "java: set names in permission dialog" (bf0bd72)
This makes sure the reply from the user is used and sent back.
Backport of 856a96852f566ed7eb855810e347f95003c25017 and
bd4be07823e422fa15bf4273e0bb9df35b866e35 in khtml.
* Apply "cmake: look for hunspell-1.6 as well" (c828f85)
Fix build against hunspell 1.6
* Apply "Sanitize URLs before passing them to FindProxyForURL" (1804c2f)
Remove user/password information
For https: remove path and query
Backport from kio f9d0cb47cf94e209f6171ac0e8d774e68156a6e4
* Apply "khtml: Delete pointer _before_ returning" (ff6a9a2)
Fixup to commit 947ffe60 ("backport 02c3192 - Patch some memory leaks"),
which backported part of the fix in the wrong order, as it was first
returning and then deleting a pointer.
Noticed by Matthew Rezny <rezny@FreeBSD.org>.
* Apply "http slave: send error page after authorization failure" (b6f2022)
BUG: KDE#373323
Backport from KF5 kio
* Apply "Verify that whoever is calling us is actually who he says he is"
(264e976)
Fixes CVE-2017-8422 in kde4libs
2016-11-23 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.26-1) unstable; urgency=medium
[ Automatic packaging ]
* Update symbols files with the buildds logs.
* Refresh patches
[ Maximiliano Curia ]
* New upstream release (4.14.26)
* Build against libssl1.0-dev (Closes: 828363)
2016-10-17 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.25-1) unstable; urgency=medium
[ Automatic packaging ]
* Update symbols files with the buildds results
* Refresh patches
[ Maximiliano Curia ]
* New upstream release (4.14.25)
2016-08-18 - Pino Toscano <pino@debian.org>
kde4libs (4:4.14.23-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Disable the support for Strigi, since it is not developed anymore:
- make it not required anymore; patch optional_strigi.diff
- drop the libstreamanalyzer-dev build dependency
- backport upstream commit e328a020645899f25d0afccc196928783d6b59d1 to fix
symbols of KFileMetaInfo without it; patch
upstream_kio-fix-KFileMetaInfo-without-strigi.patch
* Update symbols files.
* Update the patches:
- upstream_Fix-wrong-value-of-__KDE_HAVE_GCC_VISIBILITY-on-syst.patch:
drop, backported from upstream
2016-08-17 - Pino Toscano <pino@debian.org>
kde4libs (4:4.14.22-3) unstable; urgency=medium
* Team upload.
* autopkgtest: switch from oxygen5-icon-theme back to the canonical
oxygen-icon-theme.
* Backport upstream commit e9b25c7c040d8526fe8675b97d1067c8ffa7249f to fix
the symbols visibility with GCC >= 6; patch
upstream_Fix-wrong-value-of-__KDE_HAVE_GCC_VISIBILITY-on-syst.patch.
* Fix the trunc detection, to avoid adding an implementation to kdefakes;
patch assume_trunc.diff, which obsoletes the wrong patch
fix_exception_specifier.diff.
* Update symbols files.
* Wrap too long entry in changelog for version 4:4.14.22-2.
* Remove README.Debian, since all its content was obsolete already after
Squeeze.
* Fix typo in NEWS file.
* Update lintian overrides.
2016-08-01 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.22-2) unstable; urgency=medium
* Fix the cve patch, so that it forces the target directory when the warning
is issued.
2016-07-19 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.22-1) unstable; urgency=medium
[ Maximiliano Curia ]
* Add new upstream patch: upstream_fix_compilation_with_gcc6.patch
(Closes: 811895) Thanks to Martin Michlmayr for reporting.
* Add new patch: fix_exception_specifier.diff
* Add new patch: add_missing_cast.diff
* Add new patch: cve-2016-6232.patch
- Fixes: CVE-2016-6232
[ Automatic packaging ]
* Refresh patches

See Also

Package Description
libsollya-dev_6.0+ds-1_amd64.deb library for safe floating-point code development -- libdev
libsollya6_6.0+ds-1_amd64.deb library for safe floating-point code development -- lib
libsolr-java_3.6.2+dfsg-10+deb9u2_all.deb Enterprise search server based on Lucene - Java libraries
libsolv-doc_0.6.24-1+deb9u1_all.deb dependency solver using a satisfiablility algorithm (documentation files)
libsolv-perl_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (Perl bindings)
libsolv-tools_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (command-line tools)
libsolv0-dev_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (development files)
libsolv0_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (shared library)
libsolvext0-dev_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (ext development files)
libsolvext0_0.6.24-1+deb9u1_amd64.deb dependency solver using a satisfiability algorithm (extensions)
libsombok-dev_2.4.0-1+b2_amd64.deb Unicode Text Segmentation library (development files)
libsombok3_2.4.0-1+b2_amd64.deb Unicode Text Segmentation library
libsonic-dev_0.2.0-4+b1_amd64.deb Header file for linking to libsonic
libsonic-java_0.2.0-4_all.deb Simple library to speed up or slow down speech - Java bindings
libsonic0_0.2.0-4+b1_amd64.deb Simple library to speed up or slow down speech
Advertisement
Advertisement