libgnustep-base1.24_1.24.9-3.1_amd64.deb


Advertisement

Description

libgnustep-base1.24 - GNUstep Base library

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package filename libgnustep-base1.24_1.24.9-3.1_amd64.deb
Package name libgnustep-base1.24
Package version 1.24.9
Package release 3.1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://gnustep.org
License -
Maintainer Debian GNUstep maintainers <pkg-gnustep-maintainers@lists.alioth.debian.org>
Download size 1.22 MB
Installed size 6.02 MB
The GNUstep Base Library is a powerful fast library of
general-purpose, non-graphical Objective C classes, inspired by the
OpenStep API but implementing Apple and GNU additions to the API as
well.  It includes for example classes for unicode strings, arrays,
dictionaries, sets, byte streams, typed coders, invocations,
notifications, notification dispatchers, scanners, tasks, files,
networking, threading, remote object messaging support (distributed
objects), event loops, loadable bundles, attributed unicode strings,
xml, mime, user defaults.

Alternatives

Package Version Architecture Repository
libgnustep-base1.24_1.24.9-3.1_i386.deb 1.24.9 i386 Debian Main
libgnustep-base1.24 - - -

Requires

Name Value
gnustep-base-common = 1.24.9-3.1
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libc6 >= 2.14
libffi6 >= 3.0.4
libgcc1 >= 1:3.0
libgmp10 -
libgnutls30 >= 3.5.6
libicu57 >= 57.1-1~
libobjc4 >= 4.6
libxml2 >= 2.9.0
libxslt1.1 >= 1.1.25
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgnustep-base1.24_1.24.9-3.1_amd64.deb
Source Package gnustep-base

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnustep-base1.24 deb package:
    # sudo apt-get install libgnustep-base1.24

Files

Path
/usr/lib/libgnustep-base.so.1.24
/usr/lib/libgnustep-base.so.1.24.9
/usr/share/doc/libgnustep-base1.24

Changelog

2017-02-03 - Andrey Rahmatullin <wrar@debian.org>
gnustep-base (1.24.9-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Add B-D: tzdata to fix a FTBFS (Closes: #839409).
2016-08-09 - Eric Heintzmann <heintzmann.eric@free.fr>
gnustep-base (1.24.9-3) unstable; urgency=medium
* New fix-thread-deadlock patch (Closes: #649419).
* New fix-test-icu2 patch (Closes: #833755).
* Build using default gobjc: update control file.
* Update description of fix-test-lock patch.
* Update debian/copyright file (Thanks to cme).
2016-06-27 - Eric Heintzmann <heintzmann.eric@free.fr>
gnustep-base (1.24.9-2) unstable; urgency=medium
* Display Tests/tests.log file if tests fail.
* Now Build-Depends on latest gobjc-5i.
* New fix-spelling-errors3 patch.
* Don't install config.log to avoid unreproducibility issue.
* Display config.log if configure script fails.
* New debian/libgnustep-base1.24.symbols.kfreebsd-amd64  file.
* New debian/libgnustep-base1.24.symbols.kfreebsd-i386 file.
* Thanks to Richard Frith-Macdonald:
+ New fix-ftbfs-hurd patch 
+ New fix-test-lock patch to avoid FTFS on non linux arch
+ New fix-ftbfs-s390x patch
+ New fix-ftbfs-kfreebsd patch
+ New fix-test-var-size patch
+ New fix-gdnc patch
+ New fix-tests-timings patch
+ New fix-test-var-size patch:
remove workaround for tests in debian/rules
+ Replace fix-test-chroot patch by fix-test-pipe patch.

See Also

Package Description
libgnustep-dl2-0d_0.12.0-15.1_amd64.deb bundle of runtime libraries for gnustep-dl2
libgnustep-dl2-dev_0.12.0-15.1_amd64.deb development files for gnustep-dl2 runtime libraries
libgnustep-gui-dev_0.25.0-4+b1_amd64.deb GNUstep GUI header files and static libraries
libgnustep-gui0.25_0.25.0-4+b1_amd64.deb GNUstep GUI Library
libgnutls-dane0_3.5.8-5+deb9u4_amd64.deb GNU TLS library - DANE security support
libgnutls-openssl27_3.5.8-5+deb9u4_amd64.deb GNU TLS library - OpenSSL wrapper
libgnutls28-dev_3.5.8-5+deb9u4_amd64.deb GNU TLS library - development files
libgnutls30_3.5.8-5+deb9u4_amd64.deb GNU TLS library - main runtime library
libgnutlsxx28_3.5.8-5+deb9u4_amd64.deb GNU TLS library - C++ runtime library
libgo-perl_0.15-5_all.deb perl modules for GO and other OBO ontologies
libgo9-alpha-cross_6.3.0-18cross1_all.deb Runtime library for GNU Go applications
libgo9-arm64-cross_6.3.0-18cross1_all.deb Runtime library for GNU Go applications
libgo9-armel-cross_6.3.0-18cross1_all.deb Runtime library for GNU Go applications
libgo9-armhf-cross_6.3.0-18cross1_all.deb Runtime library for GNU Go applications
libgo9-m68k-cross_6.3.0-18cross1_all.deb Runtime library for GNU Go applications
Advertisement
Advertisement