hexchat_2.12.4-3_amd64.deb


Advertisement

Description

hexchat - IRC client for X based on X-Chat 2

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package name hexchat
Package version 2.12.4
Package release 3
Package architecture amd64
Package type deb
Installed size 954 B
Download size 318.37 KB
Official Mirror ftp.br.debian.org
HexChat is a graphical IRC client with a GTK+ GUI. Features include Python
and Perl scripting support, a plugin API, multiple server/channel windows,
spell checking, multiple authentication methods including SASL,
and customizable notifications. For more information on IRC,
see http://irchelp.org/.

Alternatives

Package Version Architecture Repository
hexchat_2.12.4-3_i386.deb 2.12.4 i386 Debian Main
hexchat - - -

Requires

Name Value
hexchat-common = 2.12.4-3
libatk1.0-0 >= 1.12.4
libc6 >= 2.14
libcairo2 >= 1.2.4
libcanberra0 >= 0.2
libdbus-1-3 >= 1.9.14
libdbus-glib-1-2 >= 0.88
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.25.2
libglib2.0-0 >= 2.35.9
libgtk2.0-0 >= 2.24.0
libnotify4 >= 0.7.0
libpango-1.0-0 >= 1.29.4
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libproxy1v5 >= 0.4.14
libssl1.1 >= 1.1.0

Provides

Name Value
irc -

Download

Type URL
Binary Package hexchat_2.12.4-3_amd64.deb
Source Package hexchat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install hexchat deb package:
    # sudo apt-get install hexchat

Files

Path
/usr/bin/hexchat
/usr/share/appdata/hexchat.appdata.xml
/usr/share/applications/hexchat.desktop
/usr/share/doc/hexchat/changelog.Debian.gz
/usr/share/doc/hexchat/changelog.gz
/usr/share/doc/hexchat/copyright
/usr/share/lintian/overrides/hexchat

Changelog

2017-05-30 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.4-3) unstable; urgency=medium
* Demote hexchat-otr from Recommends to Suggests.
It reportely causes noise and problems for unexperienced users, and it's
a mostly unmaintained plugin, so don't install it by default.
2017-01-26 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.4-2) unstable; urgency=medium
* Also apply patch 4c178782a779f013fafab476506f7d4dae372b8a.patch on ubuntu.
* d/p/0001-Debian-server-defaults.patch: Add missing braces around the `if`.
Thanks to Lauri Alanko <la@iki.fi> for the patch.  Closes: #779892
2016-12-26 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.4-1) unstable; urgency=medium
* New upstream version 2.12.4.
* d/copyright: update (removal of the doat plugin).
* d/watch: improve:
+ Bump version to 4.
+ Use substitution strings @ANY_VERSION@ and @ARCHIVE_EXT@.
+ Ignore version 2.12.4-repack by mangling it into 2.12.4.
* d/control: mark hexchat-dev and hexchat-lua as Multi-Arch:same.
* d/patches/:
+ openssl/*: drop, applied upstream.
+ clean.patch: drop, applied upstream.
+ 4c178782a779f013fafab476506f7d4dae372b8a.patch: include from upstream to
work around a gdk-pixbuf bug which would prevent the hexchat icon from
being displayed in panels/systrays.  Closes: #848615
* d/rules: add a 'udoc' target to update the bundled copy of upstream doc.
* Update upstream documentation.
* d/hexchat-plugins.install: upstream converted the 'doat' plugin into an
internal command, so stop trying to install the plugin.
2016-12-19 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.3-4) unstable; urgency=medium
* Re-enable Lua support everywhere now that #845929 is fixed.
2016-12-05 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.3-3) unstable; urgency=medium
* Actually disable Lua support when building.
2016-12-05 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.3-2) unstable; urgency=medium
* Temporary restrict the build of hexchat-lua to the architectures where lua
is usable right now (see #845929).
2016-12-01 - Mattia Rizzolo <mattia@debian.org>
hexchat (2.12.3-1) unstable; urgency=medium
[ Jesse Rhodes ]
* Add hexchat-dev package for .pc and .h files.
* Include dbus service file in hexchat-common.
[ Mattia Rizzolo ]
* Take over maintenance from Jasse Rhodes.
Thank you for all your work these years!  Closes: #844574
* debian/control:
+ wrap-and-sort -ast.
+ Bump Standards-Version to 3.9.8, no changes needed.
+ Add proper Breaks/Replaces for the hexchat-dev addition-
+ Have hexchat-plugins recommend hwdata for the sysinfo plugin.
Closes: #845940
+ Have hexchat recommend the hexchat-otr plugin.
Thanks to Petter Reinholdtsen <pere@hungry.com> for the suggestion
+ Bump the Breaks/Replaces of hexchat-plugins against hexchat;
hexchat-plugin.pc has been moved from hexchat to hexchat-plugins
in 2.12.0-1.  LP: #1586239
+ Set appropriate Breaks/Replaces to cope with the Ubuntu delta and
make the package syncable.
+ Mark hexchat-common as Multi-Arch:foreign (from the m-a hinter).
* debian/rules:
+ Remove huge override_dh_auto_clean: if anything of that is needed,
it should be done on the upstream side.
+ Remove *.la files before running dh_install.
+ Use dh_install --fail-missing.
* Package the Lua plugin.  Closes: #834491
* Update upstream changelog for 2.13.2.
* Use dh_installchangelogs to install the upstream changelog, instead of
manually compressing in rules and the install with d/*.docs.
* Let the upstream build system put the manpage in place, instead of copying
it of our own.
* Add patch to properly clean the upstream sources and make possible to build
the package twice in a row.
* Bump debhelper compat level to 10.
+ --with autoreconf is now default.
* debian/copyright:
+ Make it DEP-5 compliant.
+ Update.
* Drop nearly all lintian overrides; they are either fixed or unused.

See Also

Package Description
hexcompare_1.0.4-1_amd64.deb utility to compare and identify binary files
hexcurse_1.58-1+b2_amd64.deb Ncurses-based hex editor with many features
hexec_0.2.1-3+b1_amd64.deb Command line tool to hook into exec calls
hexedit_1.3-1_amd64.deb view and edit files or devices in hexadecimal or ASCII
hexer_1.0.3-1_amd64.deb interactive binary editor with a Vi-like interface
hexter_1.0.2-3+b1_amd64.deb Yamaha DX7 modeling DSSI plugin
hexxagon_1.0pl1-3.1+b3_amd64.deb Hexagonal Ataxx clone
hfsplus_1.0.4-15_amd64.deb Tools to access HFS+ formatted volumes
hfsprogs_332.25-11+b2_amd64.deb mkfs and fsck for HFS and HFS+ file systems
hfst-ospell-dev_0.4.0~r4643-4+b2_amd64.deb HFST spell checker development files
hfst-ospell_0.4.0~r4643-4+b2_amd64.deb Spell checker library and tool based on HFST
hfst_3.10.0~r2798-3_amd64.deb Helsinki Finite-State Transducer Technology
hfsutils-tcltk_3.2.6-13+b1_amd64.deb Tcl/Tk interfaces for reading and writing Macintosh volumes
hfsutils_3.2.6-13+b1_amd64.deb Tools for reading and writing Macintosh volumes
hg-fast-export_20140308-1_all.deb mercurial to git converter using git-fast-import
Advertisement
Advertisement