gir1.2-appstream-1.0_0.10.6-2_amd64.deb


Advertisement

Description

gir1.2-appstream-1.0 - Library to access AppStream services (introspection data)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package filename gir1.2-appstream-1.0_0.10.6-2_amd64.deb
Package name gir1.2-appstream-1.0
Package version 0.10.6
Package release 2
Package architecture amd64
Package type deb
Category introspection
Homepage http://www.freedesktop.org/wiki/Distributions/AppStream/
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 13.97 KB
Installed size 53.00 KB
AppStream is a metadata specification, allowing to write metadata for
software projects in a standardized format. This allows software centers
to display useful information for not installed software, as well as
determining software the user might want to install (e.g. to open an
unknown file type or to make missing firmware available).
This package contains introspection data for the AppStream library.

Alternatives

Package Version Architecture Repository
gir1.2-appstream-1.0_0.10.6-2_i386.deb 0.10.6 i386 Debian Main
gir1.2-appstream-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libappstream4 = 0.10.6-2

Replaces

Name Value
gir1.2-appstream << 0.10.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gir1.2-appstream-1.0_0.10.6-2_amd64.deb
Source Package appstream

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-appstream-1.0 deb package:
    # sudo apt-get install gir1.2-appstream-1.0

Files

Path
/usr/lib/girepository-1.0/AppStream-1.0.typelib
/usr/share/doc/gir1.2-appstream-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-appstream-1.0/copyright

Changelog

2017-03-08 - Matthias Klumpp <mak@debian.org>
appstream (0.10.6-2) unstable; urgency=medium
* vala-deps.patch: Add Vala dependency file
- Fixes Vala builds which don't explicitly depend on GIO already.
* yaml-serialize-crash.patch: Don't crash when serializing components
with a session DBus provides to YAML.
* no-cache-if-no-cpts.patch: Don't attempt (and fail) to create a cache
if there are no components at all to serialize.
* no-gvfsd-root.patch: Ensure gvfsd and friends don't get spawned as
root (or at all in case of ascli). (Closes: #852696)
2017-01-22 - Matthias Klumpp <mak@debian.org>
appstream (0.10.6-1) unstable; urgency=medium
* New upstream version: 0.10.6
- APT will no longer download icons by default if
there are no GUI frontends available that use them (Closes: #847543)
- AppStream GUIs will need to tell APT that they require icons.
2016-12-22 - Matthias Klumpp <mak@debian.org>
appstream (0.10.5-1) unstable; urgency=medium
* New upstream version: 0.10.5
- Uses fnmatch on modalias provides (Closes: #841160)
- More verbose error messages on cache update failures (Closes: #820774)
* Update symbols file
2016-11-27 - Matthias Klumpp <mak@debian.org>
appstream (0.10.4-1) unstable; urgency=medium
* New upstream version: 0.10.4
* Bump debhelper compat level
2016-11-01 - Matthias Klumpp <mak@debian.org>
appstream (0.10.3-1) unstable; urgency=medium
* New upstream version: 0.10.3
* Update Qt package name for API break
2016-10-10 - Matthias Klumpp <mak@debian.org>
appstream (0.10.2-1) unstable; urgency=medium
* New upstream version: 0.10.2
* Update dependencies
- Drop intltool
- Add itstool, gettext
- Update minimum qtbase version
* Update symbols file
2016-10-03 - Matthias Klumpp <mak@debian.org>
appstream (0.10.1-2) unstable; urgency=medium
* Install metainfo file
2016-09-16 - Matthias Klumpp <mak@debian.org>
appstream (0.10.1-1) unstable; urgency=medium
* New upstream release: 0.10.1
* Drop patches: Applied upstream
* Fix GIR package name and use GIR dh addon (Closes: #837684)
* Add more multiarch metadata
* Properly clean up the global cache on purge
2016-08-31 - Matthias Klumpp <mak@debian.org>
appstream (0.10.0-2) unstable; urgency=medium
* cache-serialization.patch: Correctly (de)serialize screenshot data
* yaml-screenshot-image-type.patch: Set correct image type when
reading YAML
* addons-find-target.patch: Fix addon/target associations
2016-08-30 - Matthias Klumpp <mak@debian.org>
appstream (0.10.0-1) unstable; urgency=medium
* New upstream release: 0.10.0
* Refresh dependencies
* Build with stemming support
* Drop all patches: Applied upstream
* Update symbols file for ABI break

See Also

Package Description
gir1.2-appstreamglib-1.0_0.6.8-1_amd64.deb GObject introspection data for the libappstream-glib library
gir1.2-atk-1.0_2.22.0-1_amd64.deb ATK accessibility toolkit (GObject introspection)
gir1.2-atril_1.16.1-2+deb9u1_amd64.deb GObject introspection data for Atril
gir1.2-atspi-2.0_2.22.0-6+deb9u1_amd64.deb Assistive Technology Service Provider (GObject introspection)
gir1.2-bamf-3_0.5.3-2_amd64.deb GObject introspection data for the Bamf library
gir1.2-brasero-3.0_3.12.1-4_amd64.deb CD/DVD burning library for GNOME - GObject introspection data
gir1.2-budgie-desktop-1.0_10.2.9-2_amd64.deb GNOME introspection library for budgie-desktop
gir1.2-caja_1.16.6-1+deb9u1_amd64.deb GObject introspection data for Caja
gir1.2-caribou-1.0_0.4.21-1+b1_amd64.deb GObject introspection for the Caribou library
gir1.2-cattle-1.0_1.2.2-1_amd64.deb Brainfuck language toolkit (introspection files)
gir1.2-champlain-0.12_0.12.15-1_amd64.deb C library providing ClutterActor to display maps (GObject introspection)
gir1.2-cheese-3.0_3.22.1-1+b1_amd64.deb tool to take pictures and videos from your webcam - gir bindings
gir1.2-cinnamondesktop-3.0_3.2.4-4_amd64.deb Introspection data for CinnamonDesktop
gir1.2-clutter-1.0_1.26.0+dfsg-3_amd64.deb GObject introspection data for the Clutter 1.0 library
gir1.2-clutter-gst-3.0_3.0.24-1_amd64.deb Gobject introspection data for Clutter GStreamer elements
Advertisement
Advertisement