gambas3-gb-opengl_3.9.1-3_amd64.deb


Advertisement

Description

gambas3-gb-opengl - Gambas OpenGL component

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main amd64
Package filename gambas3-gb-opengl_3.9.1-3_amd64.deb
Package name gambas3-gb-opengl
Package version 3.9.1
Package release 3
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://gambas.sourceforge.net
License -
Maintainer Gambas Debian Maintainers <pkg-gambas-devel@lists.alioth.debian.org>
Download size 37.57 KB
Installed size 200.00 KB
Gambas is a free development environment based on a Basic interpreter
with object extensions, like Visual Basic(tm) (but it is NOT a clone!).
This package allows you 3D programming with OpenGL in gambas.

Alternatives

Package Version Architecture Repository
gambas3-gb-opengl_3.9.1-3_i386.deb 3.9.1 i386 Debian Main
gambas3-gb-opengl - - -

Requires

Name Value
gambas3-gb-image >= 3.9.1-3
gambas3-runtime >= 3.9.1-3
libc6 >= 2.3.4
libgl1 -
libgl1-mesa-glx -
libglew2.0 >= 1.12.0
libglu1 -
libglu1-mesa -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gambas3-gb-opengl_3.9.1-3_amd64.deb
Source Package gambas3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gambas3-gb-opengl deb package:
    # sudo apt-get install gambas3-gb-opengl

Files

Path
/usr/lib/gambas3/gb.opengl.component
/usr/lib/gambas3/gb.opengl.so
/usr/lib/gambas3/gb.opengl.so.0
/usr/lib/gambas3/gb.opengl.so.0.0.0
/usr/share/doc/gambas3-gb-opengl/changelog.Debian.gz
/usr/share/doc/gambas3-gb-opengl/changelog.gz
/usr/share/doc/gambas3-gb-opengl/copyright
/usr/share/gambas3/info/gb.opengl.info
/usr/share/gambas3/info/gb.opengl.list

Changelog

2017-01-07 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.9.1-3) unstable; urgency=medium
* Team Upload
* Drop libmodplug-dev, useless
(Closes: #850525)
2016-12-09 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.9.1-2) unstable; urgency=medium
* Team Upload
[ Josh Triplett ]
* Add new programming language sections (Closes: #847533)
2016-10-08 - José L. Redrejo Rodríguez <jredrejo@debian.org>
gambas3 (3.9.1-1) unstable; urgency=medium
[ Ian Haywood ]
* New upstream version (Closes: #837541, #838309)
[ José L. Redrejo Rodríguez ]
* Fixed build dependencies 
* Removed gitignore files from upstream when building the debs
2016-07-01 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-6) unstable; urgency=medium
* debian/patches/openssl-fixes.patch:
- fix openssl 1.1 incompatibilities (Closes: #828307)
2016-06-30 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-5) unstable; urgency=medium
* Team upload
* Revert my previous change, because it breaks some arch:all
build.
2016-06-30 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-4) unstable; urgency=medium
[ Pino Toscano ]
* Fix compilation on hurd, by restricting the architecures list
(Closes: #829056)
* Remove useless kdelibs5-dev dependency (Closes: #829058)
[ Gianfranco Costamagna ]
* Team upload
* Fix installation on hurd, by restricting the gambas3 dependencies
(where not built)
2016-06-15 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-3) unstable; urgency=medium
[ Ian Haywood ]
* patch to use Qt5 preferentially over Qt4. This way the IDE works when both Qt4 and Qt5 present. 
* Remove Conflicts on Qt4 for the the IDE as now unnecessary (Closes: #814862)
[ Gianfranco Costamagna ]
* Team upload.
* Fix unsecure VCS uri.
* Disable jit package, not llvm-3.6+ ready.
* Bump std-version to 3.9.8, no changes required.
* debian/patches/fix-build-failure.patch.
- cherry-pick upstream r7740 to fix build failure.
[ trek00@inbox.ru ]
* Tweak gb.gui dependencies to not force many graphic implementations
(Closes: #823908)
2016-01-05 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-2) unstable; urgency=medium
* Team upload.
* Switch to libpng-dev to ease libpng transition (Closes: #809862).
2015-12-16 - Gianfranco Costamagna <locutusofborg@debian.org>
gambas3 (3.8.4-1) unstable; urgency=medium
* Team upload.
* Upload to unstable
* Update libgsl0-dev to libgsl-dev, to ease gsl transition.
* Remove deprecated menu file (Per the tech-ctte decision on #741573)
* Disable qt4 webkit (Closes: #784465).
* New upstream release, drop gnu_support patch, merged upstream
(Closes: #807061).
* Add breaks+replaces for gb-desktop{x11} package. (Closes: #787921)
* Drop -examples package, dropped upstream.
* Add new pacages: gambas3-gb-report2 gambas3-gb-sdl2-audio gambas3-gb-sdl2
gambas3-gb-util gambas3-gb-util-web gambas3-gb-scanner
* Add some new build-dependencies, needed for new sdl2 packages:
libsdl2-dev, libsdl2-image-dev, libsdl2-mixer-dev, libsdl2-ttf-dev
* Fix some install files.
* Drop DejaVuSans.ttf sdl link, dropped in version 3.5.3
* Add xdg-utils as build-dependency, needed to correctly handle mimes.
* fix copyright file, adding missing svg CC-by-sa licenses, removing some old
entries, making it really machine readable, add some public domain licenses
(Closes: #787761)
* Remove llvm-dev build-dependency, forcing llvm-3.5 (there is no planned
porting on top of a newer llvm release
(http://gambaswiki.org/bugtracker/edit?object=BUG.835).
* Simplify libv4l-dev build-dependency.
* Stop building gambas3-gb-inotify package on kfreebsd-* (missing libc header)
* move webkit support in new qt5 package.

See Also

Package Description
gambas3-gb-openssl_3.9.1-3_amd64.deb Gambas OpenSSL component
gambas3-gb-option_3.9.1-3_amd64.deb Gambas option component
gambas3-gb-pcre_3.9.1-3_amd64.deb Gambas regexp component
gambas3-gb-pdf_3.9.1-3_amd64.deb Gambas pdf component
gambas3-gb-qt4-ext_3.9.1-3_amd64.deb Gambas extended Qt GUI component
gambas3-gb-qt4-opengl_3.9.1-3_amd64.deb Gambas OpenGL component with QT4 toolkit
gambas3-gb-qt4_3.9.1-3_amd64.deb Gambas Qt GUI component
gambas3-gb-qt5-ext_3.9.1-3_amd64.deb Gambas extended Qt GUI component
gambas3-gb-qt5-opengl_3.9.1-3_amd64.deb Gambas OpenGL component with QT5 toolkit
gambas3-gb-qt5-webkit_3.9.1-3_amd64.deb Gambas WebKit component
gambas3-gb-qt5_3.9.1-3_amd64.deb Gambas Qt5 GUI component
gambas3-gb-report2_3.9.1-3_all.deb Gambas report2 component
gambas3-gb-report_3.9.1-3_all.deb Gambas report component
gambas3-gb-scanner_3.9.1-3_amd64.deb Gambas scanner component
gambas3-gb-sdl-sound_3.9.1-3_amd64.deb Gambas SDL sound component
Advertisement
Advertisement