libstarpu-contribfft-1.2-0_1.2.0+dfsg-4_amd64.deb


Advertisement

Description

libstarpu-contribfft-1.2-0 - Task scheduler for heterogeneous multicore machines

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Contrib amd64
Package name libstarpu-contribfft-1.2-0
Package version 1.2.0+dfsg
Package release 4
Package architecture amd64
Package type deb
Installed size 97 B
Download size 34.50 KB
Official Mirror ftp.br.debian.org
StarPU is a runtime system that offers support for heterogeneous
multicore machines. While many efforts are devoted to design efficient
computation kernels for those architectures (e.g. to implement BLAS
kernels on GPUs or on Cell's SPUs), StarPU not only takes care of
offloading such kernels (and implementing data coherency across
the machine), but it also makes sure the kernels are executed as
efficiently as possible.
This package contains a hybrid CPU+GPU FFT library.

Alternatives

Package Version Architecture Repository
libstarpu-contribfft-1.2-0 - - -

Requires

Name Value
libc6 >= 2.4
libcublas8.0 >= 2.0
libcuda1 >= 169
libcudart8.0 >= 2.0
libcufft8.0 >= 2.3
libfftw3-double3 >= 3.3.5
libfftw3-single3 >= 3.3.5
libopencl1 -
libstarpu-contrib-1.2-0 -
libstdc++6 >= 4.1.1
ocl-icd-libopencl1 -

Provides

Name Value
libstarpufft-1.2-0 -

Conflicts

Name Value
libstarpufft-1.2-0 -

Download

Type URL
Binary Package libstarpu-contribfft-1.2-0_1.2.0+dfsg-4_amd64.deb
Source Package starpu-contrib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libstarpu-contribfft-1.2-0 deb package:
    # sudo apt-get install libstarpu-contribfft-1.2-0

Files

Path
/usr/lib/x86_64-linux-gnu/libstarpufft-1.2.so.0
/usr/lib/x86_64-linux-gnu/libstarpufft-1.2.so.0.0.0
/usr/share/doc/libstarpu-contribfft-1.2-0/changelog.Debian.gz
/usr/share/doc/libstarpu-contribfft-1.2-0/changelog.gz
/usr/share/doc/libstarpu-contribfft-1.2-0/copyright

Changelog

2017-03-08 - Samuel Thibault <sthibault@debian.org>
starpu-contrib (1.2.0+dfsg-4) unstable; urgency=medium
* control: Make libstarpu-contrib-dev depend on libsocl-contrib
(Closes: Bug#857163)
2017-01-22 - Samuel Thibault <sthibault@debian.org>
starpu-contrib (1.2.0+dfsg-3) unstable; urgency=medium
* Run the full testsuite even if there are failures.
* control [contrib]: Build-Depend on clang-3.8 instead of gcc-5
* rules: Pass -ccbin clang-3.8 (Closes: Bug#835941).
* patches/nvcc_noccbin: Avoid overriding our -ccbin option.
2016-10-25 - Samuel Thibault <sthibault@debian.org>
starpu (1.2.0+dfsg-2) unstable; urgency=medium
* debian/rules: Also set FC to set gfortran version.
2016-08-25 - Samuel Thibault <sthibault@debian.org>
starpu (1.2.0+dfsg-1) unstable; urgency=medium
* New upstream release.
- Fix final soname version.
- Drop the documentation that we already generate from the tarball.
- patches/openmp-valgrind: Remove, merged upstream
- patches/examples: backport upstream fix to properly build some examples.
- copyright: Use BSD-uthash licence name for uthash.h, since it is a
modified BSD licence (Only the first item is kept, about keeping notices
in source code redistribution)
- copyright: Move standard licence texts to the end of the file.
- copyright: Label the CL headers as Expat licence since that's it.
* Downgrade opencl-headers build-dep to opencl-c-headers.
(Closes: Bug#837911).
* Build starpu-contrib on non-amd64 too (Closes: Bug#840559).
2015-07-07 - Samuel Thibault <sthibault@debian.org>
starpu (1.2.0~rc2+dfsg-2) experimental; urgency=medium
* Fix libsocl conflicting package names (Closes: Bug#779599).
2015-03-03 - Samuel Thibault <sthibault@debian.org>
starpu (1.2.0~rc2+dfsg-1) experimental; urgency=medium
* New upstream release.
- Rename libstarpu-1.2-0 to libstarpu-1.2-1 according to soname bump.
* Merge unstable changes (Closes: Bug#779599).
2014-12-10 - Samuel Thibault <sthibault@debian.org>
starpu (1.2.0~20141210+dfsg-1) experimental; urgency=medium
* New upstream snapshot.
- Bump sonames to 1.2-0.
- control: Add libleveldb-dev.
- rules: Add --enable-openmp.
2016-07-14 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.4+dfsg-6) unstable; urgency=medium
* debian/patches/cnf: Drop testing for unused f77.h.
* control:
- Bump Standards-Version to 3.9.8 (no change)
- Drop actually-unused libcnf-dev dependency.
2016-05-03 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.4+dfsg-5) unstable; urgency=medium
* Drop i386 arch from contrib, CUDA only supports amd64 nowadays.
* watch: Update to submission from bartm.
* rules: Use dpkg-parsechangelog.
* control: Bump Standards-Version to 3.9.7 (no change).
* starpu-examples.install: Add missing OpenCL programs.
* Bump starpu-contrib gcc dependency to 5, now that CUDA 7.5 is in
(Closes: Bug#818764).
2015-12-08 - Samuel Thibault <sthibault@debian.org>
starpu (1.1.4+dfsg-4) unstable; urgency=medium
* patches/sm_13: New patch from upstream to drop requesting sm_13
architecture support, available since long. Fixes build with cuda 7.

See Also

Package Description
libstarpu-contribmpi-1.2-0_1.2.0+dfsg-4_amd64.deb Task scheduler for heterogeneous multicore machines
libuutil1linux_0.6.5.9-5_amd64.deb Solaris userland utility library for Linux
libydpdict2-dev_1.0.4-3_amd64.deb library for reading Collins dictionaries - development files
libydpdict2_1.0.4-3_amd64.deb library for reading Collins dictionaries
libzfs2linux_0.6.5.9-5_amd64.deb OpenZFS filesystem library for Linux
libzfslinux-dev_0.6.5.9-5_amd64.deb OpenZFS filesystem development files for Linux
libzpool2linux_0.6.5.9-5_amd64.deb OpenZFS pool library for Linux
mathematica-fonts_20_all.deb transitional dummy package
matlab-gdf_0.1.2-2_all.deb IO library for the GDF -- Matlab interface
matlab-support_0.0.21_all.deb distro integration for local MATLAB installations
mess-desktop-entries_0.2-2_all.deb Desktop entries for MESS ROMs
microcode.ctl_1.18~0+nmu2_amd64.deb Intel IA32/IA64 CPU Microcode Utility (transitional package)
nvidia-installer-cleanup_20151021+4_amd64.deb cleanup after driver installation with the nvidia-installer
nvidia-kernel-common_20151021+4_amd64.deb NVIDIA binary kernel module support files
nvidia-modprobe_390.87-1~deb9u1_amd64.deb utility to load NVIDIA kernel modules and create device nodes
Advertisement
Advertisement