libnvvm2_6.0.37-5_i386.deb


Advertisement

Description

libnvvm2 - NVIDIA NVVM Library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Nonfree i386
Package filename libnvvm2_6.0.37-5_i386.deb
Package name libnvvm2
Package version 6.0.37
Package release 5
Package architecture i386
Package type deb
Category non-free/libs role::shared-lib
Homepage https://developer.nvidia.com/cuda-llvm-compiler
License -
Maintainer Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Download size 3.94 MB
Installed size 12.44 MB
NVIDIA's CUDA Compiler (NVCC) is based on the widely used LLVM open source
compiler infrastructure.
The NVVM library is used by NVCC to compile CUDA binary code to run on NVIDIA
GPUs.
This package contains the NVIDIA NVVM runtime library.

Alternatives

Package Version Architecture Repository
libnvvm2_6.0.37-5_amd64.deb 6.0.37 amd64 Debian Nonfree
libnvvm2 - - -

Requires

Name Value
libc6 >= 2.3.6-6~
multiarch-support -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnvvm2_6.0.37-5_i386.deb
Source Package nvidia-cuda-toolkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnvvm2 deb package:
    # sudo apt-get install libnvvm2

Files

Path
/usr/lib/i386-linux-gnu/libnvvm.so.2
/usr/lib/i386-linux-gnu/libnvvm.so.2.0.0
/usr/share/doc/libnvvm2/changelog.Debian.gz
/usr/share/doc/libnvvm2/copyright
/usr/share/lintian/overrides/libnvvm2

Changelog

2014-11-21 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-5) unstable; urgency=medium
* nvidia-opencl-dev: Bump Breaks/Replaces on nvidia-libopencl1 from
(<< 304.88-7~) to (<< 305~) to cover all versions that could end up in
wheezy. New nvidia-graphics-drivers upstream releases from the 304.xx
legacy series fixing security bugs have been uploaded to stable
previously. The package in wheezy (current version: 304.117-1) still
contains libOpenCL.so while the package in sid stopped shipping this
symbolic link in 304.88-7.
2014-10-12 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-4) unstable; urgency=medium
* libnvblas6.0 is only available on amd64. 
* nvidia-cuda-dev: Add Recommends: libnvcuvid1.
* nvidia-cuda-dev: Remove some header file workaround symlinks.
* Update documentation regarding downloading, installing and building the
CUDA Code Samples.
* Update library package descriptions from cuda-libraries(7).
2014-10-10 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-3) unstable; urgency=medium
* Bump Standards-Version to 3.9.6 (no changes needed).
* Upload to unstable.
2014-09-30 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-2) experimental; urgency=medium
[ Graham Inggs ]
* Add missing Breaks/Replaces on libcuinj{32,64}-5.5.  (Closes: #763177)
[ Andreas Beckmann ]
* Add wrapper script for nvprof due to its insane library search behavior.
* Add compat symlinks for libcuinj{32,64}.so.6.0 to the real nvprof's
bindir.  (Closes: #761363)
* nvidia-cuda-doc: Remove more tracking scripts.
* Ship the new upstream manpages.
* Fix typos, hyphenation, and sections in the manpages.
* Implement minimal quilt based patch system that is activated after
unpacking the .run files.
* libnvblas6.0: New package for the NVBLAS runtime library.
* Update lintian overrides.
2014-09-08 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-1) experimental; urgency=medium
* New upstream release 6.0 (April 2014).  (Closes: #751522)
* Upload to experimental.
* debian/copyright: Synchronize with updated EULA.txt.
* SOVERSION bump: 5.5 => 6.0, rename all library packages.
* Update symbols control files.
2014-09-28 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-6) unstable; urgency=medium
[ Andreas Beckmann ]
* Move libcuinj{32,64}-5.5 dependency from nvidia-visual-profiler to
nvidia-profiler.
* Move libcuinj{32,64}.so back to nvidia-cuda-dev, nvprof now dlopen()s the
proper soname.  (Closes: #763177)
* nvidia-cuda-dev: Upgrade libcuda.so dependency from Recommends to Depends.
* nvidia-cuda-doc: Remove tracking scripts and images.
* Update lintian overrides.
[ Graham Inggs]
* New package descriptions to satisfy lintian description-is-pkg-name.
2014-09-08 - Graham Inggs <graham@nerve.org.za>
nvidia-cuda-toolkit (5.5.22-5) unstable; urgency=medium
[ Andreas Beckmann ]
* Add Graham Inggs to Uploaders.
[ Graham Inggs ]
* Do not prevent the use of GCC 4.9.  (Closes: #757961)
* Add missing Breaks/Replaces to nvidia-opencl-dev for a clean takeover of
the libOpenCL.so symlink from {amd,nvidia,ocl-icd}-libopencl1.
(Closes: #760554)
2014-05-25 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-4) unstable; urgency=low
* Bump the alternate virtual libcuda dependency to libcuda-5.5-1.
* Remove alternate (Build-)Depends on nvidia-current.  (Closes: #745149)
* Add libopencl-1.1-1 as alternate virtual libopencl1 dependency.
* Update lintian overrides.
* Remove switch for non-multiarch builds.
2013-11-07 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-3) unstable; urgency=low
* Bump the alternate virtual B-D to libcuda-5.5-1.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Upload to unstable.

See Also

Package Description
libparmetis-dev_3.1.1-4+b1_i386.deb Parallel Graph Partitioning and Sparse Matrix Ordering Libs: Devel
libparmetis3.1_3.1.1-4+b1_i386.deb Parallel Graph Partitioning and Sparse Matrix Ordering Shared Libs
libstar-parser-perl_0.59-4_all.deb STAR compliant data file parser for Perl
libtriangle-1.6_1.6-2_i386.deb High-quality 2-D mesh generator shared library
libtriangle-dev_1.6-2_i386.deb High-quality 2-D mesh generator development files
libttspico-data_1.0+git20130326-3_all.deb Small Footprint TTS (lingware)
libttspico-dev_1.0+git20130326-3_i386.deb Small Footprint TTS (development files)
libttspico-utils_1.0+git20130326-3_i386.deb Small Footprint TTS (binaries)
libttspico0_1.0+git20130326-3_i386.deb Small Footprint TTS (library)
libvideo-info-perl_0.993-2_all.deb Perl module to examine video files
libvmtk-dev_1.0.1-3+b1_i386.deb shared links and header files for vmtk
libvmtk1.0_1.0.1-3+b1_i386.deb runtime libraries for vmtk
libxvbaw-dev_15.9-4~deb8u2_i386.deb AMD XvBA (X-Video Bitstream Acceleration) development files
lugaru-data_0~20110520.1+hge4354-2_all.deb transitional dummy package
madfuload_1.2-4+deb8u1_i386.deb Firmware loader for M-Audio DFU audio devices
Advertisement
Advertisement