libcupti-dev_6.0.37-5_i386.deb


Advertisement

Description

libcupti-dev - NVIDIA CUDA Profiler Tools Interface development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Nonfree i386
Package filename libcupti-dev_6.0.37-5_i386.deb
Package name libcupti-dev
Package version 6.0.37
Package release 5
Package architecture i386
Package type deb
Category devel::library non-free/libdevel role::devel-lib
Homepage http://developer.nvidia.com/cuda-profiling-tools-interface
License -
Maintainer Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Download size 61.88 KB
Installed size 431.00 KB
The CUDA Profiler Tools Interface (CUPTI) enables the creation of
profiling and tracing tools that target CUDA applications.  CUPTI
provides a set of APIs targeted at ISVs creating profilers and other
performance optimization tools. The CUPTI APIs are not intended to be
used by developers in their CUDA applications.
This package contains the development files: headers and libraries.

Alternatives

Package Version Architecture Repository
libcupti-dev_6.0.37-5_amd64.deb 6.0.37 amd64 Debian Nonfree
libcupti-dev - - -

Requires

Name Value
libcupti6.0 = 6.0.37-5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcupti-dev_6.0.37-5_i386.deb
Source Package nvidia-cuda-toolkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcupti-dev deb package:
    # sudo apt-get install libcupti-dev

Files

Path
/usr/include/cuda_stdint.h
/usr/include/cupti.h
/usr/include/cupti_activity.h
/usr/include/cupti_callbacks.h
/usr/include/cupti_driver_cbid.h
/usr/include/cupti_events.h
/usr/include/cupti_metrics.h
/usr/include/cupti_nvtx_cbid.h
/usr/include/cupti_result.h
/usr/include/cupti_runtime_cbid.h
/usr/include/cupti_version.h
/usr/include/generated_cudaGL_meta.h
/usr/include/generated_cudaVDPAU_meta.h
/usr/include/generated_cuda_gl_interop_meta.h
/usr/include/generated_cuda_meta.h
/usr/include/generated_cuda_runtime_api_meta.h
/usr/include/generated_cuda_vdpau_interop_meta.h
/usr/include/generated_nvtx_meta.h
/usr/lib/i386-linux-gnu/libcupti.so
/usr/share/doc/libcupti-dev/changelog.Debian.gz
/usr/share/doc/libcupti-dev/copyright
/usr/share/lintian/overrides/libcupti-dev

Changelog

2014-11-21 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-5) unstable; urgency=medium
* nvidia-opencl-dev: Bump Breaks/Replaces on nvidia-libopencl1 from
(<< 304.88-7~) to (<< 305~) to cover all versions that could end up in
wheezy. New nvidia-graphics-drivers upstream releases from the 304.xx
legacy series fixing security bugs have been uploaded to stable
previously. The package in wheezy (current version: 304.117-1) still
contains libOpenCL.so while the package in sid stopped shipping this
symbolic link in 304.88-7.
2014-10-12 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-4) unstable; urgency=medium
* libnvblas6.0 is only available on amd64. 
* nvidia-cuda-dev: Add Recommends: libnvcuvid1.
* nvidia-cuda-dev: Remove some header file workaround symlinks.
* Update documentation regarding downloading, installing and building the
CUDA Code Samples.
* Update library package descriptions from cuda-libraries(7).
2014-10-10 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-3) unstable; urgency=medium
* Bump Standards-Version to 3.9.6 (no changes needed).
* Upload to unstable.
2014-09-30 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-2) experimental; urgency=medium
[ Graham Inggs ]
* Add missing Breaks/Replaces on libcuinj{32,64}-5.5.  (Closes: #763177)
[ Andreas Beckmann ]
* Add wrapper script for nvprof due to its insane library search behavior.
* Add compat symlinks for libcuinj{32,64}.so.6.0 to the real nvprof's
bindir.  (Closes: #761363)
* nvidia-cuda-doc: Remove more tracking scripts.
* Ship the new upstream manpages.
* Fix typos, hyphenation, and sections in the manpages.
* Implement minimal quilt based patch system that is activated after
unpacking the .run files.
* libnvblas6.0: New package for the NVBLAS runtime library.
* Update lintian overrides.
2014-09-08 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (6.0.37-1) experimental; urgency=medium
* New upstream release 6.0 (April 2014).  (Closes: #751522)
* Upload to experimental.
* debian/copyright: Synchronize with updated EULA.txt.
* SOVERSION bump: 5.5 => 6.0, rename all library packages.
* Update symbols control files.
2014-09-28 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-6) unstable; urgency=medium
[ Andreas Beckmann ]
* Move libcuinj{32,64}-5.5 dependency from nvidia-visual-profiler to
nvidia-profiler.
* Move libcuinj{32,64}.so back to nvidia-cuda-dev, nvprof now dlopen()s the
proper soname.  (Closes: #763177)
* nvidia-cuda-dev: Upgrade libcuda.so dependency from Recommends to Depends.
* nvidia-cuda-doc: Remove tracking scripts and images.
* Update lintian overrides.
[ Graham Inggs]
* New package descriptions to satisfy lintian description-is-pkg-name.
2014-09-08 - Graham Inggs <graham@nerve.org.za>
nvidia-cuda-toolkit (5.5.22-5) unstable; urgency=medium
[ Andreas Beckmann ]
* Add Graham Inggs to Uploaders.
[ Graham Inggs ]
* Do not prevent the use of GCC 4.9.  (Closes: #757961)
* Add missing Breaks/Replaces to nvidia-opencl-dev for a clean takeover of
the libOpenCL.so symlink from {amd,nvidia,ocl-icd}-libopencl1.
(Closes: #760554)
2014-05-25 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-4) unstable; urgency=low
* Bump the alternate virtual libcuda dependency to libcuda-5.5-1.
* Remove alternate (Build-)Depends on nvidia-current.  (Closes: #745149)
* Add libopencl-1.1-1 as alternate virtual libopencl1 dependency.
* Update lintian overrides.
* Remove switch for non-multiarch builds.
2013-11-07 - Andreas Beckmann <anbe@debian.org>
nvidia-cuda-toolkit (5.5.22-3) unstable; urgency=low
* Bump the alternate virtual B-D to libcuda-5.5-1.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Upload to unstable.

See Also

Package Description
libcupti-doc_6.0.37-5_all.deb NVIDIA CUDA Profiler Tools Interface documentation
libcupti6.0_6.0.37-5_i386.deb NVIDIA CUDA Profiler Tools Interface runtime library
libcurand6.0_6.0.37-5_i386.deb NVIDIA cuRAND Library
libcusparse6.0_6.0.37-5_i386.deb NVIDIA cuSPARSE Library
libcwd-doc_1.0.4-1.1_all.deb Documentation of the libcwd C++ Debugging Support Library
libcwd_1.0.4-1.1_i386.deb C++ Debugging Support Library
libegl1-nvidia_340.106-1_i386.deb NVIDIA binary EGL library
libertas-firmware_9.70.7.p0.0-2_all.deb Firmware for Marvell's libertas wireless chip series (dummy package)
libf2j-java_0.8.1-2_all.deb Java library port of Fortran numerical libraries
libfaac-dev_1.28-6_i386.deb AAC audio encoder (development)
libfaac0_1.28-6_i386.deb AAC audio encoder (library)
libfdk-aac-dev_0.1.3+20140816-2_i386.deb Fraunhofer FDK AAC Codec Library - development files
libfdk-aac0_0.1.3+20140816-2_i386.deb Fraunhofer FDK AAC Codec Library - runtime files
libfglrx-amdxvba1_15.9-4~deb8u2_i386.deb AMD XvBA (X-Video Bitstream Acceleration) backend for VA API
libfglrx_15.9-4~deb8u2_i386.deb non-free ATI/AMD RadeonHD display driver (runtime libraries)
Advertisement
Advertisement