python3-pykcs11_1.3.0-1_i386.deb


Advertisement

Description

python3-pykcs11 - PKCS#11 wrapper for Python

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python3-pykcs11
Package version 1.3.0
Package release 1
Package architecture i386
Package type deb
Installed size 668 B
Download size 136.61 KB
Official Mirror ftp.br.debian.org
PyKCS11 let you access to almost all PKCS#11 functions and data types using
any PKCS#11 library, such as the various modules supplied by smartcard
vendors.
The wrapper comes with 2 interfaces: a low level and very thin interface over
the original PKCS#11 API, generated using the SWIG compiler (designed for
library tests); and an high level interface that offers a simpler access (with
few limits) to the PKCS#11 APIs.
Keywords: pkcs11

Alternatives

Package Version Architecture Repository
python3-pykcs11_1.3.0-1_amd64.deb 1.3.0 amd64 Debian Main
python3-pykcs11 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.9
python3 >= 3.4~
python3 << 3.5

Download

Type URL
Binary Package python3-pykcs11_1.3.0-1_i386.deb
Source Package pykcs11

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-pykcs11 deb package:
    # sudo apt-get install python3-pykcs11

Files

Path
/usr/lib/python3/dist-packages/PyKCS11-1.3.0.egg-info
/usr/lib/python3/dist-packages/PyKCS11/LowLevel.py
/usr/lib/python3/dist-packages/PyKCS11/_LowLevel.cpython-34m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/PyKCS11/__init__.py
/usr/share/doc/python3-pykcs11/changelog.Debian.gz
/usr/share/doc/python3-pykcs11/copyright
/usr/share/doc/python3-pykcs11/readme.txt
/usr/share/doc/python3-pykcs11/examples/dumpit.py.gz
/usr/share/doc/python3-pykcs11/examples/getinfo.py.gz
/usr/share/doc/python3-pykcs11/examples/unblock.py
/usr/share/doc/python3-pykcs11/examples/LowLevel/InitTokenPin.py
/usr/share/doc/python3-pykcs11/examples/LowLevel/dumpit.py.gz
/usr/share/doc/python3-pykcs11/examples/LowLevel/test.py
/usr/share/doc/python3-pykcs11/examples/LowLevel/test1.py.gz

Changelog

2014-07-26 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.3.0-1) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Ludovic Rousseau ]
* update Homepage: field
* New upstream release
* use dh compatibility level 9 to get hardening
* move to Python 3.x
* debian/control: Standards-Version: 3.9.3 -> 3.9.5. No change needed.
2012-04-21 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.4-1) unstable; urgency=low
* New upstream release
* debian/control: Standards-Version: 3.9.2 -> 3.9.3. No change needed.
2011-08-05 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-6) unstable; urgency=low
* Fix "Can't be found with "apt-cache search pkcs11 python""
Add a Keywords: line in the package long description (Closes: #636163)
2011-04-23 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-5) unstable; urgency=low
* rebuild to add support of python 2.7 and remove support of python 2.5
* debian/control: Standards-Version: 3.9.1 -> 3.9.2, no change needed.
2011-04-23 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-4) unstable; urgency=low
* debian/rules: use a minimal version
2011-03-09 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-3) unstable; urgency=low
* Fix "deprecation of dh_pycentral, please use dh_python2" by using
dh_python2 (Closes: #616969)
* debian/rules: add --install-layout=deb
2011-02-09 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-2) unstable; urgency=low
* upload to unstable
2010-12-03 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.3-1) experimental; urgency=low
* New upstream release
* debian/control: Standards-Version: 3.8.4 -> 3.9.1, no change needed
2010-06-16 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.2-1) unstable; urgency=low
* New upstream release
* debian/control: Fix lintian I: pykcs11 source:
binary-control-field-duplicates-source field "section" in package
python-pykcs11
* debian/control: Standards-Version: 3.8.3 -> 3.8.4, no change needed
* debian/source/format: change from "1.0" to "3.0 (quilt)" to easily patch
the package
2009-11-14 - Ludovic Rousseau <rousseau@debian.org>
pykcs11 (1.2.1-3) unstable; urgency=low
* debian/rules: allow to build without python2.4 (and with python2.6)
* debian/control: Standards-Version: 3.8.1 -> 3.8.3. no change needed.

See Also

Package Description
python3-pykde4_4.14.0-1_i386.deb Python 3 bindings for the KDE Development Platform
python3-pykka_1.2.0-2_all.deb Actor model library for Python (Python 3)
python3-pylast_1.0.0-1_all.deb Python 3 interface to Last.fm and other compatible services
python3-pyld_0.6.2-1_all.deb implementation of the JSON-LD API
python3-pylibacl_0.5.2-1_i386.deb module for manipulating POSIX.1e ACLs (Python3 version)
python3-pymemcache_1.2.4-2_all.deb comprehensive, fast, pure Python memcached client - Python 3.x
python3-pymongo-ext_2.7.2-1_i386.deb C-coded extension to the python3-pymongo package
python3-pymongo_2.7.2-1_i386.deb Python3 interface to the MongoDB document-oriented database
python3-pyopencl_2014.1-3_i386.deb Python 3 module to access OpenCL parallel computation API
python3-pyparsing_2.0.3+dfsg1-1_all.deb Python parsing module, Python3 package
python3-pypdf2_1.23+git20141008-1+deb8u1_all.deb Pure-Python library built as a PDF toolkit (Python 3)
python3-pyproj_1.8.9-1.1+b2_i386.deb Python 3 interface to PROJ.4 library
python3-pyqt4.phonon_4.11.2+dfsg-1_i386.deb Python3 bindings for Phonon
python3-pyqt4.qsci_2.8.4+dfsg-1_i386.deb Python 3 bindings for QScintilla 2 with Qt 4
python3-pyqt4.qtopengl_4.11.2+dfsg-1_i386.deb Python 3 bindings for Qt4's OpenGL module
Advertisement
Advertisement