python3-epr_0.8.1-2+b1_i386.deb


Advertisement

Description

python3-epr - Python ENVISAT Product Reader API (Python 3)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python3-epr
Package version 0.8.1
Package release 2+b1
Package architecture i386
Package type deb
Installed size 227 B
Download size 68.17 KB
Official Mirror ftp.br.debian.org
PyEPR provides Python bindings for the ENVISAT Product Reader C API
(EPR API) for reading satellite data from ENVISAT ESA (European Space
Agency) mission.
PyEPR, as well as the EPR API for C, supports ENVISAT MERIS, AATSR
Level 1B and Level 2 and also ASAR data products. It provides access
to the data either on a geophysical (decoded, ready-to-use pixel
samples) or on a raw data layer. The raw data access makes it possible
to read any data field contained in a product file.
This package contains pyepr for Python 3.

Alternatives

Package Version Architecture Repository
python3-epr_0.8.1-2+b1_amd64.deb 0.8.1 amd64 Debian Main
python3-epr - - -

Requires

Name Value
libc6 >= 2.4
libepr-api2 -
python3 >= 3.4~
python3 << 3.5
python3-numpy >= 1:1.8.0
python3-numpy-abi9 -

Provides

Name Value
python3.4-epr -

Download

Type URL
Binary Package python3-epr_0.8.1-2+b1_i386.deb
Source Package pyepr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-epr deb package:
    # sudo apt-get install python3-epr

Files

Path
/usr/lib/python3/dist-packages/epr.cpython-34m-i386-linux-gnu.so
/usr/lib/python3/dist-packages/pyepr-0.8.1.egg-info
/usr/share/doc/python3-epr/NEWS.txt.gz
/usr/share/doc/python3-epr/changelog.Debian.gz
/usr/share/doc/python3-epr/changelog.Debian.i386.gz
/usr/share/doc/python3-epr/changelog.gz
/usr/share/doc/python3-epr/copyright

Changelog

2014-05-18 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.8.1-2) unstable; urgency=medium
* Standards-Version bumped to 3.9.5 (no change)
* Fixed file conflicts in binary packages (Closes: #748237)
* debian/control
- build-depend on the new libepr-api-dev instead of
libepr-api2-dev
2013-10-26 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.8.1-1) unstable; urgency=low
* New upstream release
* Compat set to 9
* debian/control
- Build-depend from debhelper (>= 9)
- Removed unnecessary versioned dependency from libepr-api2-dev (>= 2.2)
- Removed unnecessary "${sphinxdoc:Depends}" from non-doc packages
- Added build dependencies from python-doc and python-numpy-doc.
It is necessary to make the package build self-contained.
* debian/copyright
- Updated copyright dates
- Fixed formatting of copyright file
* debian/patches:
- Only use local files for generating sphinx doc.
Set the "intersphinx_mapping" parameter in the doc/conf.py to
point to local object.inv files.
This makes the package self contained and no download attempt
happens any longer (Closes: #726859).
2012-10-21 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.6.1-3) unstable; urgency=low
* Call dh_numpy3
* Preserve the original changelog name  
* Fix installation of debug estensions for Python 3.3 (Closes: #708011)
* Standards version bumped to 3.9.4 (no changes)
* Added build dependency from cython3
* Use canonical URIs for Vcs-* fields
2012-05-01 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.6.1-2) unstable; urgency=low
* Only run dh_sphinxdoc on the -doc package (Closes: #671048).
See also #647233.
2012-04-29 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.6.1-1) unstable; urgency=low
* New upstream release
* New packages:
- -dbg package for python2
- packages for python3 (standard and -dbg)
- package for common docs
* Switch to debhelper 8
* Standard version bumped to 3.9.3 (no changes)
* debian/README.test file added
* Updated copyright file
* Use dh_sphinxdoc and common javascript code from libjs-sphinxdoc
* debian/rules:
- honor nodoc and noopt DEB_BUILD_OPTIONS
- call dh_numpy for an appropriate management of the dependency
from numpy
* debian/control:
- X-Python-Version moved to the source package section
2011-05-07 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.5-1) unstable; urgency=low
* Initial release (Closes: #625997)

See Also

Package Description
python3-espeak_0.5-1+b2_i386.deb Python bindings for eSpeak
python3-evemu_1.2.0-2_i386.deb Linux Input Event Device Emulation Library - Python3 bindings
python3-examples_3.4.2-2_all.deb examples for the Python language (default version)
python3-expiringdict_1.1.2-1_all.deb Python3 caching libarry
python3-extras_0.0.3-3_all.deb extensions to the Python standard library (Python 3.x)
python3-factory-boy_2.4.1-3_all.deb test fixtures replacement based on factory_girl for Ruby - Python 3.x
python3-falcon_0.1.8-3_i386.deb supersonic micro-framework for building cloud APIs - Python 3.x
python3-fdb_1.4.1+dfsg1-4_all.deb Python3 DB-API driver for Firebird
python3-feedparser_5.1.3-3_all.deb Universal Feed Parser for Python 3
python3-first_2.0.0-2_all.deb simple function that returns the first true value from an iterable
python3-fiu_0.93-2_i386.deb userspace fault injection framework (Python 3 bindings)
python3-fixtures_0.3.14-1.1_all.deb PyUnit extension for defining test fixtures outside of test cases - Python 3.x
python3-flake8_2.2.2-1_i386.deb code checker using pep8 and pyflakes (Python 3)
python3-flask-openid_1.2.3+dfsg-3_all.deb OpenID support for Flask applications (Python 3)
python3-flask-principal_0.4.0-1_all.deb identity management for Flask
Advertisement
Advertisement