python-pygments-doc_2.0.1+dfsg-1.1+deb8u1_all.deb


Advertisement

Description

python-pygments-doc - documentation for the Pygments

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-pygments-doc
Package version 2.0.1+dfsg
Package release 1.1+deb8u1
Package architecture all
Package type deb
Installed size 1.18 KB
Download size 222.35 KB
Official Mirror ftp.br.debian.org
Pygments is syntax highlighting package.
This package contains the documentation for Pygments in HTML and
reStructuredText format.

Alternatives

Package Version Architecture Repository
python-pygments-doc_2.0.1+dfsg-1.1+deb8u1_all.deb 2.0.1+dfsg all Debian Main
python-pygments-doc - - -

Requires

Name Value
libjs-sphinxdoc >= 1.0

Conflicts

Name Value
python-pygments <= 2.0~

Download

Type URL
Binary Package python-pygments-doc_2.0.1+dfsg-1.1+deb8u1_all.deb
Source Package pygments

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pygments-doc deb package:
    # sudo apt-get install python-pygments-doc

Files

Path
/usr/share/doc/python-pygments/html
/usr/share/doc/python-pygments/rst
/usr/share/doc/python-pygments-doc/AUTHORS.gz
/usr/share/doc/python-pygments-doc/TODO
/usr/share/doc/python-pygments-doc/changelog.Debian.gz
/usr/share/doc/python-pygments-doc/changelog.gz
/usr/share/doc/python-pygments-doc/copyright
/usr/share/doc/python-pygments-doc/examples/markdown-processor.py
/usr/share/doc/python-pygments-doc/examples/moin-parser.py
/usr/share/doc/python-pygments-doc/examples/rst-directive.py
/usr/share/doc/python-pygments-doc/html/download.html
/usr/share/doc/python-pygments-doc/html/faq.html
/usr/share/doc/python-pygments-doc/html/genindex.html
/usr/share/doc/python-pygments-doc/html/index.html
/usr/share/doc/python-pygments-doc/html/languages.html
/usr/share/doc/python-pygments-doc/html/objects.inv
/usr/share/doc/python-pygments-doc/html/py-modindex.html
/usr/share/doc/python-pygments-doc/html/search.html
/usr/share/doc/python-pygments-doc/html/searchindex.js
/usr/share/doc/python-pygments-doc/html/_sources/download.txt
/usr/share/doc/python-pygments-doc/html/_sources/faq.txt
/usr/share/doc/python-pygments-doc/html/_sources/index.txt
/usr/share/doc/python-pygments-doc/html/_sources/languages.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/api.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/authors.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/changelog.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/cmdline.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/filterdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/filters.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/formatterdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/formatters.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/index.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/integrate.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/java.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/lexerdevelopment.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/lexers.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/moinmoin.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/plugins.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/quickstart.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/rstdirective.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/styles.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/tokens.txt
/usr/share/doc/python-pygments-doc/html/_sources/docs/unicode.txt
/usr/share/doc/python-pygments-doc/html/_static/ajax-loader.gif
/usr/share/doc/python-pygments-doc/html/_static/basic.css
/usr/share/doc/python-pygments-doc/html/_static/comment-bright.png
/usr/share/doc/python-pygments-doc/html/_static/comment-close.png
/usr/share/doc/python-pygments-doc/html/_static/comment.png
/usr/share/doc/python-pygments-doc/html/_static/default.css
/usr/share/doc/python-pygments-doc/html/_static/doctools.js
/usr/share/doc/python-pygments-doc/html/_static/down-pressed.png
/usr/share/doc/python-pygments-doc/html/_static/down.png
/usr/share/doc/python-pygments-doc/html/_static/favicon.ico.gz
/usr/share/doc/python-pygments-doc/html/_static/file.png
/usr/share/doc/python-pygments-doc/html/_static/jquery.js
/usr/share/doc/python-pygments-doc/html/_static/logo_new.png
/usr/share/doc/python-pygments-doc/html/_static/logo_only.png
/usr/share/doc/python-pygments-doc/html/_static/minus.png
/usr/share/doc/python-pygments-doc/html/_static/plus.png
/usr/share/doc/python-pygments-doc/html/_static/pygments.css
/usr/share/doc/python-pygments-doc/html/_static/searchtools.js
/usr/share/doc/python-pygments-doc/html/_static/sidebar.js
/usr/share/doc/python-pygments-doc/html/_static/underscore.js
/usr/share/doc/python-pygments-doc/html/_static/up-pressed.png
/usr/share/doc/python-pygments-doc/html/_static/up.png
/usr/share/doc/python-pygments-doc/html/docs/api.html
/usr/share/doc/python-pygments-doc/html/docs/authors.html
/usr/share/doc/python-pygments-doc/html/docs/changelog.html.gz
/usr/share/doc/python-pygments-doc/html/docs/cmdline.html
/usr/share/doc/python-pygments-doc/html/docs/filterdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/filters.html
/usr/share/doc/python-pygments-doc/html/docs/formatterdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/formatters.html
/usr/share/doc/python-pygments-doc/html/docs/index.html
/usr/share/doc/python-pygments-doc/html/docs/integrate.html
/usr/share/doc/python-pygments-doc/html/docs/java.html
/usr/share/doc/python-pygments-doc/html/docs/lexerdevelopment.html
/usr/share/doc/python-pygments-doc/html/docs/lexers.html
/usr/share/doc/python-pygments-doc/html/docs/moinmoin.html
/usr/share/doc/python-pygments-doc/html/docs/plugins.html
/usr/share/doc/python-pygments-doc/html/docs/quickstart.html
/usr/share/doc/python-pygments-doc/html/docs/rstdirective.html
/usr/share/doc/python-pygments-doc/html/docs/styles.html
/usr/share/doc/python-pygments-doc/html/docs/tokens.html
/usr/share/doc/python-pygments-doc/html/docs/unicode.html

Changelog

2016-01-10 - Salvatore Bonaccorso <carnil@debian.org>
pygments (2.0.1+dfsg-1.1+deb8u1) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* Add CVE-2015-8557.patch patch.
CVE-2015-8557: Shell injection in FontManager._get_nix_font_path.
(Closes: #802828)
2015-03-22 - Sébastien Villemot <sebastien@debian.org>
pygments (2.0.1+dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/copyright: add the missing licenses of:
- pygments/lexers/robotframework.py
- tests/dtds/HTMLspec.ent
- tests/dtds/HTMLlat1.ent
- tests/dtds/HTMLsym.ent
(Closes: #766042)
2014-11-09 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* Drop disable_example_files_test.patch, no longer needed.
* Enable verbose tests output.
[ Piotr Ożarowski ]
* New upstream release
- pygmentize no longer fails when writing UTF-8 to output files
(closes: 771724)
* Drop doc/_build from the tarball (mostly due to missing JS sources; these
files are regenerated anyway)
* Remove .pyc files from upstream tarball
* make_utf8_default patch removed, no longer needed
2014-10-19 - Piotr Ożarowski <piotr@debian.org>
pygments (2.0~rc1.a2bc2bd+dfsg-1) unstable; urgency=medium
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Dmitry Shachnev ]
* Make autopkgtests depend on patch (to fix test failure on CI)
and python[3]-all (to run tests for all supported Python versions).
Closes: #740166.
[ Piotr Ożarowski ]
* New upstream release
- Bump X-Python-Version to 2.6
* Documentation moved to new binary package: python-pygments-doc
* Add dh-python and python-sphinx to Build-Depends
* Switch debhelper compat level to 9
* Standards-Version bumped to 3.9.6 (no changes needed)
2013-02-03 - Piotr Ożarowski <piotr@debian.org>
pygments (1.6+dfsg-1) experimental; urgency=low
* New upstream release
* fix_makefile_re.patch removed, no longer needed
* debian/watch file updated to handle rc versions correctly
2013-01-06 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-2) unstable; urgency=low
[ Dmitry Shachnev ]
* Add DEP-8 tests (closes: #693028).
* Remove unneeded build-dependency on quilt.
* Bump Standards-Version to 3.9.4.
+ Add empty build-arch target to debian/rules.
* Drop Breaks: {python:Breaks}, it is obsolete.
* debian/patches/fix_makefile_re.patch: cherry-picked upstream commit
that fixes Makefile highlighting.
2012-03-11 - Piotr Ożarowski <piotr@debian.org>
pygments (1.5+dfsg-1) unstable; urgency=low
* New upstream release
* make_utf8_default patch: do not change the encoding guessing part in
pygments/lexer.py; updated to new upstream version
* debian/pygmentize no longer needed, upstream now ships the script in the
tarball (and it returns correct exit codes, closes: 628881)
2011-01-04 - Piotr Ożarowski <piotr@debian.org>
pygments (1.4+dfsg-1) unstable; urgency=low
* New upstream release
* Provide python3-pygments binary package
* Convert from python-support to dh_python2
* Source package format changed to 3.0 (quilt)
* Standards-Version bumped to 3.9.1 (no changes needed)
2010-03-20 - Piotr Ożarowski <piotr@debian.org>
pygments (1.3.1+dfsg-1) unstable; urgency=low
* New upstream release
* Add ttf-bitstream-vera package to Suggests ("img" formatter needs it)
* Homepage field updated
2010-03-02 - Piotr Ożarowski <piotr@debian.org>
pygments (1.3+dfsg-1) unstable; urgency=low
* New upstream release
- install Bash completion script for pygmentize
* Standards-Version bumped to 3.8.4 (no changes needed)

See Also

Package Description
python-pygments_2.0.1+dfsg-1.1+deb8u1_all.deb syntax highlighting package written in Python
python-pygoocanvas_0.14.1-1+b3_i386.deb GooCanvas Python bindings
python-pygooglechart_0.3.0-1_all.deb complete wrapper for the Google Chart API
python-pygrace_0.4p2-3_all.deb Python bindings for grace
python-pygraph_1.8.2-6_all.deb library for working with graphs in Python
python-pygraphviz_1.3~rc2-1_i386.deb Python interface to the Graphviz graph layout and visualization package
python-pygresql_4.0-3.1_i386.deb PostgreSQL module for Python
python-pyhsm_1.0.4k-3_all.deb Python code for talking to a Yubico YubiHSM hardware
python-pyicu_1.8-1_i386.deb Python extension wrapping the ICU C++ API
python-pyinotify-doc_0.9.4-1_all.deb simple Linux inotify Python bindings -- documentation
python-pyinotify_0.9.4-1_all.deb simple Linux inotify Python bindings
python-pyip_0.7-2_all.deb Python modules for raw ip packet assembling/disassembling
python-pyisomd5sum_1.0.11-1_i386.deb ISO9660 checksum Python module
python-pyjavaproperties_0.6-2_all.deb Python implementation of java.util.Properties
python-pykaraoke_0.7.5-1.1_i386.deb free CDG/MIDI/MPEG karaoke player
Advertisement
Advertisement