python-psycopg2_2.5.4+dfsg-1_i386.deb


Advertisement

Description

python-psycopg2 - Python module for PostgreSQL

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-psycopg2
Package version 2.5.4+dfsg
Package release 1
Package architecture i386
Package type deb
Installed size 678 B
Download size 147.86 KB
Official Mirror ftp.br.debian.org
psycopg is a PostgreSQL database adapter for the Python programming language
(just like pygresql and popy.) This is version 2, a complete rewrite of the
original code to provide new-style classes for connection and cursor objects
and other sweet candies. Like the original, psycopg 2 was written with the
aim of being very small and fast, and stable as a rock.
psycopg is different from the other database adapter because it was designed
for heavily multi-threaded applications that create and destroy lots of
cursors and make a conspicuous number of concurrent INSERTs or UPDATEs.
psycopg 2 also provides full asynchronous operations for the really brave
programmer.
The main advantages of psycopg2 are that it supports the full Python DBAPI-2.0
and being thread safe at level 2. It also includes some extensions to the
standard DBAPI-2.0 to allow for better thread performance.

Alternatives

Package Version Architecture Repository
python-psycopg2_2.5.4+dfsg-1_amd64.deb 2.5.4+dfsg amd64 Debian Main
python-psycopg2 - - -

Requires

Name Value
libc6 >= 2.4
libpq5 >= 8.3~
python << 2.8
python >= 2.7

Download

Type URL
Binary Package python-psycopg2_2.5.4+dfsg-1_i386.deb
Source Package psycopg2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-psycopg2 deb package:
    # sudo apt-get install python-psycopg2

Files

Path
/usr/lib/python2.7/dist-packages/psycopg2-2.5.4.egg-info
/usr/lib/python2.7/dist-packages/psycopg2/__init__.py
/usr/lib/python2.7/dist-packages/psycopg2/_json.py
/usr/lib/python2.7/dist-packages/psycopg2/_psycopg.so
/usr/lib/python2.7/dist-packages/psycopg2/_range.py
/usr/lib/python2.7/dist-packages/psycopg2/errorcodes.py
/usr/lib/python2.7/dist-packages/psycopg2/extensions.py
/usr/lib/python2.7/dist-packages/psycopg2/extras.py
/usr/lib/python2.7/dist-packages/psycopg2/pool.py
/usr/lib/python2.7/dist-packages/psycopg2/psycopg1.py
/usr/lib/python2.7/dist-packages/psycopg2/tz.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/__init__.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/dbapi20.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/dbapi20_tpc.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_async.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_bugX000.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_bug_gc.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_cancel.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_connection.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_copy.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_cursor.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_dates.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_extras_dictcursor.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_green.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_lobject.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_module.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_notify.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_psycopg2_dbapi20.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_quote.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_transaction.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_types_basic.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_types_extras.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/test_with.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/testconfig.py
/usr/lib/python2.7/dist-packages/psycopg2/tests/testutils.py
/usr/share/doc/python-psycopg2/AUTHORS
/usr/share/doc/python-psycopg2/NEWS.gz
/usr/share/doc/python-psycopg2/README
/usr/share/doc/python-psycopg2/changelog.Debian.gz
/usr/share/doc/python-psycopg2/copyright

Changelog

2014-09-27 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.5.4+dfsg-1) unstable; urgency=medium
* New upstream release
- Repack source tarball to remove minified javascript files
* Swap DPMT to maintainer and add myself to uploaders
* Drop obsolete and unused python:Provides
* Add appropriate X-Python{3}-Version fields to debian/control
* Bump standards version to 3.9.6 without further change
* Install NEWS using dh_installchangelogs to install as upstream changelog
* Update debian/copyright
* Update debian/README.source list of files that need to be removed to
create a DFSG free tarball
* Drop obsolete python-psycopg2-doc breaks/replaces python-psycopg2-docs
2014-05-26 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.5.3+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream release
* Correct python-psycopg2-doc install location (Closes: #686741)
* Update debian/copyright
* Repack source tarball to remove minified javascript files
- Update debian/watch to unmangle upstream version
2014-02-24 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.5.2-1) unstable; urgency=low
* Team upload
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Scott Kitterman ]
* New upstream release
- Update dh_installchangelogs rule from debian/rules since upstream no
longer provides a changelog
- Remove empty usr/lib/python3/dist-packages/psycopg2/tests dir in
python3-psycopg2-dbg
* Use python version independent paths in debian/patches/local_inventory
* Remove ancient, unused files from debian dir
* Bump standards version to 3.9.5 without further change
2012-04-02 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.4.5-1) unstable; urgency=low
* Team upload
* New upstream release
- Update debian/copyright
2012-03-18 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.4.4-4) unstable; urgency=low
* Team upload
* Rename python-pyscopg2-docs to the more usual python-pyscopg2-doc
- Not creating a transitional package due to the package only existing
for a short period and never in a stable release
* Fix typos in the last debian/changelog entry
* Fix misspellings in package descriptions in debian/control
* Bump standards version to 3.9.3 without further change
2012-02-02 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.4.4-3) unstable; urgency=low
* Team upload
* Fix debian/rules so python3-psycopg2-dbg so files are properly marked as
debug versions (Closes: #658219)
* Use local Python objects.inv instead of downloading from python.org
- Add python-doc and python3-doc to Build-Depends-Indep
- Add Quilt use to debian/rules and README.source
- Add debian/patches/local_inventory
2012-01-30 - Scott Kitterman <scott@kitterman.com>
psycopg2 (2.4.4-2) unstable; urgency=low
* Team upload
* Move python-egenix-mxdatetime from Depends to Recommends since support for
it is now detected at runtime (Closes: #523414)
* Add separate python-pyscopg2-docs package suggested by both python-psycopg2
and python3-psycopg2 (only ship actual documentation in the binary and
not the source to build the documentation)
- Adjust debian/rules for an arch-indep package and python-sphinx
- Rebuild html and text docs from source instead of shipping provided
files
- Add python-sphinx (>= 1.0.7+dfsg-1~) to build-depends and use
sphinxdoc:Depends
- Add debian/python-psycopg2-docs.install
* Build packages for Python3 (Closes: #645906)
- Add python3-psycopg2/-dbg to debian/control
- Add python3-all-dev and python3-all-dbg to build-depends
- Adjust debian/rules
* Drop build-depends on autoconf (Closes: #589131)
* Drop redundant build-depends on python (python-all-dev covers it)

See Also

Package Description
python-ptrace_0.7-1_all.deb Python bindings for ptrace
python-publicsuffix_1.0.5-1_all.deb get a public suffix for a domain name using the Public Suffix List
python-pudb_2014.1-1_all.deb full-screen, console-based Python debugger
python-pwquality_1.2.3-1_i386.deb Python bindings for libpwquality
python-py++_1.0.0-1_i386.deb OO-framework for creating a code generator for Boost.Python
python-py_1.4.25-1_all.deb Advanced Python development support library (Python 2)
python-pyalsa_1.0.26-1_i386.deb Official ALSA Python binding library
python-pyao_0.82-5_i386.deb Python interface to the Audio Output library
python-pyasn1-modules_0.0.5-0.1_all.deb Collection of protocols modules written in ASN.1 language
python-pyasn1_0.1.7-1_all.deb ASN.1 library for Python (Python 2 module)
python-pyassimp_3.0~dfsg-3_all.deb 3D model import library (Python bindings)
python-pyatspi2_2.14.0+dfsg-1_all.deb Transitional package for assistive technology Python bindings
python-pyatspi_2.14.0+dfsg-1_all.deb Assistive Technology Service Provider Interface - Python bindings
python-pyaudio-doc_0.2.8-1_all.deb Documentation for Python bindings for PortAudio v19
python-pyaudio_0.2.8-1+b1_i386.deb Python bindings for PortAudio v19
Advertisement
Advertisement