python-ply_3.4-5_all.deb


Advertisement

Description

python-ply - Lex and Yacc implementation for Python2

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-ply
Package version 3.4
Package release 5
Package architecture all
Package type deb
Installed size 285 B
Download size 61.45 KB
Official Mirror ftp.br.debian.org
PLY   is   yet  another   implementation   of   lex   and  yacc   for
Python.  Although  several  other  parsing tools  are  available  for
Python, there are  several reasons why you might want  to take a look
at PLY:
* It's implemented entirely in Python.
* It uses  LR-parsing which is reasonably efficient  and well suited
for larger grammars.
* PLY  provides most  of  the standard  lex/yacc features  including
support for  empty productions, precedence  rules, error recovery,
and support for ambiguous grammars.
* PLY is  extremely easy  to use and  provides very  extensive error
checking.

Alternatives

Package Version Architecture Repository
python-ply_3.4-5_all.deb 3.4 all Debian Main
python-ply - - -

Requires

Name Value
python << 2.8
python >= 2.7

Provides

Name Value
python-ply-lex-3.2 -
python-ply-yacc-3.2 -
python2.7-ply -

Download

Type URL
Binary Package python-ply_3.4-5_all.deb
Source Package ply

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ply deb package:
    # sudo apt-get install python-ply

Files

Path
/usr/bin/dh_python-ply
/usr/lib/python2.7/dist-packages/ply/__init__.py
/usr/lib/python2.7/dist-packages/ply/cpp.py
/usr/lib/python2.7/dist-packages/ply/ctokens.py
/usr/lib/python2.7/dist-packages/ply/lex.py
/usr/lib/python2.7/dist-packages/ply/yacc.py
/usr/lib/python2.7/dist-packages/ply-3.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/ply-3.4.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/ply-3.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/ply-3.4.egg-info/top_level.txt
/usr/share/doc/python-ply/README.Debian
/usr/share/doc/python-ply/README.gz
/usr/share/doc/python-ply/TODO
/usr/share/doc/python-ply/changelog.Debian.gz
/usr/share/doc/python-ply/changelog.gz
/usr/share/doc/python-ply/copyright
/usr/share/man/man1/dh_python-ply.1.gz

Changelog

2014-10-16 - Arnaud Fontaine <arnau@debian.org>
ply (3.4-5) unstable; urgency=medium
* d/rules: add manpage for dh_python3-ply.
2014-10-16 - Arnaud Fontaine <arnau@debian.org>
ply (3.4-4) unstable; urgency=medium
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Arnaud Fontaine ]
* Remove Gustavo Franco from Uploaders as he is retiring. Closes: #729398.
* Enable tests during package build. Thanks to James Page. Closes: #734366.
+ d/rules: Execute lex and yacc tests for all python versions.
+ d/p/*.patch: Cherry picked fixes from upstream VCS to resolve
compatibility issues with Python >= 3.3.
* d/control: bump Standards-Version to 3.9.6. No changes needed.
* Add dh_python3-ply to generate proper package Depends for Python3.
Closes: #714099.
* d/patches/*: remove meaningless (at least with quilt) numbering prefix.
2012-05-14 - Arnaud Fontaine <arnau@debian.org>
ply (3.4-3) unstable; urgency=low
* debian/control: bump Standards-Version to 3.9.3. No changes needed.
* Add debian/source/options to ignore changes in egg-info/* to prevent
FTBFS if built twice. Closes: #671248.
* debian/copyright: switch to version 1.0 of machine-readable format.
2011-07-04 - Jakub Wilk <jwilk@debian.org>
ply (3.4-2) unstable; urgency=low
* Team upload.
* Set PYTHONPATH correctly when generating names of virtual packages.
2011-06-12 - Arnaud Fontaine <arnau@debian.org>
ply (3.4-1) unstable; urgency=low
[ Arnaud Fontaine ]
* New upstream release.
* Switch to dh_python2.
+ debian/control:
- Bump cdbs dependency to 0.4.90-1~.
- Bump python-all dependency to 2.6.6-9~.
- Remove Build-Depends on python-support.
- Add X-Python-Version field.
- Add ${python:Breaks}.
* Add python3-ply binary package. Closes: #605659.
+ debian/control:
- Add python3-ply binary package.
- Build-Depends on python3-all and add X-Python3-Version field.
* debian/copyright:
+ Update copyright years.
* Provide virtual packages for lex and yacc tabversions. Thanks to Jakub
Wilk. Closes: #627862.
[ Daniele Tricoli ]
* debian/control:
- Bumped Standard-Version to 3.9.2. No changes needed.
* debian/patches/01_fix-lex-tabversion.patch:
- Set proper _tabversion in ply.lex.
* debian/patches/02_relax-lex-tabversion-check.patch:
- Don't break already built packages with wrong _tabversion.
* debian/source/format:
- Switched to dpkg-source 3.0 (quilt) format.
2009-09-28 - Arnaud Fontaine <arnau@debian.org>
ply (3.3-1) unstable; urgency=low
* New upstream release.
* debian/control:
+ Depend on python-pkg-resources instead of python-setuptools as the
latter is not necessary on runtime. Closes: #546430.
+ Update Standards-Version to 3.8.3. No changes needed.
+ Bump python-support version to 0.90.
* Remove useless debian/pycompat.
2009-05-22 - Arnaud Fontaine <arnau@debian.org>
ply (3.2-1) unstable; urgency=low
[ Arnaud Fontaine ]
* New upstream release.
+ debian/copyright:
- Update license as it is now distributed as a BSD license.
+ debian/python-ply-doc.docs:
- Add all html files.
* debian/control:
+ Add ${misc:Depends} to Depends in case the result of calls debhelper
tools adds extra dependencies.
+ Update Standards-Version to 3.8.1.
- Wrap Uploaders field.
[ Sandro Tosi ]
* debian/control
- Switch Vcs-Browser field to viewsvn.
2008-05-29 - Arnaud Fontaine <arnau@debian.org>
ply (2.5-2) unstable; urgency=low
* debian/control:
+ Move python-setuptools to Build-Depends-Indep.
+ Add python-setuptools to Suggests.
2008-05-29 - Arnaud Fontaine <arnau@debian.org>
ply (2.5-1) unstable; urgency=low
* New upstream release. Closes: #483368.
* debian/control:
+ Add Build-Depends against python-setuptools (ply now supports eggs).

See Also

Package Description
python-pmock_0.3.1+s20140625-2_all.deb Python module for unit testing using mock objects
python-pmw-doc_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-pmw_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-pocketsphinx_0.8-5_i386.deb Speech recognition tool - python bindings
python-poker-engine_1.3.6-1.2_all.deb multiplayer poker engine with abstract variants specifications
python-polib-doc_1.0.5-1_all.deb Python library to parse and manage gettext catalogs (documentation)
python-polib_1.0.5-1_all.deb Python library to parse and manage gettext catalogs
python-polybori_0.8.3-3+b2_i386.deb polynomials over Boolean Rings, Python module
python-popcon_1.1_all.deb Python interface to Debian's Popularity Contest (popcon)
python-poppler-qt4_0.16.3-2+b5_i386.deb Python binding to Poppler Qt4 C++ library
python-poppler_0.12.1-8.1_i386.deb Poppler Python bindings
python-portalocker_0.5.1-1_all.deb easy API to file locking (Python 2)
python-posix-ipc_0.9.8-2+b1_i386.deb semaphores, shared memory and message queues - Python 2.x
python-poster_0.8.1-0.1_all.deb Python support for HTTP multipart PUT/POST
python-potr_1.0.1-1_all.deb Pure Python implementation of the OTR protocol
Advertisement
Advertisement