python-gobject-2_2.28.6-12_i386.deb


Advertisement

Description

python-gobject-2 - deprecated static Python bindings for the GObject library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-gobject-2
Package version 2.28.6
Package release 12
Package architecture i386
Package type deb
Installed size 850 B
Download size 328.53 KB
Official Mirror ftp.br.debian.org
GObject is an abstraction layer that allows programming with an object
paradigm that is compatible with many languages. It is a part of Glib,
the core library used to build GTK+ and GNOME.
This package contains the static Python bindings for gobject, glib, and gio.
These are deprecated by dynamic gobject-introspection bindings (which are
provided with the python-gobject package), and should not be used in newly
written code. These static bindings just exist to provide backwards
compatibility for GNOME 2 based software.

Alternatives

Package Version Architecture Repository
python-gobject-2_2.28.6-12+b1_amd64.deb 2.28.6 amd64 Debian Main
python-gobject-2 - - -

Requires

Name Value
libc6 >= 2.3.6-6~
libffi6 >= 3.0.4
libglib2.0-0 >= 2.26.0
python << 2.8
python >= 2.7

Provides

Name Value
python2.7-gobject -
python2.7-gobject-2 -

Replaces

Name Value
python-gobject << 2.90

Download

Type URL
Binary Package python-gobject-2_2.28.6-12_i386.deb
Source Package pygobject-2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gobject-2 deb package:
    # sudo apt-get install python-gobject-2

Files

Path
/usr/lib/libpyglib-2.0-python2.7.so.0
/usr/lib/libpyglib-2.0-python2.7.so.0.0.0
/usr/lib/pyshared/python2.7/glib/_glib.so
/usr/lib/pyshared/python2.7/gobject/_gobject.so
/usr/lib/pyshared/python2.7/gtk-2.0/gio/_gio.so
/usr/lib/pyshared/python2.7/gtk-2.0/gio/unix.so
/usr/lib/python2.7/dist-packages/gtk-2.0-pysupport-compat.pth
/usr/lib/python2.7/dist-packages/pygtk.pth
/usr/lib/python2.7/dist-packages/pygtk.py
/usr/lib/python2.7/dist-packages/glib/__init__.py
/usr/lib/python2.7/dist-packages/glib/_glib.so
/usr/lib/python2.7/dist-packages/glib/option.py
/usr/lib/python2.7/dist-packages/gobject/__init__.py
/usr/lib/python2.7/dist-packages/gobject/_gobject.so
/usr/lib/python2.7/dist-packages/gobject/constants.py
/usr/lib/python2.7/dist-packages/gobject/propertyhelper.py
/usr/lib/python2.7/dist-packages/gtk-2.0/dsextras.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gio/__init__.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gio/_gio.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gio/unix.so
/usr/share/doc/python-gobject-2/AUTHORS
/usr/share/doc/python-gobject-2/NEWS.gz
/usr/share/doc/python-gobject-2/README
/usr/share/doc/python-gobject-2/changelog.Debian.gz
/usr/share/doc/python-gobject-2/changelog.gz
/usr/share/doc/python-gobject-2/copyright
/usr/share/doc/python-gobject-2/examples/cairo-demo.py
/usr/share/doc/python-gobject-2/examples/option.py
/usr/share/doc/python-gobject-2/examples/properties.py
/usr/share/doc/python-gobject-2/examples/signal.py
/usr/share/pyshared/gtk-2.0-pysupport-compat.pth
/usr/share/pyshared/pygtk.pth
/usr/share/pyshared/pygtk.py
/usr/share/pyshared/glib/__init__.py
/usr/share/pyshared/glib/option.py
/usr/share/pyshared/gobject/__init__.py
/usr/share/pyshared/gobject/constants.py
/usr/share/pyshared/gobject/propertyhelper.py
/usr/share/pyshared/gtk-2.0/dsextras.py
/usr/share/pyshared/gtk-2.0/gio/__init__.py

Changelog

2013-05-10 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-12) unstable; urgency=low
* Rebuild to use Python 2.7 by default. (Closes: #701972)
* Bump Standards-Version to 3.9.4, no changes necessary.
2013-02-19 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-11) unstable; urgency=low
* debian/control.in: Drop the "Provides: python2.6-gobject". There are no
reverse dependencies anyway, and we don't encourage any new ones.
* Add 00git_class_init.patch: Move property and signal creation into
_class_init(). This allows old PyGTK applications to work with static
PyGObject and GLib 2.35.x. (LP: #1129309)
2012-03-13 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-10) unstable; urgency=low
[ Josselin Mouette ]
* Update repository URL.
[ Martin Pitt ]
* Add 00git_fix_qdata_warning.patch: Fix set_qdata warning on accessing NULL
gobject property. Backported from upstream git.
* Add 00git_gio_flag_type.patch: Fix definition of flag types. Backported
from upstream git. (LP: #918607)
* debian/copyright: Update to copyright format 1.0.
* debian/control.in: Bump Standards-Version to 3.9.3.
2011-12-12 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-9) unstable; urgency=high
* Urgency high as this blocks the testing migration of g-i, pygobject, and
others, and this is a trivial change.
* debian/control.in: Add "Provides: python2.x-gobject" to python-gobject-2
to also satisfy dependencies for packages which use the obsolete explicit
dependencies, such as python-insanity. (Closes: #651824)
2011-11-20 - Sjoerd Simons <sjoerd@debian.org>
pygobject-2 (2.28.6-8) unstable; urgency=low
* Upload to unstable
2011-09-05 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-7) experimental; urgency=low
* debian/control.in, debian/rules: Rename python-gobject-dev to
python-gobject-2-dev. pygobject 2.90 now also builds a python-gobject-dev
which depends on python-gobject-2-dev.
* debian/control.in: Fix "Conflicts/Breaks" pairs to actually be what I
mean: "Breaks/Replaces".
2011-08-18 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-6) experimental; urgency=low
* debian/copyright: Update to current licenses/copyrights, and convert to
DEP-5.
2011-08-17 - Martin Pitt <mpitt@debian.org>
pygobject-2 (2.28.6-5) experimental; urgency=low
* Split package: The 2.28 version is now deprecated and called pygobject-2;
it will only contain the old static bindings without introspection.  The
pygobject 3.0 version only contains the introspection bindings now, and
will depend on python-gobject-2 for backwards compatibility until all
packages get ported to use introspection.
- debian/control.in, debian/rules: Rename packages to *-2 and update
description to point out that these are deprecated and only provided for
backwards compatibility.
- debian/control.in, debian/rules: Drop python 3 packages; python3-gobject
does not yet have any reverse dependencies, and we don't want to
encourage porting to Python 3 without porting to GI as well.
- debian/control.in: Update Vcs-* for pygobject-2 branch.
- debian/rules: Disable introspection support. Drop gobject-introspection
and libgirepository1.0-dev build dependencies.
- debian/control.in: Conflicts/Breaks python-gobject{,-dbg} << 2.90.
2011-07-14 - Martin Pitt <mpitt@debian.org>
pygobject (2.28.6-4) unstable; urgency=low
* debian/rules: Create shlibs for python3 packages, too.
* debian/rules: Call dh_strip on python3-gobject, too.

See Also

Package Description
python-gobject-dev_3.14.0-1_all.deb Python 2.x development headers for GObject - transitional package
python-gobject_3.14.0-1_all.deb Python 2.x bindings for GObject - transitional package
python-goocalendar_0.1-4_all.deb Calendar widget for GTK+ using PyGoocanvas (Python 2)
python-google-apputils_0.4.1-1_all.deb Google Application Utilities - Python 2.x
python-googleapi-samples_1.2-3_all.deb Google APIs Client Library for Python, samples
python-googleapi_1.2-3_all.deb Google APIs Client Library - Python 2.x
python-googlecloudapis_0.9.30+debian1-1_all.deb collection of utilities for client-side tools - Python 2.x
python-gpgme_0.3-1+b1_i386.deb python wrapper for the GPGME library
python-gpiv_2.0.0-4.2_i386.deb wrapper of libgpiv
python-gpod_0.8.3-1.1+b1_i386.deb Python bindings for libgpod
python-gps_3.11-3_i386.deb Global Positioning System - Python libraries
python-gpyconf_0.2-1_all.deb Python configuration framework with support for multiple backends
python-grapefruit-doc_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily - documentation
python-grapefruit_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily
python-graphy_1.0+dfsg-3_all.deb chart generation library for Python
Advertisement
Advertisement