python-glade2_2.24.0-4_i386.deb


Advertisement

Description

python-glade2 - GTK+ bindings: Glade support

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-glade2
Package version 2.24.0
Package release 4
Package architecture i386
Package type deb
Installed size 54 B
Download size 42.53 KB
Official Mirror ftp.br.debian.org
Contains bindings for the glade library from use within Python. Glade
makes it very easy to create a user interface. In the target
application you just need to load the interface description from
the .glade file instead of constructing the GUI at runtime.
This package is deprecated, you should migrate to using
gobject-introspection (GIR) based python bindings instead (PyGObject).
https://wiki.gnome.org/Projects/PyGObject/IntrospectionPorting

Alternatives

Package Version Architecture Repository
python-glade2_2.24.0-4_amd64.deb 2.24.0 amd64 Debian Main
python-glade2 - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.3.6-6~
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglade2-0 >= 1:2.6.4-2~
libglib2.0-0 >= 2.16.0
libgtk2.0-0 >= 2.18.0
libpango-1.0-0 >= 1.21.4
libpangocairo-1.0-0 >= 1.21.4
libpangoft2-1.0-0 >= 1.21.4
libxml2 >= 2.6.27
python << 2.8
python >= 2.7
python-gtk2 = 2.24.0-4
python-numpy >= 1:1.8.0
python-numpy-abi9 -

Download

Type URL
Binary Package python-glade2_2.24.0-4_i386.deb
Source Package pygtk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-glade2 deb package:
    # sudo apt-get install python-glade2

Files

Path
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/glade.so
/usr/share/doc/python-glade2/changelog.Debian.gz
/usr/share/doc/python-glade2/changelog.gz
/usr/share/doc/python-glade2/copyright

Changelog

2014-08-24 - Andreas Henriksson <andreas@fatal.se>
pygtk (2.24.0-4) unstable; urgency=low
* Team upload.
[ Josselin Mouette ]
* Add missing epoch on libglade build-dependency.
[ Andreas Henriksson ]
* Fix Vcs-* URLs, pygtk is in attic (not packages/unstable).
* Add deprecated notice to all package descriptions.
[ Erwan Prioul ]
* Use dh-autoreconf to fix FTBFS on ppc64el (Closes: #750663)
[ Aurelien Jarno ]
* Add -a to xvfb-run invokations to fix parallell build.
2012-02-08 - Michael Biebl <biebl@debian.org>
pygtk (2.24.0-3) unstable; urgency=low
[ Josselin Mouette ]
* Replace python-gobject by python-gobject-2.
* Update repository URL.
[ Michael Biebl ]
* Tighten dependency between python-gtk2-dev and python-gtk2.
Closes: #659068
2011-05-30 - Martin Pitt <mpitt@debian.org>
pygtk (2.24.0-2) unstable; urgency=low
[ Josselin Mouette ]
* Drop incorrect ${python:Provides}.
[ Martin Pitt ]
* debian/rules: Don't call dh_numpy when building on Ubuntu, to avoid
dragging the sizable python-numpy into the default installation. The few
(if any) packages which actually use numpy ought to depend on it
themselves.
* debian/watch: Fix syntax to actually catch the latest version.
2011-04-23 - Laurent Bigonville <bigon@debian.org>
pygtk (2.24.0-1) unstable; urgency=low
* New upstream release (Closes: #619126).
* debian/control.in:
- Bump python-gobject-dev and libgtk2.0-dev build-dependencies
- Bump python-gtk2-dev dependencies against python-gobject-dev
and libgtk2.0-dev (Closes: #554973)
- Drop pysupport build-dependency and bump python-all-dev
- Bump Standards-Version to 3.9.2
- Drop all Conflicts/Replaces, all these packages only exist prior lenny
- Drop Python-Depends and use Depends instead
- Don't Depends against python-dbg, let dh_python2 generate the correct
versions
- Drop all XB-Python-Version
- Bump debhelper compatibility to 8
- Add Breaks: python-gtkglext1 (<< 1.1.0-7~) to be sure it also use
dh_python2
* debian/rules:
- Use dh_python2 instead of dh_pysupport
- Set pyexecdir to install files to py_libdir_sh
- Call dh_prep instead of dh_clean -k
* Drop debian/patches/60_pygtk-wakeupfd-fix.patch: Fixed upstream
2010-08-05 - Luca Falavigna <dktrkranz@debian.org>
pygtk (2.17.0-4) unstable; urgency=low
* Provide proper support python-numpy upgrades, calling dh_numpy to
generate correct dependencies and tighting the build-dependency on
python-numpy-dbg (Closes: #590733)
* Switch to format 3.0 (quilt).
* Bump-Standards-Version to 3.9.1.
2010-07-23 - Emilio Pozuelo Monfort <pochu@debian.org>
pygtk (2.17.0-3) unstable; urgency=low
* debian/control.in:
- Drop python2.5{,-dev} (build) dependencies. They were there to
make sure Python had wakeupfd support, but that's already in
stable and the 2.5 dependency will be problematic in the future,
so drop it already. Closes: #587008.
- Point Vcs-* to the unstable branches.
2010-04-13 - Josselin Mouette <joss@debian.org>
pygtk (2.17.0-2) unstable; urgency=low
* Pass G_HOME=/ for the test suite. Fixes FTBFS. Closes: #570313.
2010-04-13 - Josselin Mouette <joss@debian.org>
pygtk (2.17.0-1) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/rules:
- Fix typo when removing unneeded /usr/include directories.
[ Josselin Mouette ]
* New upstream release.
* Bump GTK+ build-dependency.
* 05_testPixmapCreateFromData.patch, 06_gdk.color_from_hsv.patch: 
dropped, merged upstream.

See Also

Package Description
python-glance-doc_2014.1.3-12+deb8u1_all.deb OpenStack Image Service - Python library documentation
python-glance-store-doc_0.1.8-1_all.deb OpenStack Image Service store library - doc
python-glance-store_0.1.8-1_all.deb OpenStack Image Service store library - Python 2.x
python-glance_2014.1.3-12+deb8u1_all.deb OpenStack Image Service - Python client library
python-glanceclient_0.12.0-1_all.deb Client library for Openstack glance server
python-glitch_0.6-3_all.deb Python library for OpenGL graphics programming
python-gluon_1.99.7-1_all.deb High-level Python web development framework
python-gmenu_3.0.1-4_i386.deb GNOME implementation of the freedesktop menu specification
python-gmpy2-common_2.0.3-1_all.deb interfaces GMP to Python for fast, unbound-precision computations
python-gmpy2_2.0.3-1+b1_i386.deb interfaces GMP to Python 2 for fast, unbound-precision computations
python-gmpy_1.15-1_i386.deb interfaces GMP to Python for fast, unbound-precision computations
python-gmsh_2.8.5+dfsg-1.1+b1_i386.deb Three-dimensional finite element mesh generator. Python wrapper
python-gnatpython-doc_54-3_all.deb Python framework to ease development of test suites (examples)
python-gnatpython_54-3_i386.deb Python framework to ease development of test suites
python-gnome2-desktop-dev_2.32.0+dfsg-3_all.deb Python bindings for the GNOME desktop environment
Advertisement
Advertisement