python-bobo_0.2.2-3_all.deb


Advertisement

Description

python-bobo - Web application framework for the impatient

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name python-bobo
Package version 0.2.2
Package release 3
Package architecture all
Package type deb
Installed size 192 B
Download size 18.57 KB
Official Mirror ftp.br.debian.org
Bobo is a light-weight framework for creating WSGI web applications. It's goal
is to be easy to use and remember.
It addresses 2 problems: Mapping URLs to objects, calling objects to
generate HTTP responses.
Bobo doesn't have a templateing language, a database integration layer, or a
number of other features that are better provided by WSGI middle-ware or
application-specific libraries.
Bobo builds on other frameworks, most notably WSGI and WebOb.

Alternatives

Package Version Architecture Repository
python-bobo_0.2.2-3_all.deb 0.2.2 all Debian Main
python-bobo - - -

Requires

Name Value
python >= 2.6.6-7~
python << 2.8
python-pkg-resources -
python-webob -
python2.6 -
python2.7 -

Provides

Name Value
python2.6-bobo -
python2.7-bobo -

Download

Type URL
Binary Package python-bobo_0.2.2-3_all.deb
Source Package bobo

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-bobo deb package:
    # sudo apt-get install python-bobo

Files

Path
/usr/bin/bobo
/usr/lib/python2.6/dist-packages/bobo.py
/usr/lib/python2.6/dist-packages/boboserver.py
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/PKG-INFO
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/SOURCES.txt
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/dependency_links.txt
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/entry_points.txt
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/requires.txt
/usr/lib/python2.6/dist-packages/bobo-0.2.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/bobo.py
/usr/lib/python2.7/dist-packages/boboserver.py
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/top_level.txt
/usr/share/doc/python-bobo/README.txt
/usr/share/doc/python-bobo/changelog.Debian.gz
/usr/share/doc/python-bobo/copyright
/usr/share/pyshared/bobo.py
/usr/share/pyshared/boboserver.py
/usr/share/pyshared/bobo-0.2.2.egg-info/PKG-INFO
/usr/share/pyshared/bobo-0.2.2.egg-info/SOURCES.txt
/usr/share/pyshared/bobo-0.2.2.egg-info/dependency_links.txt
/usr/share/pyshared/bobo-0.2.2.egg-info/entry_points.txt
/usr/share/pyshared/bobo-0.2.2.egg-info/requires.txt
/usr/share/pyshared/bobo-0.2.2.egg-info/top_level.txt

Changelog

2011-05-16 - Arnaud Fontaine <arnau@debian.org>
bobo (0.2.2-3) unstable; urgency=low
* Team upload. Closes: #623918.
* Switch to "3.0 (quilt)" source format.
* debian/control:
+ Bump Standards-Version to 3.9.2. No changes needed.
+ Add Vcs-Browser fields.
+ Rename XS-Vcs-Svn to Vcs-Svn (dpkg supports it now).
+ Remove minimum required version of python-setuptools because even
stable has a greater version.
+ Build-Depends on python-all (not -dev).
+ Add Depends on python-pkg-resources as it is required by the script.
Closes: #602023.
* debian/rules:
+ Drop versioned scripts.
* Switch from deprecated dh_pycentral to dh_python2. Closes: #616749.
+ debian/control:
- Bump python-all minimum version to 2.6.6-3~.
- Remove python-central from Build-Depends.
- Remove deprecated XB-Python-Version.
- Rename deprecated XS-Python-Version to X-Python-Version and specify
explicitly the minimum supported version.
+ debian/rules:
- Use --with python2 rather than --with python-central.
* debian/docs:
+ Add README.txt.
2010-01-26 - Brian Sutherland <brian@vanguardistas.net>
bobo (0.2.2-2) unstable; urgency=low
* Bump the build depends on python-setuptools to 0.6c9 to prevent the
attempted download of a newer setuptools.
2010-01-12 - Brian Sutherland <brian@vanguardistas.net>
bobo (0.2.2-1) unstable; urgency=low
* Initial Packaging.

See Also

Package Description
python-bootstrapform-doc_3.1.0-5_all.deb generate twitter-bootstrap form output for django form - doc
python-bootstrapform_3.1.0-5_all.deb generate twitter-bootstrap form output for django form - Python 2.x
python-boto_2.34.0-2_all.deb Python interface to Amazon's Web Services - Python 2.x
python-botocore_0.62.0-1_all.deb Low-level, data-driven core of boto 3 (Python 2)
python-bottle-doc_0.12.7-1+deb8u2_all.deb fast and simple WSGI-framework for Python - documentation
python-bottle_0.12.7-1+deb8u2_all.deb fast and simple WSGI-framework for Python
python-box2d-doc_2.0.2+svn20100109.244-1_all.deb Python Bindings for the 2D Physics Engine Box2D - documentation
python-box2d_2.0.2+svn20100109.244-1+b1_i386.deb Python Bindings for the 2D Physics Engine Box2D
python-braintree_3.4.0-1_all.deb Braintree Python library (Python 2)
python-breadability_0.1.20-3_all.deb Python module that makes HTML documents more readable
python-breathe_3.1.0-1_all.deb Sphinx autodox support for languages other than Python (Python 2)
python-brian-doc_1.4.1-2_all.deb simulator for spiking neural networks - documentation
python-brian-lib_1.4.1-2_i386.deb simulator for spiking neural networks -- extensions
python-brian_1.4.1-2_all.deb simulator for spiking neural networks
python-brlapi_5.2~20141018-5_i386.deb Braille display access via BRLTTY - Python bindings
Advertisement
Advertisement