postgresql-9.4-preprepare_0.7-2_i386.deb


Advertisement

Description

postgresql-9.4-preprepare - pre prepare your PostgreSQL statements server side

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name postgresql-9.4-preprepare
Package version 0.7
Package release 2
Package architecture i386
Package type deb
Installed size 18 B
Download size 8.39 KB
Official Mirror ftp.br.debian.org
The pre_prepare module for PostgreSQL aims to prepare all your statements as
soon as possible and in a way that allows client queries not to bother at all
and just call EXECUTE.

Alternatives

Package Version Architecture Repository
postgresql-9.4-preprepare_0.7-2_amd64.deb 0.7 amd64 Debian Main
postgresql-9.4-preprepare - - -

Requires

Name Value
libc6 >= 2.1.3
postgresql-9.4 -

Download

Type URL
Binary Package postgresql-9.4-preprepare_0.7-2_i386.deb
Source Package preprepare

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install postgresql-9.4-preprepare deb package:
    # sudo apt-get install postgresql-9.4-preprepare

Files

Path
/usr/lib/postgresql/9.4/lib/pre_prepare.so
/usr/lib/postgresql/9.4/lib/plugins/pre_prepare.so
/usr/share/doc/postgresql-9.4-preprepare/README.asciidoc
/usr/share/doc/postgresql-9.4-preprepare/changelog.Debian.gz
/usr/share/doc/postgresql-9.4-preprepare/copyright
/usr/share/postgresql/9.4/extension/pre_prepare--0.4.sql
/usr/share/postgresql/9.4/extension/pre_prepare--unpackaged--0.4.sql
/usr/share/postgresql/9.4/extension/pre_prepare.control

Changelog

2014-07-25 - Christoph Berg <myon@debian.org>
preprepare (0.7-2) unstable; urgency=medium
* Reupload for 9.4.
2014-06-24 - Christoph Berg <christoph.berg@credativ.de>
preprepare (0.7-1) unstable; urgency=medium
* Ship plugin symlink in the package so users don't need to create them
manually.
* Use "all" in debian/pgversions.
* Add Vcs headers.
* Set team as maintainer.
2014-01-26 - Christoph Berg <myon@debian.org>
preprepare (0.6-2) unstable; urgency=medium
* Add make to the test dependencies.
2013-12-10 - Christoph Berg <christoph.berg@credativ.de>
preprepare (0.6-1) unstable; urgency=low
* New upstream release with 9.3 support. (Closes: #731517)
* Convert debian/*.docs to dh_installdocs --all.
* debian/rules: Use "pg_buildext loop".
* Add myself to Uploaders.
* Update description to mention PostgreSQL.
* Add example query to README.*.
* Run regression tests using autopkgtest.
* Add watch file.
2011-10-31 - Dimitri Fontaine <dim@tapoueh.org>
preprepare (0.5-1) unstable; urgency=low
* Fix an error with -Werror=format-security, from ubuntu builds (Closes: #647222)
2011-09-05 - Dimitri Fontaine <dim@tapoueh.org>
preprepare (0.4-2) unstable; urgency=low
[ Dimitri Fontaine ]
* Repackage for 9.1 support (Closes: #639482)
[ Christoph Berg ]
* Remove debian/*.dirs, they are not needed.
* Override dh_auto_install to do nothing, dh_install will take care.
2010-02-18 - Sandro Tosi <morph@debian.org>
preprepare (0.4-1.1) unstable; urgency=low
* Non-maintainer upload.
* debian/{control, postgresql-8.3*, rules}
- support only PostgreSQL 8.4, dropping support for 8.3; thanks to Martin
Pitt for the report; Closes: #559611
2009-08-18 - Dimitri Fontaine <dim@tapoueh.org>
preprepare (0.4-1) unstable; urgency=low
* Better support for GUC options
2009-07-18 - Dimitri Fontaine <dim@tapoueh.org>
preprepare (0.3-1) unstable; urgency=low
* Add support for discard() function
* Add support for prepare_all('schema.relation'), overriding GUC setting
* Document those additions
2009-07-07 - Dimitri Fontaine <dim@tapoueh.org>
preprepare (0.2-1) unstable; urgency=low
* Add support for local_preload_libraries and preprepare.at_init = on
for PostgreSQL 8.4 and following
* ITP (Closes: #536782)

See Also

Package Description
postgresql-9.4-python-multicorn_1.0.4-1_i386.deb multicorn extension for Postgres 9.4 to write FDWs with python2
postgresql-9.4-python3-multicorn_1.0.4-1_i386.deb multicorn extension for Postgres 9.4 to write FDWs with python3
postgresql-9.4-repmgr_2.0-3_i386.deb replication manager support modules for PostgreSQL 9.4
postgresql-9.4-slony1-2_2.2.3-1_i386.deb replication system for PostgreSQL: PostgreSQL 9.4 server plug-in
postgresql-9.4_9.4.15-0+deb8u1_i386.deb object-relational SQL database, version 9.4 server
postgresql-autodoc_1.40-3_all.deb Utility to create a PostgreSQL database schema overview in HTML, DOT and XML
postgresql-client-9.4_9.4.15-0+deb8u1_i386.deb front-end programs for PostgreSQL 9.4
postgresql-client-common_165+deb8u3_all.deb manager for multiple PostgreSQL client versions
postgresql-client_9.4+165+deb8u3_all.deb front-end programs for PostgreSQL (supported version)
postgresql-common_165+deb8u3_all.deb PostgreSQL database-cluster manager
postgresql-comparator_2.2.5-2_i386.deb efficient PostgreSQL table content comparison and synchronization
postgresql-contrib-9.4_9.4.15-0+deb8u1_i386.deb additional facilities for PostgreSQL
postgresql-contrib_9.4+165+deb8u3_all.deb additional facilities for PostgreSQL (supported version)
postgresql-doc-9.4_9.4.15-0+deb8u1_all.deb documentation for the PostgreSQL database management system
postgresql-doc_9.4+165+deb8u3_all.deb documentation for the PostgreSQL database management system
Advertisement
Advertisement