postgis_2.1.4+dfsg-3_i386.deb


Advertisement

Description

postgis - Geographic objects support for PostgreSQL

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name postgis
Package version 2.1.4+dfsg
Package release 3
Package architecture i386
Package type deb
Installed size 987 B
Download size 559.34 KB
Official Mirror ftp.br.debian.org
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
This package contains the PostGIS userland binaries, common files.

Alternatives

Package Version Architecture Repository
postgis_2.1.4+dfsg-3_amd64.deb 2.1.4+dfsg amd64 Debian Main
postgis - - -

Requires

Name Value
libc6 >= 2.4
libgdal1h >= 1.9.0
libgeos-c1 >= 3.4.2
libglib2.0-0 >= 2.12.0
libgtk2.0-0 >= 2.14.0
liblwgeom-2.1.4 >= 2.0.0
libpq5 -

Download

Type URL
Binary Package postgis_2.1.4+dfsg-3_i386.deb
Source Package postgis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install postgis deb package:
    # sudo apt-get install postgis

Files

Path
/usr/bin/pgsql2shp
/usr/bin/raster2pgsql
/usr/bin/shp2pgsql
/usr/bin/shp2pgsql-gui
/usr/share/doc/postgis/README.Debian
/usr/share/doc/postgis/changelog.Debian.gz
/usr/share/doc/postgis/changelog.gz
/usr/share/doc/postgis/copyright
/usr/share/doc/postgis-doc/README.postgis.gz
/usr/share/man/man1/pgsql2shp.1.gz
/usr/share/man/man1/raster2pgsql.1.gz
/usr/share/man/man1/shp2pgsql-gui.1.gz
/usr/share/man/man1/shp2pgsql.1.gz

Changelog

2015-03-30 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.4+dfsg-3) unstable; urgency=high
* Add patch geojson-fix-3094.patch, back-ported from the 2.1.7 release,
to fix a crash of the database backend process when given invalid
GeoJSON data.
2014-10-15 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.4+dfsg-2) unstable; urgency=medium
* Add Dutch translation by Frans Spiesschaert. Closes: #765409.
* Bump S-V: no changes required.
2014-09-21 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.4+dfsg-1) unstable; urgency=medium
[ Paulo Flabiano Smorigo ]
* add -lm for liblwgeom to avoid linkage problem.
* enable ppc64el.
(closes: #759505)
[ Bas Couwenberg ]
* Add Swedish translation by Martin Bagge. Closes: #761975.
* Add strip-invalid-whitespace-in-pom.patch to fix mh_cleanpom failure.
* Update copyright file.
* Add patch to fix FTBFS on hurd-i386.
[ Markus Wanner ]
* New upstream release, 2.1.4. Adapt packaging to the new version.
* Drop patches debian-versions, fix-armel, use-json-c, and
postgresql-9.4-fixes.patch, these should be fixed upstream.
* Refresh patches use-debian-maven, honor-build-flags, and
enable-ppc64el.patch.
* Add patch correct-java-version.patch.
2014-08-14 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.3+dfsg-4) unstable; urgency=low
[ Bas Couwenberg ]
* Add Czech translation by Michal Šimůnek. Closes: 751426.
* Add Japanese translation by victory. Closes: 756718.
* Add Danish translation by Joe Dalton. Closes: 757653.
* Update for PostgreSQL 9.4.
[ Jérémy Lal ]
* Switch Build-Deps back to default-jdk instead of openjdk 7 | 8,
as gcj-jdk does work now.
* Backport upstream commits fixing test results with PostgreSQL 9.4.
[ Markus Wanner ]
* Let postgis recommend the (most up to date) extension, rather than
only suggesting it.
2014-05-22 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.3+dfsg-3) unstable; urgency=high
* In patch use-debian-maven: Also drop the version requirement for the
maven-javadoc-plugin.
* Add Breaks & Replaces against liblwgeom-2.1.2, which shipped
liblwgeom-2.1.3.so in a package named liblwgeom-2.1.2 due to the
attempted quick security fix. Closes: #749015.
2014-05-21 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.3+dfsg-2) unstable; urgency=high
[ Bas Couwenberg ]
* Bump liblwgeom package name from 2.1.2 to 2.1.3.
(closes: #748756)
[ Markus Wanner ]
* Add NEWS.Debian to warn about a possibly breaking change.
* Correct patch use-json-c. Drop explicit dependencies, but rely on
shlibs:Depends, instead. Closes: #748332.
* Revert parts of the patch use-debian-maven to actually build the
javadocs. Add a libpostgis-java-doc package carrying the docs.
2014-05-14 - Markus Wanner <markus@bluegap.ch>
postgis (2.1.3+dfsg-1) unstable; urgency=high
* New upstream release, 2.1.3: strengthens the code to forbid database
users to trigger opening of arbitrary files or network connections by
the system user running the PostgreSQL server process.
* Add B-D-I libmaven-javadoc-plugin-java to support a new plugin in the
jdbc pom file - supposedly generating java documentation.
* Adjust the following patches to the new release: debian-versions, and
use-debian-maven.
* Refresh line numbers on: honor-build-flags, use-json-c.
* Drop obsolete patch: java-version-fix.

See Also

Package Description
postgresql-9.4-asn1oid_0.0.20100818-3.1_i386.deb ASN.1 OID data type for PostgreSQL
postgresql-9.4-debversion_1.0.7-4_i386.deb Debian version number type for PostgreSQL
postgresql-9.4-ip4r_2.0.2-3_i386.deb IPv4 and IPv6 types for PostgreSQL 9.4
postgresql-9.4-orafce_3.0.7-4_i386.deb Oracle support functions for PostgreSQL 9.4
postgresql-9.4-pgespresso_1.0-2_i386.deb extension for Barman, Backup and Recovery Manager for PostgreSQL
postgresql-9.4-pgextwlist_1.3-3_i386.deb PostgreSQL Extension Whitelisting
postgresql-9.4-pgfincore_1.1.2-3_i386.deb set of PostgreSQL functions to manage blocks in memory
postgresql-9.4-pgmemcache_2.2.0-1_i386.deb PostgreSQL interface to memcached
postgresql-9.4-pgmp_1.0.1-6_i386.deb arbitrary precision integers and rationals for PostgreSQL 9.4
postgresql-9.4-pgpool2_3.3.4-1_i386.deb connection pool server and replication proxy for PostgreSQL - modules
postgresql-9.4-pgq3_3.2-2_i386.deb Skype tools for PostgreSQL replication, londiste and PGQ
postgresql-9.4-pgrouting-doc_2.0.0-3_all.deb basic routing functionality support for PostgreSQL 9.4 (Documentation)
postgresql-9.4-pgrouting_2.0.0-3_i386.deb basic routing functionality support for PostgreSQL 9.4
postgresql-9.4-pllua_1.0-5_i386.deb Lua procedural language for PostgreSQL 9.4
postgresql-9.4-plproxy_2.5-5_i386.deb database partitioning system for PostgreSQL 9.4
Advertisement
Advertisement