pkg-kde-tools_0.15.15_all.deb


Advertisement

Description

pkg-kde-tools - various packaging tools and scripts for KDE Applications

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name pkg-kde-tools
Package version 0.15.15
Package architecture all
Package type deb
Installed size 439 B
Download size 92.91 KB
Official Mirror ftp.br.debian.org
This package contains a variety of packaging tools and build scripts that may
be very useful when packaging KDE applications. Even if you are a maintainer
of a very small KDE application, this package should be worthwhile checking
out.
Main highlights:
- recommended build flags for building packages based on the KDE Platform;
- cdbs class for building packages based on the KDE Platform (kde.mk);
- debhelper build system (--buildsystem=kde) and dh addon (--with kde) for
building packages based on the KDE Platform;
- dh_sameversiondep for generating a dependency that is versioned the same
way as a dependency (coming from the same source) of another reference
package.
- dh_movelibkdeinit for moving libkdeinit4_*.so libraries to private
location;
- dh_sodeps (and sodeps dh addon) for generating so:Depends substvar for -dev
packages based to which local packages lib*.so symlinks point to;
- pkgkde-symbolshelper tool for efficient management of C and C++ symbol
files;
- pkgkde-debs2symbols tool for generating symbol files and symbol file
patches from pre-built binaries in the deb packages;
- pkgkde-getbuildlogs tool for downloading build logs for the specified
package (from buildd.debian.org);
- pkgkde-override-sc-dev-latest tool for overriding Breaks of the
kde-sc-dev-latest package;
- pkgkde-vcs tool for performing common tasks when packaging under VCS.
NOTE: since this package is cumulative, it does not depend on the packages it
provides helpers for. I.e. you still need to explicitly build depend on
debhelper or cdbs in your packages.

Alternatives

Package Version Architecture Repository
pkg-kde-tools_0.15.15_all.deb 0.15.15 all Debian Main
pkg-kde-tools - - -

Requires

Name Value
libdpkg-perl >= 1.15.6~
perl -

Download

Type URL
Binary Package pkg-kde-tools_0.15.15_all.deb
Source Package pkg-kde-tools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pkg-kde-tools deb package:
    # sudo apt-get install pkg-kde-tools

Files

Path
/usr/bin/dh_movelibkdeinit
/usr/bin/dh_sameversiondep
/usr/bin/dh_sodeps
/usr/bin/pkgkde-debs2symbols
/usr/bin/pkgkde-gensymbols
/usr/bin/pkgkde-getbuildlogs
/usr/bin/pkgkde-git
/usr/bin/pkgkde-override-sc-dev-latest
/usr/bin/pkgkde-symbolshelper
/usr/bin/pkgkde-vcs
/usr/share/doc/pkg-kde-tools/NEWS.Debian.gz
/usr/share/doc/pkg-kde-tools/README.Debian
/usr/share/doc/pkg-kde-tools/README.DebianABIManager
/usr/share/doc/pkg-kde-tools/changelog.gz
/usr/share/doc/pkg-kde-tools/copyright
/usr/share/lintian/overrides/pkg-kde-tools
/usr/share/man/man1/dh_movelibkdeinit.1.gz
/usr/share/man/man1/dh_sameversiondep.1.gz
/usr/share/man/man1/dh_sodeps.1.gz
/usr/share/man/man1/pkgkde-gensymbols.1.gz
/usr/share/man/man1/pkgkde-git.1.gz
/usr/share/man/man1/pkgkde-override-sc-dev-latest.1.gz
/usr/share/man/man1/pkgkde-vcs.1.gz
/usr/share/perl5/Debian/PkgKde.pm
/usr/share/perl5/Debian/Debhelper/Buildsystem/kde.pm
/usr/share/perl5/Debian/Debhelper/Sequence/kde.pm
/usr/share/perl5/Debian/Debhelper/Sequence/pkgkde_symbolshelper.pm
/usr/share/perl5/Debian/Debhelper/Sequence/sodeps.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/CompileTest.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Patching.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/String.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Subst.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Substs.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Symbol.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/SymbolFile.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/SymbolFileCollection.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm
/usr/share/pkg-kde-tools/bin/dpkg-gensymbols
/usr/share/pkg-kde-tools/cmake/DebianABIManager.cmake
/usr/share/pkg-kde-tools/cmake/README.DebianABIManager
/usr/share/pkg-kde-tools/cmake/debabi_verscript.cmake
/usr/share/pkg-kde-tools/cmake/debcontrol2cmake.pl
/usr/share/pkg-kde-tools/lib/kde4_flags
/usr/share/pkg-kde-tools/lib/shell_common
/usr/share/pkg-kde-tools/lib/Dpkg/Shlibs/Cppfilt.pm
/usr/share/pkg-kde-tools/lib/Dpkg/Shlibs/Objdump.pm
/usr/share/pkg-kde-tools/lib/Dpkg/Shlibs/Symbol.pm
/usr/share/pkg-kde-tools/lib/Dpkg/Shlibs/SymbolFile.pm
/usr/share/pkg-kde-tools/makefiles/1/variables.mk
/usr/share/pkg-kde-tools/makefiles/1/cdbs/kde.mk
/usr/share/pkg-kde-tools/makefiles/1/cdbs/symbolshelper.mk
/usr/share/pkg-kde-tools/qt-kde-team/README
/usr/share/pkg-kde-tools/qt-kde-team/1/debian-qt-kde.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/library-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/policy.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/policy/unstable.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/README
/usr/share/pkg-kde-tools/qt-kde-team/2/commands
/usr/share/pkg-kde-tools/qt-kde-team/2/debian-qt-kde.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/dhmk.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/dhmk.pl
/usr/share/pkg-kde-tools/qt-kde-team/2/library-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/list-missing.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/policy.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/policy/unstable.mk
/usr/share/pkg-kde-tools/vcs/git.sh

Changelog

2014-07-13 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.15) unstable; urgency=medium
* The fix for #744173 required to convert non-anchored regexps to anchored
ones. The problem with this is that kfreebsd-amd64 was no longer matched.
Fix it by adding kfreebsd-amd64 in the lists where amd64 appears, as
they both share the same sizes (Closes: #754765).
2014-07-12 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.14) unstable; urgency=medium
[ William Grant ]
* perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm:
- Anchor architecture matches to the ends of the string, to avoid
erroneously mapping qreal to float on arm64.
- Add arm64 and ppc64el to the 64-bit matches (Closes: #744173).
[ Helmut Grohne ]
* Mark binary pkg-kde-tools as M-A:foreign. (Closes: #751338).
2014-02-23 - Maximiliano Curia <maxy@debian.org>
pkg-kde-tools (0.15.13) unstable; urgency=medium
[ Maximiliano Curia ]
* Fix "Useless use of \E at" warning in dhmk.pl.
* Bump Standards-Version to 3.9.5, no further changes needed.
[ Pino Toscano ]
* debcontrol2cmake.pl: filter out binary packages not belonging to the build
architecture.
2013-12-18 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.12) unstable; urgency=low
[ Dmitry Shachnev ]
* pkgkde-symbolshelper: fix qptrdiff expansion for s390x.
2013-11-14 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.11) unstable; urgency=low
* Add support for mips64 and mips64el. Thanks YunQiang Su for the patch.
(Closes: #723223).
2013-10-03 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.10) unstable; urgency=low
* Actually s390 uses 'j' (unsigned int) for quintptr (Closes: #725300).
2013-10-02 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.9) unstable; urgency=low
* Add s390 and s390x to the list of archs that use 'y' (unsigned long long)
as replacement for quintptr (Closes: #725023).
* Add myself to Uploaders.
2013-08-25 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
pkg-kde-tools (0.15.8) unstable; urgency=low
* Team upload.
[ Felix Geyer ]
* pkgkde-symbolshelper: Add intptr_t type substitution.
[ Pino Toscano ]
* Fix Vcs-* headers.
2013-05-20 - Modestas Vainius <modax@debian.org>
pkg-kde-tools (0.15.7) unstable; urgency=low
* pkgkde-vcs: replace support for lenny-backports with wheezy-backports.
2013-05-10 - Maximiliano Curia <maxy@debian.org>
pkg-kde-tools (0.15.6) unstable; urgency=low
* pkgkde-git: Update sanity check, allow git clones inside gited homes.
* Add myself to Uploaders.
* Bump debhelper buil-dep and compat to 9.
* Bump Standards-Version to 3.9.4, no further changes needed.

See Also

Package Description
pkg-mozilla-archive-keyring_1.1_all.deb GnuPG archive keys for the Debian Mozilla team package repository
pkg-perl-autopkgtest_0.19_all.deb collection of autopktest scripts for Perl packages
pkg-perl-tools_0.19_all.deb collection of tools to aid packaging Perl modules in Debian
pkg-php-tools_1.28_all.deb various packaging tools and scripts for PHP packages
pkgconf_0.9.7-1_i386.deb manage compile and link flags for libraries
pkgsync_1.23_all.deb automated package list synchronization
pkpgcounter_3.50-7_all.deb computes number of pages or quantity of ink needed to print documents
pktools-dev_2.5.3-1+b1_i386.deb GDAL add-on tools to perform useful raster processing - development files
pktools_2.5.3-1+b1_i386.deb GDAL add-on tools to perform useful raster processing
pktstat_1.8.5-4_i386.deb top-like utility for network connections usage
plainbox-insecure-policy_0.5.4-1_all.deb policykit policy required to use plainbox (insecure version)
plainbox-provider-checkbox_0.3-2_i386.deb CheckBox provider for PlainBox
plainbox-provider-resource-generic_0.3-1_i386.deb CheckBox generic resource jobs provider
plainbox-secure-policy_0.5.4-1_all.deb policykit policy required to use plainbox (secure version)
plainbox_0.5.4-1_all.deb toolkit for software and hardware integration testing
Advertisement
Advertisement