pkg-config_0.28-1_i386.deb


Advertisement

Description

pkg-config - manage compile and link flags for libraries

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name pkg-config
Package version 0.28
Package release 1
Package architecture i386
Package type deb
Installed size 148 B
Download size 55.81 KB
Official Mirror ftp.br.debian.org
pkg-config is a system for managing library compile and link flags that
works with automake and autoconf.
Increasingly libraries ship with ".pc" files that allow querying of the
compiler and linker flags needed to use them through the pkg-config(1)
program.

Alternatives

Package Version Architecture Repository
pkg-config_0.28-1_amd64.deb 0.28 amd64 Debian Main
pkg-config - - -

Requires

Name Value
libc6 >= 2.3
libglib2.0-0 >= 2.16.0

Download

Type URL
Binary Package pkg-config_0.28-1_i386.deb
Source Package pkg-config

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pkg-config deb package:
    # sudo apt-get install pkg-config

Files

Path
/usr/bin/i486-pc-linux-gnu-pkg-config
/usr/bin/pkg-config
/usr/share/pkg-config-crosswrapper
/usr/share/aclocal/pkg.m4
/usr/share/doc/pkg-config/AUTHORS
/usr/share/doc/pkg-config/NEWS.gz
/usr/share/doc/pkg-config/README
/usr/share/doc/pkg-config/changelog.Debian.gz
/usr/share/doc/pkg-config/changelog.gz
/usr/share/doc/pkg-config/copyright
/usr/share/doc/pkg-config/pkg-config-guide.html
/usr/share/man/man1/pkg-config.1.gz

Changelog

2014-04-23 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.28-1) unstable; urgency=medium
* New upstream release.  (Closes: #699476, #744031)
- Updated man page with fewer errors. (Closes: #661838)
* Fix test running with newer automake.
* Drop popt stuff from debian/rules, upstream no longer ships popt.
2014-03-24 - Wookey <wookey@debian.org>
pkg-config (0.26-1+autoconf) unreleased; urgency=medium
* Non-maintainer upload.
* Update config.{sub,guess} for new arches (with dh-autoreconf) (Closes: #742665)
* Add Multiarch metadata (M-A: foreign), so this package can
satisfy cross- build-dependencies. The cross-build environment is
responsible for providing the $triplet-pkg-config symlink to
pkg-config-crosswrapper. (Closes: #726598)
* Update crosswrapper script to search multiarch paths, traditional
cross-compilation paths, arch-independent paths, and /usr/local counterparts.
Thanks to Simon McVittie, Steve Langasek, Vincent Danjean, Wookey
(Closes: #642292, #650298, #631275)
* Make pkg-config itself cross-buildable. (Closes: #716918)
2011-05-15 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.26-1) unstable; urgency=low
* New upstream release
- Updated usage message.  Closes: #389066
- Fixes old bug.  Closes: #475031
- Allows PKG_CONFIG_LIBDIR.  Closes: #398901
- Man page documents how to get the default search path.  
Closes: #576320
* Switch to multiarch paths.  Thanks to Steve Langasek for the patch.
Closes: #590992
* Strip out multiarch library paths.  Closes: #482884
* Drop a cross wrapper into /usr/share.  Thanks to Wookey for the
implementation.   Closes: #217902
* Re-add two missing lines in Changelog which were accidentially
removed.
2010-10-03 - Tim Retout <diocles@debian.org>
pkg-config (0.25-1.1) unstable; urgency=low
* Non-maintainer upload.
* pkg.m4: Apply commit 2b86e9b from upstream, to fix compatibility with
autoconf (>= 2.66). (Closes: #591547)
2010-05-28 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.25-1) unstable; urgency=low
* New upstream release
- Stops escaping = and : in output.  Closes: #582995
* Build with external libpopt.
2010-05-23 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.24-1) unstable; urgency=low
* New upstream release. closes: #476947
- Marks PKG_CONFIG_PATH and PKG_CONFIG_LIBDIR as precious.  
Closes: #398901
- Give the ability to log, closes: #528240
- Adds description of Requires.Private to man page.  Closes: #341977
- Fixes man page formatting.  Closes: #398434
* Add ${misc:Depends} to control
* Bump debhelper version to 7, switch to dh
* Add homepage field to control
* Update Standards-Version field to 3.8.4.
2007-06-18 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.22-1) unstable; urgency=low
* New upstream release
- Make Requires.private a whole lot more useful by traversing the
whole tree, not just the top-level, for Cflags.  Closes: #390132
- Add support for using the system glib.
* Build using system glib.
* Add _GNU_SOURCE to the list of defines to make strsignal appear.
Closes: #316384
* Remove suggests for libgnome-dev.  Closes: #405901
2006-08-16 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.21-1) unstable; urgency=low
* New upstream release
- Adds internal pkg-config package.  (closes: #254289)
- Supports escaping $ rather than %.  (closes: #378570)
- Always adds all cflags.  (closes: #340904)
* Includes full NEWS file.  (closes: #334896)
* Remove libglib2.0-dev build-deps.  (closes: #350176)
2005-10-17 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.20-1) unstable; urgency=low
* New upstream release
- Fixes segfault with --help and gcc4 (closes: #321961)
- New pkg.m4 uses --short-errors and spits out a more sensible error
when some dependencies aren't found.  (closes: #321970)
* Install upstream ChangeLog (closes: #318718)

See Also

Package Description
pkg-kde-tools_0.15.15_all.deb various packaging tools and scripts for KDE Applications
pkg-mozilla-archive-keyring_1.1_all.deb GnuPG archive keys for the Debian Mozilla team package repository
pkg-perl-autopkgtest_0.19_all.deb collection of autopktest scripts for Perl packages
pkg-perl-tools_0.19_all.deb collection of tools to aid packaging Perl modules in Debian
pkg-php-tools_1.28_all.deb various packaging tools and scripts for PHP packages
pkgconf_0.9.7-1_i386.deb manage compile and link flags for libraries
pkgsync_1.23_all.deb automated package list synchronization
pkpgcounter_3.50-7_all.deb computes number of pages or quantity of ink needed to print documents
pktools-dev_2.5.3-1+b1_i386.deb GDAL add-on tools to perform useful raster processing - development files
pktools_2.5.3-1+b1_i386.deb GDAL add-on tools to perform useful raster processing
pktstat_1.8.5-4_i386.deb top-like utility for network connections usage
plainbox-insecure-policy_0.5.4-1_all.deb policykit policy required to use plainbox (insecure version)
plainbox-provider-checkbox_0.3-2_i386.deb CheckBox provider for PlainBox
plainbox-provider-resource-generic_0.3-1_i386.deb CheckBox generic resource jobs provider
plainbox-secure-policy_0.5.4-1_all.deb policykit policy required to use plainbox (secure version)
Advertisement
Advertisement