packagekit-command-not-found_1.0.1-2_i386.deb


Advertisement

Description

packagekit-command-not-found - Offer to install missing programs automatically

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename packagekit-command-not-found_1.0.1-2_i386.deb
Package name packagekit-command-not-found
Package version 1.0.1
Package release 2
Package architecture i386
Package type deb
Category misc
Homepage http://www.packagekit.org
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 28.32 KB
Installed size 60.00 KB
PackageKit allows performing simple software management tasks over a DBus
interface e.g refreshing the cache, updating, installing and removing
software packages or searching for multimedia codecs and file handlers.
This package contains a simple handler for command_not_found that offers to
install missing packages on the command line using PackageKit.

Alternatives

Package Version Architecture Repository
packagekit-command-not-found_1.0.1-2_amd64.deb 1.0.1 amd64 Debian Main
packagekit-command-not-found - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.37.3
libpackagekit-glib2-18 >= 0.9.4
packagekit = 1.0.1-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package packagekit-command-not-found_1.0.1-2_i386.deb
Source Package packagekit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install packagekit-command-not-found deb package:
    # sudo apt-get install packagekit-command-not-found

Files

Path
/etc/PackageKit/CommandNotFound.conf
/etc/profile.d/PackageKit.sh
/usr/lib/packagekit/pk-command-not-found
/usr/share/doc/packagekit-command-not-found/changelog.Debian.gz
/usr/share/doc/packagekit-command-not-found/copyright

Changelog

2014-12-08 - Matthias Klumpp <mak@debian.org>
packagekit (1.0.1-2) unstable; urgency=medium
* Ship with pkla file for older PolicyKit versions (Closes: #766792)
* Place temporary data in subdirectory in /tmp (Closes: #764928)
* Don't try to ask any questions if we are running in
non-interactive mode (Closes: #764926)
* Drop obsolete configuration (Closes: #768420)
* Recommend PackageKit session-interface providers for packages
which need a session-interface (Closes: #770814)
2014-10-21 - Matthias Klumpp <mak@debian.org>
packagekit (1.0.1-1) unstable; urgency=medium
* New upstream release: 1.0.1
* Drop patches: Applied upstream
* Build package using dh-systemd to cleanup stuff on package removal
* Drop Python3 backend bindings
* Remove dist-upgrade notification support from aptcc
- This only really worked on Ubuntu, and the functionality relies
on outdated Python code and needs to be reimplemented in a
sane way. There is no need to ship cruft with Jessie.
2014-10-08 - Matthias Klumpp <mak@debian.org>
packagekit (1.0.0-3) unstable; urgency=medium
* Don't explicitly pass systemd unit path to configure
- Should resolve FTBFS on non-Linux ports
2014-09-27 - Matthias Klumpp <mak@debian.org>
packagekit (1.0.0-2) unstable; urgency=medium
* Add patch to fix systemd-dependent conditional compilation
- Will hopefully resolve the FTBFS on !linux
2014-09-22 - Matthias Klumpp <mak@debian.org>
packagekit (1.0.0-1) unstable; urgency=medium
* New upstream release: 1.0.0
- This release drops support for plugins
- Aptcc is now the only viable backend for Debian, other
backends have been removed upstream.
* Drop patches: Applied upstream
* Update symbols file
* Update copyright
* Bring back the PackageKit command-not-found support in a
separate package.
2014-09-08 - Matthias Klumpp <mak@debian.org>
packagekit (0.9.5-2) unstable; urgency=medium
* Include missing header for plugin builds
2014-09-08 - Matthias Klumpp <mak@debian.org>
packagekit (0.9.5-1) unstable; urgency=medium
* Upload to unstable
* New upstream release: 0.9.5
* Drop all previous patches: Applied upstream
* Drop defaults.diff: Debian's defaults are now upstream
* Take patch from upstream to increase hardcoded transation limits
* Update symbols file
2014-07-22 - Matthias Klumpp <mak@debian.org>
packagekit (0.9.4-1) experimental; urgency=medium
* New upstream release: 0.9.4
* Drop build-dep on browsers, use npapi-sdk instead (Closes: #754373)
* Drop patches which have been applied upstream
* npapi-sdk.patch: Compile using npapi-sdk
2014-06-14 - Matthias Klumpp <mak@debian.org>
packagekit (0.8.17-4) unstable; urgency=medium
* Tighten dependency on iceweasel-dev
* aptcc-python3.patch: Use Python3 for aptcc upgrade helper
* link-gstreamer1.0.patch: Link against GStreamer 1.0 by default
* Build GStreamer 1.0 plugin by default, drop 0.10 plugin
2014-06-14 - Matthias Klumpp <mak@debian.org>
packagekit (0.8.17-3) unstable; urgency=medium
* Don't ship transactions.db (Closes: #746327)
* tdb-permissions.patch: Update permissions on the transactions db
* Replace xulrunner-dev build-dep with dependency on iceweasel-dev

See Also

Package Description
packagekit-docs_1.0.1-2_all.deb Documentation for PackageKit
packagekit-gtk3-module_1.0.1-2_i386.deb Install fonts automatically using PackageKit
packagekit-tools_1.0.1-2_i386.deb Provides PackageKit command-line tools
packagekit_1.0.1-2_i386.deb Provides a package management service
packagesearch_2.7.4_i386.deb GUI for searching packages and viewing package information
packaging-dev_0.8_all.deb convenient tools to develop packages
packaging-tutorial_0.15_all.deb introduction to Debian packaging
packeth_1.6.5-2_i386.deb Ethernet packet generator
packit_1.0-2_i386.deb Network Injection and Capture
packup_0.6-2_i386.deb CUDF solver based on pseudo-Boolean constraints
pacman4console_1.3-1_i386.deb ncurses-based pacman game
pacman_10-17_i386.deb Chase Monsters in a Labyrinth
paco_2.0.9-3_i386.deb simple but yet powerful source code package management system
pacpl_4.0.5-7.1_all.deb multi-purpose audio converter/ripper/tagger script
padevchooser_0.9.4-1.1_i386.deb PulseAudio Device Chooser
Advertisement
Advertisement