nypatchy_20061220+dfsg3-4.1_i386.deb


Advertisement

Description

nypatchy - CERNLIB data analysis suite - patch pre-processor for source code

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name nypatchy
Package version 20061220+dfsg3
Package release 4.1
Package architecture i386
Package type deb
Installed size 1.10 KB
Download size 267.80 KB
Official Mirror ftp.br.debian.org
CERNLIB is a suite of data analysis tools and libraries created for
use in physics experiments, but also with applications to other
fields such as the biological sciences.
This package contains the Nypatchy family of programs, the successors to
Patchy and Ypatchy.  These programs are intended for working with sets of
patches (for instance, for use on different machine architectures) meant to
be applied to a source code tree.  The patch sets and common source code are
maintained as a single text-based Patchy Master file (PAM file).  PAM files
can contain C, FORTRAN, or assembly code.
Nypatchy and related utilities can perform actions on a PAM file such as
updating it; comparing it to an older version; or outputting source code
suitable for input to a compiler, having selected some subset of available
patches to use.  These utilities can be used interactively, or can run in
batch mode from a "cradle" file of commands.
While Nypatchy is still used in places, mainly high-energy physics, these
programs are no longer under active development.  They are not recommended
for use in new projects.

Alternatives

Package Version Architecture Repository
nypatchy_20061220+dfsg3-4.1_amd64.deb 20061220+dfsg3 amd64 Debian Main
nypatchy - - -

Requires

Name Value
cernlib-base >= 2006.dfsg.2-12
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libgfortran3 >= 4.6
libkernlib1-gfortran -
libquadmath0 >= 4.6

Download

Type URL
Binary Package nypatchy_20061220+dfsg3-4.1_i386.deb
Source Package cernlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nypatchy deb package:
    # sudo apt-get install nypatchy

Files

Path
/usr/bin/fcasplit
/usr/bin/nycheck
/usr/bin/nydiff
/usr/bin/nyindex
/usr/bin/nylist
/usr/bin/nymerge
/usr/bin/nypatchy
/usr/bin/nyshell
/usr/bin/nysynopt
/usr/bin/nytidy
/usr/bin/yexpand
/usr/bin/ypatchy
/usr/share/doc/nypatchy/NEWS.Debian.gz
/usr/share/doc/nypatchy/changelog.Debian.gz
/usr/share/doc/nypatchy/copyright
/usr/share/man/man1/fcasplit.1.gz
/usr/share/man/man1/nycheck.1.gz
/usr/share/man/man1/nydiff.1.gz
/usr/share/man/man1/nyindex.1.gz
/usr/share/man/man1/nylist.1.gz
/usr/share/man/man1/nymerge.1.gz
/usr/share/man/man1/nypatchy.1.gz
/usr/share/man/man1/nyshell.1.gz
/usr/share/man/man1/nysynopt.1.gz
/usr/share/man/man1/nytidy.1.gz
/usr/share/man/man1/yexpand.1.gz
/usr/share/man/man1/ypatchy.1.gz

Changelog

2014-08-28 - Aurelien Jarno <aurel32@debian.org>
cernlib (20061220+dfsg3-4.1) unstable; urgency=medium
[ Aurelien Jarno ]
* Non-maintainer upload.
[ Mauricio Faria de Oliveira ]
* Fix 'debian/control.new' for GNU make 3.82+ (Closes: #720689)
Thanks Michael Tautschnig. New versions of GNU make don't 'sort' the output
of 'wildcard' anymore. This is reported in the following GNU make announce:
https://lists.gnu.org/archive/html/info-gnu/2010-07/msg00023.html
2013-08-24 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-4) unstable; urgency=low
* cernlib-base-dev: depends on dpkg-dev to fix Multiarch support.
2013-08-23 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-3) unstable; urgency=low
* Support multiarch.
* Set source format to 3.0 (quilt).
* Temporarily disable test-suite. (Closes: #701254, #713535)
* {cernlib-base-dev,libmathlib2,pawserv}: set priority to optional.
* Apply patchset manually rather than using obsolete dpatch.
* debian/control:
- bump Standards-Version to 3.9.4.
- remove obsolete dpatch from build-dep.
- remove obsolete DM-Upload-Allowed field.
- transition from lesstif2 to motif, we will rename packages in next
upload. (Closes: #717639)
- canonical VCS-* fields.
2011-08-04 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-2) unstable; urgency=low
* Add patch 138: Remove invalid declaration of the REPEAT function.
(Closes: #636565).
* Add Danish translation of the debconf templates.
Thanks to Joe Dalton <joedalton2@yahoo.dk>. (Closes: #621357)
* debian/debhelper: rename to debian/dh to make lintian happy.
* Bump Standards-Version to 3.9.2. No change needed.

See Also

Package Description
nyquist_3.05-2_i386.deb language for music composition and sound synthesis
nzb_0.2-1_i386.deb Usenet binary grabber
nzbget_13.0+dfsg-1_i386.deb command-line based binary newsgrabber for nzb files
oaklisp-doc_1.3.3-5_all.deb Documentation for the Oaklisp dialect of Scheme
oaklisp_1.3.3-5_i386.deb An object-oriented dialect of Scheme
oar-api_2.5.4-2+deb8u1_all.deb transitional dummy package
oar-common_2.5.4-2+deb8u1_i386.deb OAR batch scheduler common package
oar-doc_2.5.4-2+deb8u1_all.deb OAR batch scheduler documentation package
oar-node_2.5.4-2+deb8u1_i386.deb OAR batch scheduler node package
oar-restful-api_2.5.4-2+deb8u1_i386.deb OAR web services
oar-server-mysql_2.5.4-2+deb8u1_i386.deb OAR batch scheduler MySQL server backend package
oar-server-pgsql_2.5.4-2+deb8u1_i386.deb OAR batch scheduler PostgreSQL server backend package
oar-server_2.5.4-2+deb8u1_i386.deb OAR batch scheduler server package
oar-user-mysql_2.5.4-2+deb8u1_i386.deb OAR batch scheduler MySQL user backend package
oar-user-pgsql_2.5.4-2+deb8u1_i386.deb OAR batch scheduler PostgreSQL user backend package
Advertisement
Advertisement