libupnp-dev_1.6.19+git20141001-1+deb8u1_all.deb


Advertisement

Description

libupnp-dev - Portable SDK for UPnP Devices (development files)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename libupnp-dev_1.6.19+git20141001-1+deb8u1_all.deb
Package name libupnp-dev
Package version 1.6.19+git20141001
Package release 1+deb8u1
Package architecture all
Package type deb
Category devel::library implemented-in::c libdevel network::client network::configuration network::server protocol::TODO role::devel-lib use::configuring
Homepage http://pupnp.sourceforge.net/
License -
Maintainer Nick Leverton <nick@leverton.org>
Download size 46.28 KB
Installed size 73.00 KB
The Portable SDK for UPnP Devices (libupnp) provides developers with an
API and open source code for building control points, devices, and
bridges that are compliant with Version 1.0 of the Universal Plug and
Play Device Architecture Specification - see http://www.upnp.org/ for
specifications.
The libupnp-dev package is a metapackage which will depend on the
current stable development package.

Alternatives

Package Version Architecture Repository
libupnp-dev_1.6.19+git20141001-1+deb8u1_all.deb 1.6.19+git20141001 all Debian Main
libupnp-dev - - -

Requires

Name Value
libupnp6-dev >= 1:1.6.19+git20141001-1+deb8u1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libupnp-dev_1.6.19+git20141001-1+deb8u1_all.deb
Source Package libupnp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libupnp-dev deb package:
    # sudo apt-get install libupnp-dev

Files

Path
/usr/share/doc/libupnp-dev/changelog.Debian.gz
/usr/share/doc/libupnp-dev/changelog.gz
/usr/share/doc/libupnp-dev/copyright

Changelog

2016-12-13 - Uwe Kleine-K├Ânig <ukleinek@debian.org>
libupnp (1:1.6.19+git20141001-1+deb8u1) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* backport fixes for CVE-2016-6255 and CVE-2016-8863
(Closes: #831857, #842093)
2014-10-08 - Nick Leverton <nick@leverton.org>
libupnp (1:1.6.19+git20141001-1) unstable; urgency=low
* Ack both NMUs, thankyou for your care of this package.
* New upstream release (Closes: #740584, #670964).  We take the git version
as the git log suggests some worthwhile security and reliability fixes.
* Build for IPv6 (note, UpnpInit() only enables IPv4 connections so
most existing libupnp users need not be aware of this).
* Change Priority to "optional" (Closes: #740582).
* Remove patch 0001-Security-fix-for-CERT-issue-VU-922681 now in upstream.
* Improve debian/rules hardening option usage stuff.
* Update Standards-Version to 3.9.6 (no changes required).
* Fix "memset(ctx, 0, sizeof(ctx));   /* In case it's sensitive */"
in our copy of Colin Plumb's md5.c (patch 01-debian-md5-licence.patch).
* Disable build tests since we aren't guaranteed to have network access
in buildds (patch 19).
2013-02-01 - Yves-Alexis Perez <corsac@debian.org>
libupnp (1:1.6.17-1.2) unstable; urgency=high
* Non-maintainer upload by the Security Team.
* debian/patches/0001-Security-fix-for-CERT-issue-VU-922681 added, fix
various stack-based buffer overflows in service_unique_name() function.
This fix CVE-2012-5958, CVE-2012-5959, CVE-2012-5960, CVE-2012-5961,
CVE-2012-5962, CVE-2012-5963, CVE-2012-5964, CVE-2012-5965. closes: #699316
2012-05-08 - Julien Cristau <jcristau@debian.org>
libupnp (1:1.6.17-1.1) unstable; urgency=high
* Non-maintainer upload.
* libupnp6-doc Replaces libupnp3-dev (closes: #670894)
2012-04-14 - Nick Leverton <nick@leverton.org>
libupnp (1:1.6.17-1) unstable; urgency=low
* Ack NMU, thankyou for your work on this package.
* New upstream release, rename to libupnp6 for upstream's soname bump.
(LP: #855339, LP: #648506).  Now includes IPv6 support.
* Update from upstream git to get reinstated UpnpSetVirtualDirCallbacks API.
* Remove all patches that are now in upstream.
* Update remaining patches (01,07,12) for new upstream coding standards.
* Remove fixed-length URLs from upnpapi (patch 18, Closes: #353169).
* Update to debhelper v9 to get multi-arch and build-hardening in dh.
* Update to Policy 3.9.3, and note that we are "discouraged" from
shipping three libraries in this package but live with it for now.
* Convert to multiarch.
* libupnp-dev metapackage is now Arch: all.
* Override lintian about versioned Conflicts and dupe files in docs.
* Update debian/copyright to DEP-5 v1.0.
* Generate up-to-date docs for the current API and ship a -doc package.
2011-06-25 - Luk Claes <luk@debian.org>
libupnp (1:1.6.6-5.1) unstable; urgency=low
* Non-maintainer upload.
* Don't ship .la files (Closes: #622520).
2010-05-14 - Nick Leverton <nick@leverton.org>
libupnp (1:1.6.6-5) unstable; urgency=low
* Fixes to BSD build issues (Closes: #573319, FTBFS on Gnu/kFreeBSD)
* We no longer Build-Depend on dbs anyway (Closes: #576068)
* More debug tidying (07-neaten-debug.patch):
- send UPNP_CRITICAL msgs to the info log as well as to the error log.
- don't print HTTP headers to stdout as they're already in logfile.
* Always compile in logging code but don't log unless requested
(12-debian-always-debug.patch) to help porting other apps.
* Cherry-pick some upstream bug fixes:
- soap_request_and_response http_request parameter error from r486
- "reuseaddr" patch from issue 2995758 backported from r548
- threadpool hang when busy from r515
- memory leak in SSDP AdvertiseAndReply from issue 2392304, r518
* Add $PTHREAD_CFLAGS to libupnp.pc as assumed by {acx,ax}_pthread.m4
(patch 16, Closes: #555386).

See Also

Package Description
libupnp-java-doc_1.0.4+triplea-1_all.deb Java library for Universal Plug aNd Play (upnp) - doc
libupnp-java_1.0.4+triplea-1_all.deb Java library for Universal Plug aNd Play (upnp)
libupnp6-dev_1.6.19+git20141001-1+deb8u1_i386.deb Portable SDK for UPnP Devices, version 1.6 (development files)
libupnp6-doc_1.6.19+git20141001-1+deb8u1_all.deb Documentation for the Portable SDK for UPnP Devices, version 1.6
libupnp6_1.6.19+git20141001-1+deb8u1_i386.deb Portable SDK for UPnP Devices, version 1.6 (shared libraries)
libupower-glib-dev_0.99.1-3.2_i386.deb abstraction for power management - development files
libupower-glib3_0.99.1-3.2_i386.deb abstraction for power management - shared library
libups-nut-perl_2.7.2-4_all.deb network UPS tools - Perl bindings for NUT server
libupsclient-dev_2.7.2-4_i386.deb network UPS tools - development files
libupsclient4_2.7.2-4_i386.deb network UPS tools - client library
libupse-dev_1.0.0-2_i386.deb unix playstation sound emulator - library development files
libupse2_1.0.0-2_i386.deb unix playstation sound emulator - library
libupstart-dev_1.11-5_i386.deb Upstart Client Library (development files)
libupstart1_1.11-5_i386.deb Upstart Client Library
libuptimed-dev_0.3.17-4_i386.deb utility to track high uptimes - development files
Advertisement
Advertisement