libsys-syscall-perl_0.25-2+deb8u1_all.deb


Advertisement

Description

libsys-syscall-perl - module to access system calls that Perl doesn't normally provide access to

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libsys-syscall-perl
Package version 0.25
Package release 2+deb8u1
Package architecture all
Package type deb
Installed size 58 B
Download size 10.08 KB
Official Mirror ftp.br.debian.org
Sys::Syscall allows one to use epoll and sendfile system calls from
Perl.  Support is mostly Linux-only for now, but other syscalls/OSes
are planned for the future.

Alternatives

Package Version Architecture Repository
libsys-syscall-perl_0.25-2+deb8u1_all.deb 0.25 all Debian Main
libsys-syscall-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libsys-syscall-perl_0.25-2+deb8u1_all.deb
Source Package libsys-syscall-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsys-syscall-perl deb package:
    # sudo apt-get install libsys-syscall-perl

Files

Path
/usr/share/doc/libsys-syscall-perl/changelog.Debian.gz
/usr/share/doc/libsys-syscall-perl/changelog.gz
/usr/share/doc/libsys-syscall-perl/copyright
/usr/share/man/man3/Sys::Syscall.3pm.gz
/usr/share/perl5/Sys/Syscall.pm

Changelog

2017-06-28 - gregor herrmann <gregoa@debian.org>
libsys-syscall-perl (0.25-2+deb8u1) jessie; urgency=medium
* Add patches (from -3, -4, and -6) to support more architectures.
aarch64.patch, hppa.patch, mips.patch, ppc64le.patch, s390x.patch.
(Closes: #824843, #824936, #826136)
2014-09-04 - gregor herrmann <gregoa@debian.org>
libsys-syscall-perl (0.25-2) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add patch 0001-restore-missing-changes-from-0.20.0.22.patch.
Between the 0.23 and 0.25 releases, changes from the 0.20..0.22 releases
were somehow lost. This patch restores them again.
Thanks to Eric Wong for reporting the issue and providing the patch.
(Closes: #760336)
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.5.
2013-09-20 - Florian Schlichting <fsfs@debian.org>
libsys-syscall-perl (0.25-1) unstable; urgency=low
[ Fabrizio Regalli ]
* Add myself to Uploaders and Copyright.
* Switch d/compat to 8.
* Build-Depends: switch to debhelper (>= 8).
* Fixed lintian copyright-refers-to-symlink-license message.
* Fixed lintian spelling-error-in-description message.
* Fixed lintian extended-description-is-probably-too-short message.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Florian Schlichting ]
* Import Upstream version 0.25
* Update upstream copyright stanza
* Delete "GNU/Linux" from license paragraphs
* Bump Standards-Version to 3.9.4 (no change)
* Reword long description
* Add myself to uploaders and copyright
2010-05-24 - gregor herrmann <gregoa@debian.org>
libsys-syscall-perl (0.23-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Italo Valcy ]
* New upstream release
[ gregor herrmann ]
* Convert to source format 3.0 (quilt).
* Add /me to Uploaders.
* Set Standards-Version to 3.8.4; drop version from perl build dependency.
* Switch to debhelper 7
* Reformat debian/copyright according to DEP5.
* Improve short and long description.
* Don't install the new README.pod.
2008-01-26 - Roberto C. Sanchez <roberto@debian.org>
libsys-syscall-perl (0.22-3) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Removed: XS-
Vcs-Svn fields.
* debian/rules: delete /usr/lib/perl5 only if it exists.
[ Rene Mayorga ]
* Prepare for Perl 5.10 update
* debian/control
+ Wrap Uploaders field
+ Set Standards-version to 3.7.3 ( no changes needed )
+ Raise debhelper B-D to 6
* debian/rules
+ Remove OPTIMIZE, we're not using it
+ move test suite from install-stamp to build-stamp
+ use $@ when touching -stamp files
+ remove unussed dh_ calls
* improve debian/watch
2006-12-16 - gregor herrmann <gregor+debian@comodo.priv.at>
libsys-syscall-perl (0.22-2) unstable; urgency=medium
* Add netbase to Build-Depends-Indep (closes: #403320).
* Set urgency to medium because this fixes an RC bug.
2006-12-05 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libsys-syscall-perl (0.22-1) unstable; urgency=low
* New upstream release (closes: #401708)
2006-08-26 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libsys-syscall-perl (0.21-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
libsys-syslog-perl_0.33-1+deb8u1_i386.deb Perl interface to the UNIX syslog(3) calls
libsys-utmp-perl_1.7-1+b1_i386.deb perl module to query UTMP files
libsys-virt-perl_1.2.9-2_i386.deb Perl module providing an extension for the libvirt library
libsysactivity-dev_0.6.5-2_i386.deb Retrieves statistics of the system's activity (development headers)
libsysactivity-doc_0.6.5-2_all.deb Retrieves statistics of the system's activity (development doc)
libsysactivity1_0.6.5-2_i386.deb Retrieves statistics of the system's activity
libsysadm-install-perl_0.44-1_all.deb module for typical installation tasks of system administrators
libsysfs-dev_2.1.0+repack-4_i386.deb interface library to sysfs - development files
libsysfs2_2.1.0+repack-4_i386.deb interface library to sysfs
libsyslog-ocaml-dev_1.4-6+b3_i386.deb syslog routines for OCaml (development files)
libsyslog-ocaml_1.4-6+b3_i386.deb syslog routines for OCaml (runtime)
libsystem-command-perl_1.110-1_all.deb Perl class for running system commands
libsystemd-daemon-dev_215-17+deb8u7_i386.deb systemd utility library (transitional package)
libsystemd-daemon0_215-17+deb8u7_i386.deb systemd utility library (deprecated)
libsystemd-dev_215-17+deb8u7_i386.deb systemd utility library - development files
Advertisement
Advertisement