libsoup-gnome2.4-1_2.48.0-1+deb8u1_i386.deb


Advertisement

Description

libsoup-gnome2.4-1 - HTTP library implementation in C -- GNOME support library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libsoup-gnome2.4-1
Package version 2.48.0
Package release 1+deb8u1
Package architecture i386
Package type deb
Installed size 63 B
Download size 56.20 KB
Official Mirror ftp.br.debian.org
It was originally part of a SOAP (Simple Object Access Protocol)
implementation called Soup, but the SOAP and non-SOAP parts have now been
split into separate packages.
libsoup uses the Glib main loop and is designed to work well with GTK+
applications.  This enables GNOME applications to access HTTP servers
on the network in a completely asynchronous fashion, very similar to
the GTK+ programming model (a synchronous operation mode is also
supported for those who want it).
The GNOME support library is used for features which are important to
GNOME apps, but which require GNOME-specific libraries that non-GNOME
apps may not want to add dependencies on.
Features:
* Both asynchronous (GMainLoop and callback-based) and synchronous APIs
* Automatically caches connections
* SSL Support using GnuTLS
* Proxy support, including authentication and SSL tunneling
* Client support for Digest, NTLM, and Basic authentication
* Server support for Digest and Basic authentication
* Basic client-side SOAP and XML-RPC support
This package contains the GNOME support shared library.

Alternatives

Package Version Architecture Repository
libsoup-gnome2.4-1_2.48.0-1+deb8u1_amd64.deb 2.48.0 amd64 Debian Main
libsoup-gnome2.4-1 - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.39.90
libsoup2.4-1 >= 2.41.90
libsqlite3-0 >= 3.5.9
libxml2 >= 2.6.27
multiarch-support -

Download

Type URL
Binary Package libsoup-gnome2.4-1_2.48.0-1+deb8u1_i386.deb
Source Package libsoup2.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsoup-gnome2.4-1 deb package:
    # sudo apt-get install libsoup-gnome2.4-1

Files

Path
/usr/lib/i386-linux-gnu/libsoup-gnome-2.4.so.1
/usr/lib/i386-linux-gnu/libsoup-gnome-2.4.so.1.7.0
/usr/share/doc/libsoup-gnome2.4-1/AUTHORS
/usr/share/doc/libsoup-gnome2.4-1/NEWS.gz
/usr/share/doc/libsoup-gnome2.4-1/README
/usr/share/doc/libsoup-gnome2.4-1/changelog.Debian.gz
/usr/share/doc/libsoup-gnome2.4-1/copyright

Changelog

2017-08-09 - Salvatore Bonaccorso <carnil@debian.org>
libsoup2.4 (2.48.0-1+deb8u1) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* Fix chunked decoding buffer overrun (CVE-2017-2885)
2014-09-23 - Andreas Henriksson <andreas@fatal.se>
libsoup2.4 (2.48.0-1) unstable; urgency=medium
* New upstream release.
2014-09-05 - Sjoerd Simons <sjoerd@debian.org>
libsoup2.4 (2.47.4-1) experimental; urgency=medium
* New upstream release
2014-04-02 - Emilio Pozuelo Monfort <pochu@debian.org>
libsoup2.4 (2.46.0-2) unstable; urgency=medium
* Upload to unstable.
2014-03-24 - Andreas Henriksson <andreas@fatal.se>
libsoup2.4 (2.46.0-1) experimental; urgency=medium
* New upstream release.
2014-02-20 - Emilio Pozuelo Monfort <pochu@debian.org>
libsoup2.4 (2.45.90-1) experimental; urgency=medium
* New upstream development release.
* debian/control.in:
+ Bump glib b-d to 2.39.90, needed for the test suite now that it has
switch to the TAP driver.
* debian/patches/01_tests_debug_output.patch:
+ Dropped, the extra debug output confused the TAP driver and makes it
think some tests fail.
2014-02-16 - Emilio Pozuelo Monfort <pochu@debian.org>
libsoup2.4 (2.45.3-1) experimental; urgency=medium
* New upstream development release.
* debian/control.in:
+ Standards-Version is 3.9.5, no changes needed.
2013-12-02 - Andreas Henriksson <andreas@fatal.se>
libsoup2.4 (2.44.2-1) unstable; urgency=low
* New upstream release. (Closes: #731107)
2013-10-17 - Andreas Henriksson <andreas@fatal.se>
libsoup2.4 (2.44.1-1) unstable; urgency=low
* New upstream release
* Drop patches crippling test-cases which has now been fixed upstream:
- 11-cache-test.patch
- 12-timeout-test.patch
* Update debian/libsoup2.4-1.symbols with 4 added symbols
2013-06-20 - Emilio Pozuelo Monfort <pochu@debian.org>
libsoup2.4 (2.42.2-6) unstable; urgency=low
* debian/rules:
+ Temporarily disable the test suite on !linux as one test hangs there.

See Also

Package Description
libsoup-gnome2.4-dev_2.48.0-1+deb8u1_i386.deb HTTP library implementation in C -- GNOME support development files
libsoup2.4-1_2.48.0-1+deb8u1_i386.deb HTTP library implementation in C -- Shared library
libsoup2.4-dev_2.48.0-1+deb8u1_i386.deb HTTP library implementation in C -- Development files
libsoup2.4-doc_2.48.0-1+deb8u1_all.deb HTTP library implementation in C -- API Reference
libsource-highlight-common_3.1.7-1_all.deb architecture-independent files for source highlighting library
libsource-highlight-dev_3.1.7-1+b1_i386.deb development files for source highlighting library
libsource-highlight4_3.1.7-1+b1_i386.deb source highlighting library
libsox-dev_14.4.1-5_i386.deb Development files for the SoX library
libsox-fmt-all_14.4.1-5_i386.deb All SoX format libraries
libsox-fmt-alsa_14.4.1-5_i386.deb SoX alsa format I/O library
libsox-fmt-ao_14.4.1-5_i386.deb SoX Libao format I/O library
libsox-fmt-base_14.4.1-5_i386.deb Minimal set of SoX format libraries
libsox-fmt-mp3_14.4.1-5_i386.deb SoX MP2 and MP3 format library
libsox-fmt-oss_14.4.1-5_i386.deb SoX OSS format I/O library
libsox-fmt-pulse_14.4.1-5_i386.deb SoX PulseAudio format I/O library
Advertisement
Advertisement