libservlet2.5-java_6.0.45+dfsg-1~deb8u1_all.deb


Advertisement

Description

libservlet2.5-java - Servlet 2.5 and JSP 2.1 Java API classes

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename libservlet2.5-java_6.0.45+dfsg-1~deb8u1_all.deb
Package name libservlet2.5-java
Package version 6.0.45+dfsg
Package release 1~deb8u1
Package architecture all
Package type deb
Category devel::lang:java devel::library devel::web implemented-in::java java protocol::http role::devel-lib role::shared-lib
Homepage http://tomcat.apache.org
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 214.95 KB
Installed size 352.00 KB
Apache Tomcat implements the Java Servlet and the JavaServer Pages (JSP)
specifications from Sun Microsystems, and provides a "pure Java" HTTP web
server environment for Java code to run.
This package contains the Java Servlet and JSP library.

Alternatives

Package Version Architecture Repository
libservlet2.5-java_6.0.45+dfsg-1~deb8u1_all.deb 6.0.45+dfsg all Debian Main
libservlet2.5-java - - -

Conflicts

Name Value
libservlet2.4-java <= 5.5.33-1

Replaces

Name Value
libservlet2.4-java <= 5.5.33-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libservlet2.5-java_6.0.45+dfsg-1~deb8u1_all.deb
Source Package tomcat6

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libservlet2.5-java deb package:
    # sudo apt-get install libservlet2.5-java

Files

Path
/usr/share/doc/libservlet2.5-java/README.Debian.gz
/usr/share/doc/libservlet2.5-java/changelog.Debian.gz
/usr/share/doc/libservlet2.5-java/copyright
/usr/share/java/el-api-2.1.jar
/usr/share/java/jsp-api-2.1.jar
/usr/share/java/servlet-api-2.5.jar
/usr/share/maven-repo/javax/el/el-api/2.1/el-api-2.1.jar
/usr/share/maven-repo/javax/el/el-api/2.1/el-api-2.1.pom
/usr/share/maven-repo/javax/el/el-api/debian/el-api-debian.jar
/usr/share/maven-repo/javax/el/el-api/debian/el-api-debian.pom
/usr/share/maven-repo/javax/servlet/jsp/jsp-api/2.1/jsp-api-2.1.jar
/usr/share/maven-repo/javax/servlet/jsp/jsp-api/2.1/jsp-api-2.1.pom
/usr/share/maven-repo/javax/servlet/jsp/jsp-api/debian/jsp-api-debian.jar
/usr/share/maven-repo/javax/servlet/jsp/jsp-api/debian/jsp-api-debian.pom
/usr/share/maven-repo/javax/servlet/servlet-api/2.5/servlet-api-2.5.jar
/usr/share/maven-repo/javax/servlet/servlet-api/2.5/servlet-api-2.5.pom
/usr/share/maven-repo/javax/servlet/servlet-api/debian/servlet-api-debian.jar
/usr/share/maven-repo/javax/servlet/servlet-api/debian/servlet-api-debian.pom

Changelog

2016-04-01 - Markus Koschany <apo@debian.org>
tomcat6 (6.0.45+dfsg-1~deb8u1) jessie-security; urgency=high
* Imported Upstream version 6.0.45+dfsg.
Fixes all current known security vulnerabilities in the source package.
Users were not directly affected since we only build the servlet API and
documentation. This update simplifies upgrades from Wheezy.
2014-10-22 - Emmanuel Bourg <ebourg@apache.org>
tomcat6 (6.0.41-3) unstable; urgency=medium
* Build only the libservlet2.5-java and libservlet2.5-java-doc packages.
Tomcat 6 will not be supported in Jessie, but the Servlet API is still
useful as a build dependency for other packages.
* Standards-Version updated to 3.9.6 (no changes)
2014-08-24 - tony mancill <tmancill@debian.org>
tomcat6 (6.0.41-2) unstable; urgency=medium
[ Emmanuel Bourg ]
* Updated the version required for libtcnative-1 (>= 1.1.30)
[ tony mancill ]
* Add patch for logfile compression. (Closes: #682955)
- Thank you to Thijs Kinkhorst.
2014-05-22 - Emmanuel Bourg <ebourg@apache.org>
tomcat6 (6.0.41-1) unstable; urgency=medium
* New upstream release.
- Refreshed the patches
2014-02-17 - Emmanuel Bourg <ebourg@apache.org>
tomcat6 (6.0.39-1) unstable; urgency=medium
* Team upload.
* New upstream release.
- Refreshed the patches
* Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
* Use XZ compression for the upstream tarball
* Use canonical URL for the Vcs-Git field
2013-08-03 - tony mancill <tmancill@debian.org>
tomcat6 (6.0.37-1) unstable; urgency=low
* New upstream release.
- Drop patches for CVE-2012-4534, CVE-2012-4431, CVE-2012-3546,
CVE-2012-2733, CVE-2012-3439
- Drop 0011-CVE-02012-0022-regression-fix.patch
- Drop 0017-eclipse-compiler-update.patch
* Freshened remaining patches.
2013-07-30 - Stephen Nelson <stephen@eccostudio.com>
tomcat6 (6.0.35-7) unstable; urgency=low
* Team upload.
* Fixed the watch file
* Fix FTBFS with ecj 3.8 (closes: #717279, #713796) 
* Updated the standards version to 3.9.4 - no changes
* Updated the Vcs-Git field to the canonical url
2012-12-06 - tony mancill <tmancill@debian.org>
tomcat6 (6.0.35-6) unstable; urgency=high
* Acknowledge NMU: 6.0.35-5+nmu1 (Closes: #692440)
- Thank you to Michael Gilbert.
* Add patches for the following security issues: (Closes: #695250)
- CVE-2012-4534, CVE-2012-4431, CVE-2012-3546
2012-11-17 - Michael Gilbert <mgilbert@debian.org>
tomcat6 (6.0.35-5+nmu1) unstable; urgency=high
* Non-maintainer upload.
* Fix multiple security issues (closes: #692440)
- cve-2012-2733: denial-of-service by triggering out of memory error.
- cve-2012-3439: multiple replay attack issues in digest authentication. 
2012-08-06 - tony mancill <tmancill@debian.org>
tomcat6 (6.0.35-5) unstable; urgency=low
* Apply patch to README.Debian to explain setting the HTTPOnly flag
in cookies by default; CVE-2010-4312. (Closes: #608286)
- Thank you to Thijs Kinkhorst for the patch.
* Use ucf and a template for /etc/logrotate.d/tomcat6 file to avoid
updating the shipped conffile. (Closes: #687818)

See Also

Package Description
libservlet3.0-java-doc_7.0.56-3+deb8u11_all.deb Servlet 3.0 and JSP 2.2 Java API documentation
libservlet3.0-java_7.0.56-3+deb8u11_all.deb Servlet 3.0 and JSP 2.2 Java API classes
libservlet3.1-java-doc_8.0.14-1+deb8u11_all.deb Servlet 3.1, JSP 2.3, EL 3.0 and WebSocket 1.0 Java API documentation
libservlet3.1-java_8.0.14-1+deb8u11_all.deb Servlet 3.1, JSP 2.3, EL 3.0 and WebSocket 1.0 Java API classes
libsession-storage-secure-perl_0.010-1_all.deb module implementing a secure way to encode session data
libset-crontab-perl_1.02-1_all.deb Expand crontab-style integer lists
libset-infinite-perl_0.63-1_all.deb Sets of intervals
libset-intspan-perl_1.19-1_all.deb module to manage sets of integers
libset-nestedgroups-perl_0.01-2_all.deb Simple implementation of nested groups
libset-object-perl_1.34-2+b1_i386.deb collection of objects without duplications
libset-scalar-perl_1.29-1_all.deb Perl interface for operations on finite sets
libset-tiny-perl_0.02-1_all.deb Simple sets of strings
libsetools-java_3.3.8-3.1_all.deb SETools Java bindings (architecture-independent)
libsetools-jni_3.3.8-3.1_i386.deb SETools Java bindings (architecture-dependent)
libsetools-tcl_3.3.8-3.1_i386.deb SETools Tcl bindings
Advertisement
Advertisement