libpurple-dev_2.11.0-0+deb8u2_all.deb


Advertisement

Description

libpurple-dev - multi-protocol instant messaging library - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package filename libpurple-dev_2.11.0-0+deb8u2_all.deb
Package name libpurple-dev
Package version 2.11.0
Package release 0+deb8u2
Package architecture all
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://www.pidgin.im
License -
Maintainer Ari Pollak <ari@debian.org>
Download size 251.32 KB
Installed size 1.08 MB
This package contains the headers and other development files not included in
the main libpurple0 package. Install this if you wish to compile your own
client-agnostic plugins, or would like to compile programs that use
libpurple.

Alternatives

Package Version Architecture Repository
libpurple-dev_2.11.0-0+deb8u2_all.deb 2.11.0 all Debian Main
libpurple-dev - - -

Requires

Name Value
libdbus-glib-1-dev -
libglib2.0-dev -
libpurple0 >= 2.11.0
libpurple0 << 2.11.0+1~
pkg-config -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpurple-dev_2.11.0-0+deb8u2_all.deb
Source Package pidgin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpurple-dev deb package:
    # sudo apt-get install libpurple-dev

Files

Path
/usr/include/libpurple/account.h
/usr/include/libpurple/accountopt.h
/usr/include/libpurple/blist.h
/usr/include/libpurple/buddyicon.h
/usr/include/libpurple/certificate.h
/usr/include/libpurple/cipher.h
/usr/include/libpurple/circbuffer.h
/usr/include/libpurple/cmds.h
/usr/include/libpurple/connection.h
/usr/include/libpurple/conversation.h
/usr/include/libpurple/core.h
/usr/include/libpurple/dbus-bindings.h
/usr/include/libpurple/dbus-define-api.h
/usr/include/libpurple/dbus-maybe.h
/usr/include/libpurple/dbus-purple.h
/usr/include/libpurple/dbus-server.h
/usr/include/libpurple/dbus-types.h
/usr/include/libpurple/dbus-useful.h
/usr/include/libpurple/debug.h
/usr/include/libpurple/desktopitem.h
/usr/include/libpurple/dnsquery.h
/usr/include/libpurple/dnssrv.h
/usr/include/libpurple/eventloop.h
/usr/include/libpurple/ft.h
/usr/include/libpurple/gaim-compat.h
/usr/include/libpurple/idle.h
/usr/include/libpurple/imgstore.h
/usr/include/libpurple/log.h
/usr/include/libpurple/marshallers.h
/usr/include/libpurple/media-gst.h
/usr/include/libpurple/media.h
/usr/include/libpurple/mediamanager.h
/usr/include/libpurple/mime.h
/usr/include/libpurple/nat-pmp.h
/usr/include/libpurple/network.h
/usr/include/libpurple/notify.h
/usr/include/libpurple/ntlm.h
/usr/include/libpurple/plugin.h
/usr/include/libpurple/pluginpref.h
/usr/include/libpurple/pounce.h
/usr/include/libpurple/prefs.h
/usr/include/libpurple/privacy.h
/usr/include/libpurple/proxy.h
/usr/include/libpurple/prpl.h
/usr/include/libpurple/purple.h
/usr/include/libpurple/request.h
/usr/include/libpurple/roomlist.h
/usr/include/libpurple/savedstatuses.h
/usr/include/libpurple/server.h
/usr/include/libpurple/signals.h
/usr/include/libpurple/smiley.h
/usr/include/libpurple/sound-theme-loader.h
/usr/include/libpurple/sound-theme.h
/usr/include/libpurple/sound.h
/usr/include/libpurple/sslconn.h
/usr/include/libpurple/status.h
/usr/include/libpurple/stringref.h
/usr/include/libpurple/stun.h
/usr/include/libpurple/theme-loader.h
/usr/include/libpurple/theme-manager.h
/usr/include/libpurple/theme.h
/usr/include/libpurple/upnp.h
/usr/include/libpurple/util.h
/usr/include/libpurple/value.h
/usr/include/libpurple/version.h
/usr/include/libpurple/whiteboard.h
/usr/include/libpurple/xmlnode.h
/usr/include/libpurple/media/backend-iface.h
/usr/include/libpurple/media/candidate.h
/usr/include/libpurple/media/codec.h
/usr/include/libpurple/media/enum-types.h
/usr/lib/libpurple-client.so
/usr/lib/libpurple.so
/usr/lib/pkgconfig/purple.pc
/usr/share/aclocal/purple.m4
/usr/share/doc/libpurple-dev/changelog.Debian.gz
/usr/share/doc/libpurple-dev/changelog.gz
/usr/share/doc/libpurple-dev/copyright

Changelog

2017-03-04 - Luciano Bello <luciano@debian.org>
pidgin (2.11.0-0+deb8u2) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* CVE-2017-2640: Out-of-bound memory access fixed by ported upstream
patch from 2.12.0
2016-07-14 - Salvatore Bonaccorso <carnil@debian.org>
pidgin (2.11.0-0+deb8u1) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* Imported Upstream version 2.11.0 to fix security issues:
- CVE-2016-4323 CVE-2016-2380 CVE-2016-2378 CVE-2016-2377 CVE-2016-2376
CVE-2016-2375 CVE-2016-2374 CVE-2016-2373 CVE-2016-2372 CVE-2016-2371
CVE-2016-2370 CVE-2016-2369 CVE-2016-2368 CVE-2016-2367 CVE-2016-2366
CVE-2016-2365
* Update libpurple0.symbols for 2.10.12 and 2.11.0
2014-11-24 - Ari Pollak <ari@debian.org>
pidgin (2.10.11-1) unstable; urgency=low
* Recommend gstreamer0.10-alsa and gstreamer0.10-ffmpeg for voice/video calls
* Imported Upstream version 2.10.11
2014-11-14 - John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
pidgin (2.10.10-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add debian/patches/0001-update-msn-application-id.patch to update the
MSN_APPLICATION_ID sent when signing in to MSN (Closes: #769491).
2014-10-16 - Ari Pollak <ari@debian.org>
pidgin (2.10.10-1) unstable; urgency=high
* Imported Upstream version 2.10.10
* Fixes security issues: CVE-2014-3694, CVE-2014-3695, CVE-2014-3696,
CVE-2014-3697, CVE-2014-3698
* Update debian/watch to check upstream signature (Closes: #764768)
* Build with system libgadu
2014-02-03 - Ari Pollak <ari@debian.org>
pidgin (2.10.9-1) unstable; urgency=medium
* Imported Upstream version 2.10.9
- Fixes XMPP connection problem (Closes: #737509)
2014-01-25 - Ari Pollak <ari@debian.org>
pidgin (2.10.8-1) unstable; urgency=high
* Imported Upstream version 2.10.8
- Fixes many security issues: CVE-2012-6152, CVE-2013-6477,
CVE-2013-6478, CVE-2013-6479, CVE-2013-6481, CVE-2013-6482,
CVE-2013-6483, CVE-2013-6484, CVE-2013-6485, CVE-2013-6486,
CVE-2013-6487, CVE-2013-6489, CVE-2013-6490, and CVE-2014-0020.
- Fixes undefined conversion from double to enum (Closes: #701671)
* Imported Upstream version 2.10.8
2013-02-24 - Ari Pollak <ari@debian.org>
pidgin (2.10.7-2) unstable; urgency=low
* Fix IRC protocol loading by linking with SASL (Closes: #701541)
* Apply patch from upstream to fix crash in Contact Availability Plugin
(Closes: #701544)
2013-02-23 - Ari Pollak <ari@debian.org>
pidgin (2.10.7-1) unstable; urgency=low
* Imported Upstream version 2.10.7
* Move libpurple0 to section devel, to reflect #700141
2013-02-11 - Ari Pollak <ari@debian.org>
pidgin (2.10.6-3) unstable; urgency=high
* Apply patches from 2.10.7 to fix CVE-2013-0271, CVE-2013-0272,
CVE-2013-0273, and CVE-2013-0274

See Also

Package Description
libpurple0_2.11.0-0+deb8u2_i386.deb multi-protocol instant messaging library
libpuzzle-bin_0.9-6+b1_i386.deb quick similar image finder - runtime tool
libpuzzle-dev_0.9-6+b1_i386.deb quick similar image finder - development files
libpuzzle-php_0.9-6+b1_i386.deb quick similar image finder - PHP bindings
libpuzzle1_0.9-6+b1_i386.deb quick similar image finder - shared library
libpvm3_3.4.5-12.6_i386.deb Parallel Virtual Machine - shared libraries
libpwiz-dev_3.0.6585-2_i386.deb library to perform proteomics data analyses (devel files)
libpwiz-doc_3.0.6585-2_all.deb set of programs to perform proteomics data analyses (doc)
libpwiz-tools_3.0.6585-2_i386.deb ProteoWizard command line tools
libpwiz3_3.0.6585-2_i386.deb library to perform proteomics data analyses (runtime)
libpwquality-common_1.2.3-1_all.deb library for password quality checking and generation (data files)
libpwquality-dev_1.2.3-1_i386.deb Password quality checking and generation (development files)
libpwquality-tools_1.2.3-1_i386.deb tools for password quality checking and generation
libpwquality1_1.2.3-1_i386.deb library for password quality checking and generation
libpxp-ocaml-dev_1.2.4-1+b1_i386.deb OCaml library that implements an XML-1.0 validating parser
Advertisement
Advertisement